ICHSMB(4) BSD Kernel Interfaces Manual ICHSMB(4)
ichsmb -- Intel ICH SMBus controller
ichsmb* at pci?
iic* at ichsmb?
The ichsmb driver provides support for the Intel ICH SMBus host interface to be used with
the iic(4) framework.
o Intel ICH, ICH2, ICH3, ICH4, ICH4-M, ICH5, ICH5R, ICH6, ICH6-M, ICH6R, ICH7, ICH8,
ICH9, ICH10, C-ICH, 6300ESB and 6321ESB.
iic(4), intro(4), pci(4)
The ichsmb driver first appeared in OpenBSD 4.0. This driver imports from OpenBSD 3.9.
The ichsmb driver was written by Alexander Yurchenko <email@example.com>.
The driver doesn't support I2C commands with a data buffer size of more than 2 bytes.
BSD July 30, 2010 BSD