CISS(4) BSD Kernel Interfaces Manual CISS(4)
ciss -- HP/Compaq Smart ARRAY 5/6 RAID controllers
ciss* at pci? function ?
The ciss driver provides support for the CISS interface implemented by fifth and later gen-
erations of the HP/Compaq Smart ARRAY family of controllers.
The CISS interface is defined in the document entitled CISS Command Interface for SCSI-3
Support Open Specification, Version 1.04, Valence Number 1, Compaq Computer Corporation,
This driver supports several Compaq and HP controllers implementing the CISS interface,
o Compaq Smart Array 5300 version 1
o Compaq Smart Array 5300 version 2
o Compaq Smart Array 5i version 1
o Compaq Smart Array 5i version 2
o HP Smart Array 5312
o HP Smart Array 6i
o HP Smart Array 641
o HP Smart Array 642
o HP Smart Array 6400
o HP Smart Array 6400 EM
o HP Smart Array E200
o HP Smart Array E200i
o HP Smart Array P400
o HP Smart Array P400i
o HP Smart Array P600
o HP Smart Array P800
o HP Smart Array V100
o HP Smart Array 1 through 13
These controllers support RAID 0, RAID 1, RAID 5, JBOD, and superpositions of those configu-
Although the controllers are actual RAID controllers, the ciss driver makes them look just
like SCSI controllers. All RAID configuration must be done through the controllers' BIOSes.
Hardware from previous generations of this product family may be supported by the cac(4)
bio(4), cac(4), intro(4), pci(4), scsi(4), sd(4)
The ciss driver first appeared in NetBSD 3.1.
The ciss driver was written by Michael Shalayeff <email@example.com>, and ported to NetBSD
by Tonnerre Lombard <firstname.lastname@example.org>.
BSD May 28, 2008 BSD