BE(4) BSD Kernel Interfaces Manual BE(4)NAME
be -- SPARC Fast Ethernet interface
qec* at sbus? slot ? offset ?
be* at qec?
The be interface provides access to the 10Mb/s and 100Mb/s (half duplex only) Ethernet networks. The be is found on the Sun 10/100 Mbit Eth-
ernet boards (Sun part number SUNW,501-2450).
Each of the host's network addresses is specified at boot time with an SIOCSIFADDR ioctl(2). The be interface employs the address resolution
protocol described in arp(4) to dynamically map between Internet and Ethernet addresses on the local network.
The be is not capable of link autonegotiation, so a media type must be specified with ifconfig(8). The supported media types are:
Use 100Mbps, half duplex
Use 10Mbps, half duplex
SEE ALSO arp(4), ifmedia(4), inet(4), intro(4), netintro(4), sbus(4), ifconfig(8)HISTORY
Support for the be first appeared in NetBSD 1.4.
BSD March 31, 2004 BSD
Check Out this Related Man Page
TXP(4) BSD Kernel Interfaces Manual TXP(4)NAME
txp -- 3Com 3XP Typhoon/Sidewinder (3CR990) Ethernet interface
To compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The txp interface provides access to the 10Mb/s and 100Mb/s Ethernet networks via the 3Com Typhoon/Sidewinder chipset.
Basic Ethernet functions are provided as well as support for vlan(4) tag removal and insertion assistance, receive ip(4), tcp(4), and udp(4)
checksum offloading, and transmit ip(4) checksum offloading. There is currently no support for transmit tcp(4) or udp(4) checksum offload-
ing, tcp(4) segmentation, nor ipsec(4) acceleration.
Each of the host's network addresses is specified at boot time with an SIOCSIFADDR ioctl(2). The txp interface employs the address resolu-
tion protocol described in arp(4) to dynamically map between Internet and Ethernet addresses on the local network.
When a txp interface is brought up, by default, it will attempt to auto-negotiate the link speed and duplex mode. The speeds, in order of
attempt, are: 100Mb/s Full Duplex, 100Mb/s Half Duplex, 10 Mb/s Full Duplex, and 10 Mb/s Half Duplex.
The txp supports several media types, which are selected via the ifconfig(8) command. The supported media types are:
Attempt to autoselect the media type (default)
media 100baseTX mediaopt full-duplex
Use 100baseTX, full duplex
media 100baseTX [mediaopt half-duplex]
Use 100baseTX, half duplex
media 10baseT mediaopt full-duplex
Use 10baseT, full duplex
media 10baseT [mediaopt half-duplex]
Use 10baseT, half duplex
The txp driver supports the following cards:
o 3Com 3CR990-TX-95
o 3Com 3CR990-TX-97
o 3Com 3cR990B-TXM
o 3Com 3CR990SVR95
o 3Com 3CR990SVR97
o 3Com 3cR990B-SRV
SEE ALSO altq(4), arp(4), inet(4), intro(4), ip(4), miibus(4), tcp(4), udp(4), vlan(4), ifconfig(8)HISTORY
The txp driver first appeared in OpenBSD 2.9.
BSD March 12, 2009 BSD
We are trying to Establish Network using Linux.Now we are facing the problem in configring Ethernet.In out network we are giving eth0 in server and activating it at the boot time,so it is activating as it is but when we define the Ethernet of node on server and allowing it to activate at boot time... (5 Replies)
i owe a HP 9000 E55 (antique...) server. I also owe the original version of the OS HPUX 11.0. Unfortenately i can't find the HP-Support Plus medium. During the instlallation i was asked to put it in, i always skip this one. But the system runs not very well. On HP's website you can... (8 Replies)
I am trying to find a command to return the "link" speed of the networks installed on AIX.
ifconfig - gives me where the link is up and the duplex setting. I need to determine for example if the ethernet connection is 10, 100, 1000 Mbs or what the current speed is based on the network media... (3 Replies)
Hi, is there a way in Solaris 8 to determine how many total NIC's say a Sun Sparc box has installed - plumbed or unplumbed - and find out its capable network speeds and MAC address?
I know ifconfig -a but that only shows the plumbed and used interfaces.
cc (2 Replies)
I was checking nettl output for a unstable telnet to my server. this is part of output:
Timestamp : Sun Jun 22 EETDST 2008 22:14:47.492899
Process ID : Subsystem ... (4 Replies)
i want to know how to grep inet address for below
below is the output of ifconfig command
eth0 Link encap:Ethernet HWaddr 00:11:0A:5B:2E:E9
inet addr:220.127.116.11 Bcast:18.104.22.168 Mask:255.255.255.128
UP BROADCAST RUNNING... (3 Replies)
Hi here is my question;
any help would be appreciated
The Linux system pokey has two Ethernet cards. The first Ethernet card is connected to a companywide
TCP/IP network covering the addresses 87.65.43.xx, where pokey's address is
22.214.171.124. The second Ethernet interface is connected to a... (2 Replies)
I have a new Sun 440 and I am trying to configure it. Non of the Ethernet ports are enabled; when I issue "ifconfig -a" it returns nothing. Is there a way to know the available port name (e.g. ce, bge, etc.) by running a command or so ? (4 Replies)
can anyone help me fix this? what command should I use to bring them back to "TRUE"?
Interface Speed Duplex Autoneg
--------- ----- ------ -------
ce0 100 Mbit/s FULL FALSE
ce5 100 Mbit/s FULL ... (3 Replies)
I have Sun SPARC Enterprise T5140 with Solaris 10 and it unable to up network interface after boot, but after issuing ifconfig interface begins to work... svcs -xv says that service svc:/network/physical:default is failed to start and service log stores something like "service method... (5 Replies)
genunix: NOTICE: ce0: xcvr addr:0x01 - link up 100 Mbps half duplex
genunix: WARNING: ce0: fault detected external to device; service degraded
genunix: WARNING: ce0: xcvr addr:0x01 - link down
genunix: NOTICE: ce0: fault cleared external to device; service available
genunix: ... (4 Replies)
I am using cntrl w f for this
But now the new file is displayed in half of the screen...and the old file in the other half...
how can ichange this default behaviour ...
say for eg:80% to 1 file and remaining 20 % to the other file.... (4 Replies)
So I have a server I am trying to set up a script to send a Wall message notifying of my eth0 nic being set to 100 half duplex instead of 100 full duplex.
I know I am trying to read from /etc/sysconfig/network/ifcfg-eth0 to pull the parameters
BOOTPROTO=static... (6 Replies)
I have been trying to connect two computers directly through their LAN cards. One is a 3com 3c905c 10/100 Mbit/s card and the other is an Intel i217-lm 10/100/1000Mbit/s card. I have connected them through a CAT 6 cable. Whenever autoneg is turned on, the PCs connect in the 10Mb/s mode, and... (7 Replies)