GROUP(5) File Formats Manual GROUP(5)NAME
group - group file
Group contains for each group the following information:
numerical group ID
a comma separated list of all users allowed in the group
This is an ASCII file. The fields are separated by colons; Each group is separated from the next by a new-line. If the password field is
null, no password is demanded.
This file resides in directory /etc. Because of the encrypted passwords, it can and does have general read permission and can be used, for
example, to map numerical group ID's to names.
SEE ALSO setgroups(2), initgroups(3X), crypt(3), passwd(1), passwd(5)BUGS
The passwd(1) command won't change the passwords.
7th Edition May 15, 1985 GROUP(5)
Check Out this Related Man Page
GROUP(5) BSD File Formats Manual GROUP(5)NAME
group -- format of the group permissions file
The file </etc/group> consists of newline separated ASCII records, one per group, containing four colon ':' separated fields. These fields
are as follows:
group Name of the group.
passwd Group's encrypted password.
gid The group's decimal ID.
member Group members.
The group field is the group name used for granting file access to users who are members of the group. The gid field is the number associ-
ated with the group name. They should both be unique across the system (and often across a group of systems) since they control file access.
The passwd field is an optional encrypted password. This field is rarely used and an asterisk is normally placed in it rather than leaving
it blank. The member field contains the names of users granted the privileges of group. The member names are separated by commas without
spaces or newlines. A user is automatically in a group if that group was specified in their /etc/passwd entry and does not need to be added
to that group in the /etc/group file.
INTERACTION WITH DIRECTORY SERVICES
Processes generally find group records using one of the getgrent(3) family of functions. On Mac OS X, these functions interact with the
DirectoryService(8) daemon, which reads the /etc/group file as well as searching other directory information services to determine groups and
SEE ALSO passwd(1), setgroups(2), crypt(3), getgrent(3), initgroups(3), passwd(5), DirectoryService(8)BUGS
The passwd(1) command does not change the group passwords.
A group file format appeared in Version 6 AT&T UNIX.
Mac OS X July 18, 1995 Mac OS X
In my cgi script(written in Perl using cgi.pm) i have a checkbox and i want all the items to be checked. Here is what i use:
checkbox_group(-name=>'studenten_in_groep', -values=>\@member_keys, -defaults=>\@member_keys, -labels=>\%temp_members, -columns=>2),
But no boxes are checked...... (18 Replies)
I have this file which has 3 columns, District , stores and unit. What I want is all rows belonging to one district to be created separately under each district, the districts may vary every day , the source file may have 3 districts today and may have 160 tomorrow, so what I need is a... (20 Replies)
I have a Fixed format data file where I need to to get the total of the field at certain position in a file for a group of lines.
In this data file I need the total of all the field ats position 30:39 for each line starting with 6 and for each group startign with 5. Which means for... (27 Replies)
I have trouble selecting record that contain one biggest value for a group of other values. I mean, this is my table:
mysql> SELECT * FROM b;
| id | user | value |
| 1 | 1 | 100 |
| 3 | 1 | 150 |
| 5 | 1 | 300 |
| 6... (20 Replies)
i have a file.txt:
Note: All the seperators are SPACE.
ParameterObject=1 Speech 1
ParameterObject=2 Speech 1
ParamFunction=1 UserID 1 (DEACTIVATED)
Sector=1,Device=2,Unit=3 DeviceId 1
FeederCable=2B ... (18 Replies)
I'm the root user on my computer, but I'm writing a script that does a lot of file handling. Every time I create a file or directory it automatically requires root privileges. Is there a way I can just create a file that the user can access without a password?
For example in my script I... (20 Replies)
We are encountering the following issue on AIX 5.3. When we do ls -ltr the list displays only user id and group id instead of user name and group name.
This is happening for all users except root. Whe we do ls -ltr with root user it shows perfectly fine.
When we searched... (25 Replies)
I have a script which called by user id (mftp) . The set up is working on two server and not working one server.
Working Server :
-rw-rw-r-- 1 mftp csp 0 Jan 17 00:14 117001.log
Non working server
-rw-rw-r-- 1 mftp mftp 0 Jan 17 00:14 117001.log
from the above... (18 Replies)