Visit Our UNIX and Linux User Community


cpio


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers cpio
# 1  
Old 06-16-2001
cpio

by mistake I deleted all the files in
/usr2/symix/users/wfpsys/tpsc/ directory.
full backup has taken yesterday using "CPIO" command and I am able to view the files from tape also using cpio command.
but i couldn't able to restore back the files. Can you please help me immeditely by giving the command to restore all the files inside tpsc directory. Please it is a urgent request. Advance thanks.
Please contact me at ::email removed::

Last edited by oombera; 02-18-2004 at 03:45 PM..
# 2  
Old 06-18-2001
cpio -icdB < [name_of_cpio_archive]

If you want a verbose listing of each file as it is extracted include the v flag. If you get a block error omit the B flag.

Hope this helps.

Regards.
alwayslearningunix
# 3  
Old 06-18-2001
Bug REG: cpio

Thank you.

I used

cpio -icvdumB "usr2/symix/users/wfpsys/tpsc/*.*" < /dev/rst5

above command restored all the files to tpsc directory from the tape drive.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #436
Difficulty: Easy
React is an open source JavaScript library.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Cpio - input files (from list) are stored in different order inside cpio archive - why?

Due to budget constraints I have to reinvent an Enterprise backup system in a SPARC (sun4v) Solaris estate (10 & 11). (yep - reinvent wheel, fun but time consuming. Is this wise?! :confused: ) For each filesystem of interest, to try to capture a 'catalog' at the front of each cpio archive (for... (1 Reply)
Discussion started by: am115998
1 Replies

2. SCO

Questions about cpio

Should 'cpio' backup only unmounted filesystems? Should a 'cpio' backup file be restored to a mounted device? Can 'cpio' interact with /dev/root, /dev/u, /dev/stand directly? (1 Reply)
Discussion started by: grips03
1 Replies

3. Debian

CPIO with Ubuntu

Hi, i am new here, and i have a question about cpio. i have a scsi traban tape drive, and i will restore some files and directories. Did anybody knows the instructions with cpio? regards Harald (1 Reply)
Discussion started by: gernsemer
1 Replies

4. UNIX and Linux Applications

CPIO Problem

Hi all, I have a trouble with CPIO: I have a file called asa802. I extract it with the following command: Then I tried to rebuild archive: Filesizes are not identical ! As I saw these messages: I tried: And messages disappears, but filesizes are still not identical Tried... (0 Replies)
Discussion started by: nekkro-kvlt
0 Replies

5. Solaris

CPIO issue

Hello, I am running Solaris and trying to install Oracle 10g. I have the software on my server and I am trying to extract the file using cpio -idmv. It seems to be taking a very long time and when I monitor it using top, it is sleeping and the cpu is 0%. Any ideas as to what may be going on... (3 Replies)
Discussion started by: dkranes
3 Replies

6. UNIX for Advanced & Expert Users

cpio versus cp

I am copying a file system to another one. someone suggest me use find . -print |cpio -pdmv but I think cp -r should do the same thing. Am I right? In addition, by using " find . ", I got all the file names,, why do I have to use the -print option? Thanks a lot! (1 Reply)
Discussion started by: fredao
1 Replies

7. AIX

cpio - files > 2 GB

Hi, Currently a backup script copies compressed files to tape using cpio command (on AIX 5.2). Recently we've had a compressed file which has gone over 2 GB in size resulting in an error while copying this file onto the tape using cpio. Any suggestions on relevant workarounds would be much... (0 Replies)
Discussion started by: dnicky
0 Replies

8. HP-UX

Please help with cpio on HP-UX

Hello all ... I am an Oracle DBA that got stuck in a HP-UX SA role and need some help figuring out a UNIX problem. According to Oracle documentation, I am to issue the following command ... cpio -idcmv <file_name> However when I do, the server just hangs there and does nothing til I... (3 Replies)
Discussion started by: soestx
3 Replies

9. UNIX for Dummies Questions & Answers

cpio

Hello, how can I restore files from a DAT using CPIO ? If I make : # mkdir save # cd /save # cpio -icumvdB </dev/rct0 Does the archive restore only in the directory /save ? And how can I restore a specified file from the DAT with the cpio command ? How can I know the size of the... (2 Replies)
Discussion started by: kok
2 Replies

10. UNIX for Dummies Questions & Answers

Help with cpio

Hi all, Please help me with the extraction of files from a cpio. what I mean is basically I have received a file from someone i.e rooh.cpio. this file rooh.cpio contains various files in it. I want to know how I can extract the files and copy them to a different directory . Your quick... (2 Replies)
Discussion started by: rooh
2 Replies

Featured Tech Videos