Visit Our UNIX and Linux User Community


cable modem to sparc


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers cable modem to sparc
# 1  
Old 10-25-2002
Bug cable modem to sparc

hi , i have sparc machine , i want to connect my le0 (ethernet interface) directly to cable modem ,
i have created a file resolv.conf,hosts, dhcp.le0,defaultrouter,nisswitch,hostname.le0. i dont know my cable companies <domain name> and <name server assigned to me> , also they even dont know how to help me with this.
so i have created a empty file resolv.conf, i think DHCP can update it. after rebooting , i get error as no carrier or cable disconnected to hub , and error in ifconfig timed out , and argument error in /usr/lib/inet/in.dhcpd -r argument.
i m unable to connect to internet using cable modem.
i hope u people can enlighten me of my mistakes here , thanx in advance.
or just tell me procedure to connect using cable modem.
raju
raju
# 2  
Old 10-25-2002
Do you need a cross-over cable between the cable modem and the machine? Are you using a straight through RJ45 cable? That might be a problem.
# 3  
Old 10-26-2002
MySQL

auswipe ,i use cable provided by cable modem company , which is crossover,
when system boots , i get following msgs or errors...
1.configuring network intefaces : le0
2.starting DHCP on primary:le0
(at this moment LED on cable modem for connection to ethernet on sparc , dosent light)
le0 cable disconected..(this comes only once)
(now LED showing sparc to ethernet connection goes on)
ifconfig timed out
....all msgs for starting..
in.rdisc: no interfaces up
setting default interfaces for multicast 224.0.0.0...
in.dhpcdSmiliebad file number: no interfaces up....

and then i log on to root , on CDE.
after loging in , i check ifconfig -a , it shows
both adapters , la0 (local loopback), and le0 but it shows le0 BROADCAST, RUNNING,MULTICAST,DHCP...it is not up(even though i set the ifconfig with earlier and did like ifconfig le0 broadcast +).and inet0.0.0.0 netmask 0 , ether hex address.
netstat -rn shows:
127.0.0.1 as destination ,127.0.0.1 as Gateway ,with UH Flags.it does not list le0 at all.
so i do , ifconfig le0 x.x.x.x ( IP Address of my machine i had set in /etc/hosts) up
than i get it up in ifconfig -a , and also arp -a shows some i.p. adresess of my cable provider,and le0 with x.x.x.x , Mask ff.ff.ff.ff. flags SP and physical address ,and le0 with multicast address(224.0.0.0) and mask 240.0.0.0.
but when i try to browse i get host unreachable or not found...
i hope you people can help me here , is it my ethernet interface speed (10mbps) which is problem.
thanx in advance...
raju
# 4  
Old 10-27-2002
Quote:
Originally posted by raju
i hope you people can help me here , is it my ethernet interface speed (10mbps) which is problem.
thanx in advance...
I know little of Sun OEM equipment. Is your interface a 10/100 or just a 100 Mbit only interface? From your description it sounds like the hardware is reporting that the connection isn't being made.

I am assuming that you have tested the cross-over cable with another machine that the modems works correctly?
# 5  
Old 10-27-2002
Bug

hardware is 10mbps only , and same crossover cable works fine with another machine.
but why do i have to run ifconfig again after booting to make my le0 up????
thanx in advance
raju
# 6  
Old 10-29-2002
Tools

okay , guys thanx alot , for your help , i could get it resolved by my self , here is procedure:
1.ifconfig interface name address mask up example:ifconfig le0 xx.xx.xx.xx netmask (subnet mask here) up
2.create /etc/hostname.le0 , add ur host name to it ,for example sparky or whatever.
3.edit your /etc/hosts file to have locol host and your host name with i p address you set.
4.add i p address of your ISP default gateway to your /etc/defaultrouter
5.edit /etc/nsswitch file , to read host line as dns files
6.creat /etc/resolv.conf , add your domain name and nameserver
7. and better create a file /etc/dhcp.le0 (to get ip of your cable modem provider automaticaly using DHCP.
and reboot with init 6.
but never forget to switch of ur cable modem and restart again, (that was mistake i made , and coudn't figured it out)
make check on reboot with ifconfig -a , and netstat -rn
thanx any way
raju
raju
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #795
Difficulty: Easy
10 has three prime factors 1, 2 and 5.
True or False?

10 More Discussions You Might Find Interesting

1. OS X (Apple)

Cannot access UNIX.com with new cable modem

Hi. I have a very strange problem, so strange I don't even know which sub-forum to post it to. Last week, my cable modem broke, so I took it back and got a new one. The new one doesn't work with my old router so, for now, I have to connect the modem directly to my Mac with an ethernet... (14 Replies)
Discussion started by: Scott
14 Replies

2. Solaris

Null modem cable in Ultra sparc 10

Hi Gurus, Can I use null modem cable in Ultra sparc 10 workstation Thanks (3 Replies)
Discussion started by: kumarmani
3 Replies

3. Solaris

Is the cable you are using a null modem cable or a modem cable

Hi all, Is there any difference between a null modem cable or a modem cable ? i assume that a null modem cable is a normal cable that i used from cpu serial ports to a modem for dialup. please correct if i am wrong, thks (2 Replies)
Discussion started by: waterbear
2 Replies

4. BSD

cable modem problem

hi I want to setup my cable modem under OpenBSD. I did not configure my network while installing the system. When I type, I get # ifconfig -a lo0 : .... ... ... rl0 : .... ... ... vr0 : ... ... ... I have two network cards (the machine will be a router). I created... (1 Reply)
Discussion started by: fnoyan
1 Replies

5. UNIX for Dummies Questions & Answers

Installing Cable Modem on Irix Machine.

Ok I am new to this and wondering if there is any way of connecting a cable modem to an SGI that is running IRIX 6.5 and how to do it... (1 Reply)
Discussion started by: Acidjack
1 Replies

6. IP Networking

DHCP Linux and cable modem

I can do all this in windows, but Im trying to run the SuSe 8.0 professional as a gateway. I have the local (private) LAN setup with no problems, but Im having troubles getting it to use DHCP to go out on the external card to the service provider, which only uses Dynamic IP's. WHere, what and how... (3 Replies)
Discussion started by: ftn96
3 Replies

7. UNIX for Dummies Questions & Answers

Is anyone using unix with cable modem

Is anyone using a cable modem with unix and if so does your cable co. support unix or did you get that going on your own and how. Thank you for all your help. (5 Replies)
Discussion started by: gparsons70
5 Replies

8. UNIX for Dummies Questions & Answers

can't get my cable modem up

Caldera eDesktop 2.4 - Cable Modem my NIC card has been detected, but funny scenario: #dmesg eth0: RealTek rtl8139 Fast Ethernet at 0x2400, IRQ 0, 00:50:ba:43:a0:ef /*I noticed that it detected the correct module (rtl8139) but I'm using D-Link and not RealTek, which uses the same module.... (1 Reply)
Discussion started by: zorro
1 Replies

9. UNIX for Dummies Questions & Answers

Linux and my cable modem

I recently installed Caldera 2.4 (successfully:p ), but I cannot seem to get my cable modem up and running! My ISP is AT&T and I'm using @home. I've tried using DHCP and that didn't work either. I briefly read the cable modem HOWTO, but the lsmod didn't list my network card (3COM). What do I do now? (4 Replies)
Discussion started by: zorro
4 Replies

10. IP Networking

unix and the cable modem

If the cable modem that the cable company is using doesn't support unix is there a way around that . Are there drivers I can get online or is there a way to configure redhat lenix (that's what I will be using) to work with the cable modem. Or is there a way to buy a third party cable modem that... (3 Replies)
Discussion started by: gparsons70
3 Replies

Featured Tech Videos