Visit Our UNIX and Linux User Community


dmesg on a sun, unqualified host


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers dmesg on a sun, unqualified host
# 8  
Old 10-25-2002
The command you used tells sendmail to set debug mode zero.one. This allows you to check that the configuration is working or not. Any errors should be fixed.

The -bt is for address test mode. You should have gotten a prompt back without using control-C. The < /dev/null is input, not output.

You posted
(short domain name) $w = nameofdomain
(canonical domain name) $j = nameofdomain (same as above)
(subdomain name) $m = <null>
(node name) $k = nameofdomain (same as the short, canonical)

nameofdomain SHOULD have hostname.nameofdomain.com - please specify if it shows the hostname AND the name of the domain or just the hostname (which is why I explained how to change your post if you did not want company info on here).

I also posted that you need to set your /etc/hosts entry for the system having this problem to have the IP, hostname, and fully qualified hostname. Re-read the post prior to this please.

You should have also gotten back the full Version of sendmail you are running - you did not post it.
# 9  
Old 10-28-2002
Version 8.10.2+Sun
Compiled with: MAP_REGEX LOG MATCHGECOS MIME7TO8 MIME8TO7 NAMED_BIND
NDBM NETINET NETUNIX NEWDB NIS NISPLUS QUEUE SCANF SMTP USERDB
XDEBUG
Oct 28 15:45:35 abc sendmail[21199]: unable to qualify my own domain name (abc) -- using short name

============ SYSTEM IDENTITY (after readcf) ============
(short domain name) $w = abc
(canonical domain name) $j = abc
(subdomain name) $m = <null>
(node name) $k = abc
========================================================

WARNING: local host name (abc) is not qualified; fix $j in config file
ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)
Enter <ruleset> <address>

note that the value for abc is the same. abc does not contain any other actually.dontknow.whatdomain. abc is just a word by itself. to my limited knowledge, its a hostname. something like i type
telnet myserver
yls177
# 10  
Old 10-29-2002
further info, i hope so....

hi, i thot this might be useful, here we go...

i ran nslookup on my two solaris physical servers from the entries of /etc/hosts.

so the one that i have been posting with errors of sendmail gave me this..

*** Can't find server name for address 127.0.0.1: Unspecified error
*** Default servers are not available


note that the /etc/hosts had some other servers but whichever i tried with nslookup, the system message is the same as above....

HOWEVER, the other solaris server is fine... giving me the server, name, address info.

thanks
yls177
# 11  
Old 10-29-2002
You need an entry in /etc/hosts as follows:
127.0.0.1 localhost

This will fix the error you are getting.
# 12  
Old 10-29-2002
i had 127.0.0.1 localhost as an entry in my /etc/hosts

so what could be wrong..

this is a side problem which i do a walk through when my first problem is with the sendmail.. see my earlier posts...

thanks for all for helping..
yls177
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #274
Difficulty: Easy
OpenSolaris is a descendant of the UNIX System V Release 4 (SVR4) code base developed by Sun and AT&T in the late 1980s.
True or False?

7 More Discussions You Might Find Interesting

1. Solaris

Add new EML 103e Tape Library in SUN Solaris Host to implement HP DP

Hi, Our environment is SUN Solaris. We have purchased HP EML 103e tape library. Can you please let me know do I need to install any Driver of newly added Tape Library to see from the Solaris Host? or how can i see the tape library from my Solaris hosts. Thanks, Hassan (0 Replies)
Discussion started by: M_Hassan
0 Replies

2. Solaris

Classic: sendmail[pid]: My unqualified host name (hostname) unknown

Hi all, I'd like to disable sendmail permanently on my "new" 220R with freshly installed SunOS 5.10 because it prints annoying messages to the system console. Also I'm interested in how to fix the actual problem with unqualified host name. My unqualified host name (hostname) unknown; sleeping... (2 Replies)
Discussion started by: pseudocoder
2 Replies

3. UNIX for Dummies Questions & Answers

Unqualified Host at boot

I'm sure this is as basic as they get. I installed Solaris 10 x86 on a compaq 7500 that I switched motherboards out with an AMD processor. Since I installed, I've gotten the "unqualified host name" message at boot plus I"m not sure how to find my NIC (or if the driver is installed). I only show... (7 Replies)
Discussion started by: ltillman
7 Replies

4. Solaris

My unqualified host name

Hi experts . . . host name: prd47e Sunsolaris 9 version My mails are not going and am gettin regular messages like: * My unqualified host name (prd47e) unknown; sleeping for retry * unable to qualify my own domain name (prd47e) -- using short name my /etc/hosts file contnets are... (6 Replies)
Discussion started by: vrjalli
6 Replies

5. Solaris

Unqualified host name

Hi All I am Having V890 Server with Solaris 10 OS.In Dmesg showing the sendmail error. This is the error: Jul 26 22:04:56 ORACLE sendmail: My unqualified host name (ORACLE) unknown; sleeping for retry Jul 26 22:05:56 ORACLE sendmail: unable to qualify my own domain name (ORACLE) -- using... (5 Replies)
Discussion started by: ravigpb
5 Replies

6. Solaris

sendmail and unqualified addresses

I have a solaris 10 server running sendmail 8.13.8, configuration file V10. On another server I am able to send local emails without appending a domain name but on this server I cannot. The mail does not bounce, the log file says they are sent, but they are not delivered. There isn't a problem... (10 Replies)
Discussion started by: csgonan
10 Replies

7. UNIX for Dummies Questions & Answers

sun dmesg says

Oct 22 13:40:07 snmpdx: community_check() : bad community from Oct 22 13:40:07 snmpdx: session_open() failed for a pdu received from any help? thanks (4 Replies)
Discussion started by: yls177
4 Replies

Featured Tech Videos