Visit Our UNIX and Linux User Community


Unqualified Host at boot


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Unqualified Host at boot
# 1  
Old 08-10-2009
Unqualified Host at boot

I'm sure this is as basic as they get. I installed Solaris 10 x86 on a compaq 7500 that I switched motherboards out with an AMD processor. Since I installed, I've gotten the "unqualified host name" message at boot plus I"m not sure how to find my NIC (or if the driver is installed). I only show loopback.

I entered info in hosts and get "alive" when I ping the name. Can someone tell me what "haven't" I done and how to fix this so I can access my router?

Thanks in advance
# 2  
Old 08-10-2009
This feels a bit like you haven't got an FQDN entry in your hosts file (if so, it won't actually cause any major connectivity issues but is good to fix for email to work right).
Check by looking in /etc/hosts and if it's not present, adding:
<hostname>.<your.domain.name>
To the end of the line already containing your hostname.

If that's not it, and you are unable to ping your router IP address, please post the following:
  • ifconfig -a
  • cat /etc/hosts
  • ls /etc/hostname.*
  • cat /etc/hostname.*
  • netstat -r
# 3  
Old 08-11-2009
Thanks... here is the info

Sorry for the time lapse... didn't connect the floppy... thank God for USB.
As you can see hostname was not found. Also, I can ping the name I entered for the router ip address and get "alive" but the ip address says it's "unreachable"

# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
#

# netstat -r

Routing Table: IPv4
Destination Gateway Flags Ref Use Interface
-------------------- -------------------- ----- ----- ------ ---------
localhost localhost UH 10 316 lo0
#

# pwd
/etc
# ls hosts*
hosts hosts2

---------- Post updated 08-11-09 at 07:30 PM ---------- Previous update was 08-10-09 at 10:20 PM ----------

I found that my interface didn't have the drivers installed so I replaced it with another that I had. Now I am pinging the router, my other pc (in a different floor) and everything on my network. I can even get into the router settings with my password from my Sol 10 box. One problem though, whenever I try to open my web browser, I get "connection refused". I've checked all passwords,security on the router, and tried proxie settings as well as direct connect... same result. I do not show my Solaris box in my client table on my router but the ping is successful. I have added the box's ip to the "allow" list... no luck. Any ideas where else to look?

Thank You

# netstat -i
Name Mtu Net/Dest Address Ipkts Ierrs Opkts Oerrs Collis Queue
lo0 8232 loopback localhost 493 0 493 0 0 0
elxl2 1500 me me 8027 109 6856 0 0 0

Name Mtu Net/Dest Address Ipkts Ierrs Opkts Oerrs Collis
lo0 8252 localhost localhost 493 0 493 0 0
elxl2 1500 fe80::250:daff:fe06:a341/10 fe80::250:daff:fe06:a341 8027 109 6856 0 0
# 4  
Old 08-11-2009
I'm assuming you mean the you get 'connection refused' when trying to browse to some address rather than actually during the browser start-up, yes?
If so, what are you trying to connect to? The router or some address elsewhere?

If it's the router, see what happens if you issue:
telnet <router address> 80

If it also refuses connection, than it's the web interface on the router being switched off.

If it's not the router, does a ping to the target website succeed?
# 5  
Old 08-12-2009
Hi, Thanks for your reply.

I can bring up the router in the browser and change settings, etc., but I get the 'connection refused...' whenever I try to start the browser on any website (it has Sun Microsystems as the default address, of course). I tried to ping the router address by itself but didn't include the port, so I will try that now.

I tried to ping the server address listed in my router from my cable provider but got "imcp unreachable..." even though it did include the name of the provider so it seemed like it did see something.

btw, I'm still getting the maill error at boot. Is that a clue? I can even access my XP pc and see my files so I know it's on my network... I just can't seem to get to the internet.

---------- Post updated 08-12-09 at 01:50 AM ---------- Previous update was 08-11-09 at 10:14 PM ----------

...it's arp (the suspect, that is... ) I keep seeing a broadcast of 192.168.1.255 which is out of my subnet range (go figure) and of course it's my Solaris box. Even though I sys-unconfigure'd and go in 115 which is within my range. This also explains (to me, at least) why I never can see my S-box listed in my Router client table. How do I turn that off?

Thx
# 6  
Old 08-12-2009
If you can see the local subnet but nothing outside, it's likely to be a routing table issue (or your router).
Lets have another look at the table now you have the NIC configured:
netstat -r
And your IP and netmask:
ifconfig -a

Assuming your router is on 192.168.1.1 and your Solaris box is on something in the 192.168.1.0/24 subnet (based on that broadcast address you are using), then I'd expect to see a pretty simple table with 192.168.1.1 as the default route and your NIC as the route for 192.168.1.0 ffffff00.
# 7  
Old 08-13-2009
Interesting... I'm on now

Thanks for your help.

Odd thing. I did another sys-unconfig and this time it only asked me to re-enter network configuration as domain, NIS, DNS,etc but not the host name and ip info for this machine. I figured I had misconfigured it. Instead when it rebooted and got my desktop, I tried the browser and it connected to the internet. The only concern are the unknown entries... or should I not be concerned?

Code:
# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
elxl2: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 2
        inet 192.168.1.3 netmask ffffff00 broadcast 192.168.1.255
        ether 0:50:da:6:a3:41
lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
        inet6 ::1/128
elxl2: flags=2000841<UP,RUNNING,MULTICAST,IPv6> mtu 1500 index 2
        inet6 fe80::250:daff:fe06:a341/10
        ether 0:50:da:6:a3:41
# netstat -r

Routing Table: IPv4
  Destination           Gateway           Flags  Ref   Use   Interface
-------------------- -------------------- ----- ----- ------ ---------
192.168.1.0          unknown              U         1    457 elxl2
BASE-ADDRESS.MCAST.NET unknown              U         1      0 elxl2
default              mediasnd             UG        1    102 elxl2
localhost            localhost            UH        6    179 lo0

Routing Table: IPv6
  Destination/Mask            Gateway                   Flags Ref   Use   If
--------------------------- --------------------------- ----- --- ------ -----
fe80::/10                   fe80::250:daff:fe06:a341    U       1      0 elxl2
ff00::/8                    fe80::250:daff:fe06:a341    U       1      0 elxl2
default                     fe80::250:daff:fe06:a341    U       1      0 elxl2
localhost                   localhost                   UH      1     14 lo0


Last edited by DukeNuke2; 08-13-2009 at 03:24 AM.. Reason: added code tags
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #864
Difficulty: Medium
In 2019, the UNIX.com UserCP was rewritten in Vue.js by Neo.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Need to recover/move diskgroup from failed host to another host

Hi All I am having VxVm on two Solaris hosts. host1 is using disk group dgHR. right now this server went down due to hardware fault. Not I need to import this dgHR into host2 server. Please let me know the procedure for the same. (1 Reply)
Discussion started by: amity
1 Replies

2. Solaris

Classic: sendmail[pid]: My unqualified host name (hostname) unknown

Hi all, I'd like to disable sendmail permanently on my "new" 220R with freshly installed SunOS 5.10 because it prints annoying messages to the system console. Also I'm interested in how to fix the actual problem with unqualified host name. My unqualified host name (hostname) unknown; sleeping... (2 Replies)
Discussion started by: pseudocoder
2 Replies

3. UNIX for Dummies Questions & Answers

Transfer large number of files host to host

Hello.... I have two servers, one has an empty / and the other has a subdirectory with a large number (4 gig) with many, many files. I need a way to transfer the files en masse from the server with the large number of files to the one that is essentially blank. I don't have space on the used... (16 Replies)
Discussion started by: blaine.miller
16 Replies

4. UNIX for Advanced & Expert Users

Help! How to find the local host after few ssh hops to remote host???

I do a ssh to remote host(A1) from local host(L1). I then ssh to another remote(A2) from A1. When I do a who -m from A2, I see the "connected from" as "A1". => who -m userid pts/2 2010-03-27 08:47 (A1) I want to identify who is the local host who initiated the connection to... (3 Replies)
Discussion started by: gomes1333
3 Replies

5. Shell Programming and Scripting

running commands to remote host from centralized host

Gurus/Experts We have a centralized UNIX/Solaris server from where we can actually ssh to all other UNIX/Solaris servers...I need to write a script that reside on this centerlized server and do FileSystem monitoring (basically run df -h or -k) of other remote servers and then send an email to me... (6 Replies)
Discussion started by: anjum.suri
6 Replies

6. Solaris

My unqualified host name

Hi experts . . . host name: prd47e Sunsolaris 9 version My mails are not going and am gettin regular messages like: * My unqualified host name (prd47e) unknown; sleeping for retry * unable to qualify my own domain name (prd47e) -- using short name my /etc/hosts file contnets are... (6 Replies)
Discussion started by: vrjalli
6 Replies

7. Solaris

Unqualified host name

Hi All I am Having V890 Server with Solaris 10 OS.In Dmesg showing the sendmail error. This is the error: Jul 26 22:04:56 ORACLE sendmail: My unqualified host name (ORACLE) unknown; sleeping for retry Jul 26 22:05:56 ORACLE sendmail: unable to qualify my own domain name (ORACLE) -- using... (5 Replies)
Discussion started by: ravigpb
5 Replies

8. Solaris

sendmail and unqualified addresses

I have a solaris 10 server running sendmail 8.13.8, configuration file V10. On another server I am able to send local emails without appending a domain name but on this server I cannot. The mail does not bounce, the log file says they are sent, but they are not delivered. There isn't a problem... (10 Replies)
Discussion started by: csgonan
10 Replies

9. UNIX for Dummies Questions & Answers

dmesg on a sun, unqualified host

Oct 22 01:01:47 sendmail: My unqualified host name unknown; sleeping for retry Oct 22 01:02:47 sendmail: unable to qualify my own domain name -- using short name how to resolve this error thanks (11 Replies)
Discussion started by: yls177
11 Replies

10. IP Networking

QNX host cannot ping SCO host, vice versa

The problem I am facing now is that the QNX host could not ping the SCO host and vice versa. They are in the same domain, ie, 172.20.3.xx. As I am very new to Unix, I guess I must have missed out some important steps. Pls help... Thanx alot (2 Replies)
Discussion started by: gavon
2 Replies

Featured Tech Videos