Visit Our UNIX and Linux User Community


FreeBSD 4.6 Video Settings for Xwindows


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers FreeBSD 4.6 Video Settings for Xwindows
# 1  
Old 09-10-2002
FreeBSD 4.6 Video Settings for Xwindows

I have set-up FreeBSD on an HP Vectra Intel Based PC, now when I go to /stand/sysinstall and "do a post installation configuration" and try to set-up the XFree86 server under Video card the model of my card does not exist. My video card model is SiS 6205 but FreeBSD supports or listed only 5205. I pressume this is the main hurdle why my "startx" command to launch Xwindows is not succesful. How could I get the correct driver for my video Thanks.
# 2  
Old 09-14-2002
Hi

Is this the most stupid question, that's why everybody ignored it?
# 3  
Old 09-14-2002
Re: Hi

Quote:
Originally posted by charlie499
Is this the most stupid question, that's why everybody ignored it?
Try running xf86cfg --configure to generate an XF86Config file and after placing it in /etc/X11 try running xf86cfg to edit settings.

For more detailed examples check out the FreeBSD Handbook at www.freebsd.org.
# 4  
Old 09-26-2002
usually works the generic svga driver, this is a good one to start with if your card is not [yet] listed in the xfree drivers list. you can use even an older variant of the same vendor.
# 5  
Old 09-26-2002
Java hm

i'm not sure, but search the ports to have x11 server with specific card to be installed. Like mine is x11 mach64 server, but dunno, because i use x11 like a toy, not for working..
# 6  
Old 09-29-2002
Re: Re: Hi

I am having a similar problem on an IBM Thinkpad laptop. I installed FreeBSD 4.7-RC2 and XFree86 4.2 did not start. What is strange is that I have another partition with SuSE Linux 7.2 and XFree86 4.2 installed and it works fine.

The chipset is silicon motion LynxEM+, which is claimed to be supported by 4.2.

Quote:
Originally posted by auswipe

Try running xf86cfg --configure to generate an XF86Config file and after placing it in /etc/X11 try running xf86cfg to edit settings.[/url]
I have tried to use xf86cfg as mentioned in the handbook. But even the generic settings there do not function. In all cases the screen simply turned dark and did not respond.

The X server log:
http://www.cbkihong.com/temp/XFree86.0.log
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #635
Difficulty: Medium
The iPhone 6 and 6S were available in three sizes at launch: 32, 64, and 128 GB.
True or False?

5 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Video Cards :: Video Memory Intercept and Redirect

I need a broad spectrum understanding on this subject, and any help would be greatly appreciated. First of all, as I understand it... The way the video hardware works is the CPU sends information about input and possible changes to the display, the video card receives these changes, makes the... (2 Replies)
Discussion started by: ciNG
2 Replies

2. Solaris

video adapter settings

Hi Please help to set the video adapter resolution, frequency. By default the frequency is 66Hz, 61 kHz, and the resolution 1024*768. Can I set different values. We use Solaris WS, SPARC. Thanks (2 Replies)
Discussion started by: Andrey Malishev
2 Replies

3. UNIX for Dummies Questions & Answers

Terminal Video Settings

I am not a Solaris (Unix) guy so i need help. I am trying to get a Sun Ultra 5 running Solaris 8 to display the correct video for my KVM switch. I have set the CDE to 1024x768x75 and have no problem with video using this setting in CDE. When I shut down the server or boot up the server it is... (4 Replies)
Discussion started by: cchyzm
4 Replies

4. UNIX Desktop Questions & Answers

New FreeBSD User....Xwindows Problem

Hi, would anybody kindly help me as I am new in FreeBSD 4.4 (downloaded iso image from FreeBSD.org) and have installed it to an HP VEctra Pentium 1-166Mhz PC, have installled all the devices mouse,video card,monitor and some ports specifically to Xfree86 and all gnome related to "X" but when I type... (3 Replies)
Discussion started by: charlie499
3 Replies

5. UNIX for Dummies Questions & Answers

Xwindows will not start with FreeBSD 4.2

I have tried to start X windonws using the startx command. It fails. the error message I receive is: warning: 'fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/font/local". Entry deleted from font path (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/local) xf86Openconsole: KDEABOP... (2 Replies)
Discussion started by: wanderer00
2 Replies

Featured Tech Videos