Visit Our UNIX and Linux User Community


trying to use mount command


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers trying to use mount command
# 1  
Old 09-10-2002
trying to use mount command

Im simply trying to use the mount command to map a shared drive from one unix box to another

mount 192.168.1.101:/export/home /export/home

but complains that the command is "nfs mount: 192.168.1.101: : RPC: Program not registered"

what can I do about this if anything

thanks in advance for responses
# 2  
Old 09-10-2002
You must mount the file system as an nfs filesystem with the appropriate flags.

Also, you must insure that you have correctly exported the remote directory in a file similar to /etc/exports

You must insure that the proper network processes are running like the RPC daemon and port mapper.... etc.
# 3  
Old 09-10-2002
Re: trying to use mount command

try follow:

mount -t nfs 192.168.1.101:/export/home /export/home

NFS-Server must be started...
# 4  
Old 09-10-2002
Neo,

On the system I'm trying to share I used the command:
share -F nfs -o -rw /export/home

this seemed to work OK.

I tried using mount -F nfs 192.168.1.101:/export/home /export/home
on my other system but it still comes up with
RPC Program not Registered.

even if I try the command 'showmount' it responds with 'RPC Program not Registered'. So perhaps there is configuration issues here??
# 5  
Old 09-10-2002
Your nfs server should have a program called rpcbind (older systems may call it portmap). Is rpcbind eveb running? On the nfs server you should be able to use the command "rpcinfo" and see a long list of stuff. Do you? The list should include entiries for mountd. If you have never mounted anything before from your nfs server, you may just need to turn on the nfs server daemons. If this used to work but it no longer does, your rpcbind may be out to lunch. You can try the warm start procedure on the man page, but you may need a reboot to bring it back.
# 6  
Old 09-10-2002
MySQL

checked
restarted it and it works thanks.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #459
Difficulty: Medium
NTP uses an epoch of January 1, 1970.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Passing User Credentials with Mount Command

My HP-UX server currently mounts a directory on a Windows 2012 server. The Windows server allows anonymous connections for RW and this configuration has worked well for years. Now, due to tightening security requirements I can't use anonymous. I also can't setup Identity Mapping on the Windows... (5 Replies)
Discussion started by: jduehmig
5 Replies

2. Shell Programming and Scripting

Problem with command mount

Hi, I have a problem with the command mount with a password with special character mount -t smbfs '//itransfert_cs:password@IP/itransfert/1-Arrivees/Vers_K2' /share the password contain a * and a @ I try to quote but don't work, replace the @ with %40 and try to escape with \ but... (8 Replies)
Discussion started by: protocomm
8 Replies

3. Solaris

Mount command doesn't work on Solaris System

Hi All, I am using a solaris Sun-Fire-V440 server. The OS is solaris. My problem is whenever I run the command mount | grep "^/ " | sed -e 's,^.*dsk/\(*\).*$,\1,' it should return a disk value as "d30" as it does on each of my other servers.But on this server I am not getting any o/p from... (3 Replies)
Discussion started by: vivek.goel.piet
3 Replies

4. AIX

mount command for AIX server

Hi Guys,, I am newbie to administration.. I like to mount one directory from one server to another server. Both the servers are AIX. Could you please give me the syntax for the mount command? Thanks For your help in advance, Regards, Magesh. (1 Reply)
Discussion started by: mac4rfree
1 Replies

5. UNIX for Advanced & Expert Users

how to check the options used in mount command

hi , I want to check that what options i have used in mount command ... or what switches i have used while mounting .. is there any method to check ? thanks (1 Reply)
Discussion started by: tahir23
1 Replies

6. UNIX for Advanced & Expert Users

mount command

hi can you tell mount command which mount my windows c drives on my linux machine my windows file system is vfat (1 Reply)
Discussion started by: munnu
1 Replies

7. UNIX for Dummies Questions & Answers

Mount Command

For this command: mount -F UFS -o rw,remount /usr mount -F UFS -o ro,remount /usr -- doesn't work for me (read only mode). Frankly speaking, I've only been able to remount for read/write (rw). I've always had to reboot the system for read only (ro) to take effect. Thanks. (2 Replies)
Discussion started by: esofthub
2 Replies

8. UNIX for Dummies Questions & Answers

using the mount command to connect to a windows share

Until recently I have been using the following command successfully to connect to a windows share: mount -t smbfs -o username=my_username,password=my_password /home/temp //oldserverx1/openexchange But from today, I've been getting the following error: INFO: Debug class all level = 1 (pid... (1 Reply)
Discussion started by: cw1972
1 Replies

9. UNIX for Dummies Questions & Answers

pwd Command and NIS mount points

I am running NIS, NFS and automount. If I execute % cd /xyz/data1 % pwd I get different results depending on the operating system. On SGI running Irix 6.5.x pwd returns /xyz/data1 On Redhat Linux 7.3 pwd returns /xyz/data1 BUT On Tru64 UNIX the pwd command returns... (1 Reply)
Discussion started by: agreenwo
1 Replies

10. UNIX for Dummies Questions & Answers

how to mount a hotswap scsi drive on a solaris 2.6 netra box using the mount command?

Hi... question is this: How do I mount an LVD hotswap scsi drive in bay #2 on a netra using the mount command? volmgt doesn't seem to mount it and/or I don't know how to view the drives data if it's formatted which it may not be. This drive is not new out of the box so I'm not sure. ... (4 Replies)
Discussion started by: soulshaker
4 Replies

Featured Tech Videos