Visit Our UNIX and Linux User Community


dns and resolv.conf


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers dns and resolv.conf
# 1  
Old 07-24-2002
Data dns and resolv.conf

Hi ,,still struggling with unix ,,the system is running sco openserver release 5 and have dsl installed ,, the dsl modem is a bt router which in turn is connected to a vpn hardware router,, which also serves internet to the whole network ,, but i still cant connect to the internet via the unix box ,,i have edited the resolv.conf file with the following settings,,

domain btopenworld.com
nameserver 217.37.41.254

these settings where given to me by btopenworld ,,the ip is the adress of the bt modem which works on all windows based machines . any help would be usefull

Thanks in advance Smilie

P.S. i have read lots of links on the subject in the forum and tried most things here ,,,i must be missing something totally simple me thinks !!!

I have already set up the vpn router as the gateway too on the unix box
# 2  
Old 07-24-2002
I did a nslookup of the MX record to grab the dns servers for btopenworld.com and got the following:

> set type=mx
> btopenworld.com
Server: which1.mycom.com
Address: 10.140.16.20

btopenworld.com preference = 10, mail exchanger = stargate.btinternet.com
btopenworld.com preference = 20, mail exchanger = moongate.btinternet.com
btopenworld.com nameserver = dns1.btinternet.com
btopenworld.com nameserver = dns2.btinternet.com
dns1.btinternet.com internet address = 194.73.73.95
dns2.btinternet.com internet address = 194.73.73.94

I then set my server to dns1 and type to address

> server dns1.btinternet.com
Default Server: dns1.btinternet.com
Address: 194.73.73.95

> set type=a
> 217.37.41.254
Server: dns1.btinternet.com
Address: 194.73.73.95

Name: host217-37-41-254.in-addr.btopenworld.com
Address: 217.37.41.254

I believe the address is your system, not the DNS nameserver (unless you are running DNS on the server). Try setting your nameserver to 194.73.73.95. If that works, add a second nameserver of 194.73.73.94 (dns2).

Last edited by RTM; 07-24-2002 at 12:55 PM..
# 3  
Old 07-24-2002
Hi ,,
The ip address 217.37.41.254 is the address of the bt modem/router but i tried changing the settings in resolv.conf with no luck ,, havent restarted the system though ,dont know if this will make any difference ,,thanx for your help though ,,, will restart later when all are logged off

Cheers b03der Smilie
# 4  
Old 07-24-2002
If you changed resolv.conf, the change is immediate - no reboot needed.
# 5  
Old 07-24-2002
Thanx RTM ,, this system has 2 network cards installed with only one actually used ,,when using netstat it is listed as having an ip address the corresponds to our network ,,could this somehow be causing a problem ,, ,would it be worth while actually removing this card completely ,,or using this card and connecting it direct to the bt router with a static ip address (5 are available )

Thanx b03derSmilie
# 6  
Old 07-24-2002
Okay, I checked and the nameserver you had listed is running DNS.

> server 217.37.41.254
Default Server: host217-37-41-254.in-addr.btopenworld.com
Address: 217.37.41.254

> set class=chaos
> set type=txt
> version.bind.
Server: host217-37-41-254.in-addr.btopenworld.com
Address: 217.37.41.254

VERSION.BIND text = "8.3.3-REL"

Please give some more information:

1. Is this a new install - first time trying to get the unix server on the internet?
2. Can you ping 217.37.41.254 ?
3. Can you ping other hosts on your network (if any)?

The network card being used with a IP address that corresponds to your network - is that part of the 217.37.41 subnet? (Removing the card would probably not be needed.) It's possible that a route is needed - how are you connected to the bt router?
# 7  
Old 07-25-2002
Hi,,
The bt router is connected to a linksys vpn server/router, this then distributes the internet to our local network ,,, the ip of the bt router is 217.37.41.254 the internal network has an ip address of 192.168.2.??? i can ping the linksys box which has an ip of 192.168.2.254 but cant ping the bt router ,,but i can ping the machines through the other side of the vpn which are on a different ip (192.168.1.??? ) i have entered the vpn as the default gateway on the unix box ,, this is a first install of trying to get this box on the net ,, the unix box is just connected to a hub,,the other network card in the unix box has an ip that corresponds to our internal network (192.168.2.???) but isnt connected to anything ,,

Thank you


B03derSmilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #52
Difficulty: Easy
A magnetic disc array is an example of offline storage.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Configure resolv.conf and nsswitch.conf

Hi, I've installed Solaris 11.3(live media) and configured DNS. Everytime I reboot the server, resolv.conf got deleted and it created a new nsswitch.conf. I used below to configure both settings: # svccfg -s dns/client svc:/network/dns/client> setprop config/nameserver = (xx.xx.xx.aa... (1 Reply)
Discussion started by: flexihopper18
1 Replies

2. Ubuntu

Resolv.conf not getting updated regularly!

Hi All! I am using Ubuntu 12.04 with LXDE. This is office's allocated laptop. I have a problem here now, my /etc/resolv.conf file is not getting updated automatically whenever I am switching network, i.e. home or office. I have to do it manually every-time, I manually input the office's DNS,... (3 Replies)
Discussion started by: nixhead
3 Replies

3. UNIX for Dummies Questions & Answers

DNS server - /etc/resolv.conf file issue

Hi, Am trying to configure DNS server and trying to keep the information in /etc/resolv.conf file as: search server nameserver 192.168.0.10 when i restart the network service with #service network restart, resolv.conf file is changing as: nameserver 192.168.0.10 search server -... (5 Replies)
Discussion started by: raosr020
5 Replies

4. Red Hat

Issue on resolv.conf

Hi all, :( I am facing issue while I have updated in resolv.conf, after nework service restart, it was automatically deleted IP from resolv.conf file. Could you please let me know what is the reason resolv.conf deleted any IP which I have manually updated, but it store only my router IP... (3 Replies)
Discussion started by: Pradipta Kumar
3 Replies

5. Ubuntu

resolv.conf

Hi, My resolv.conf keeps overwritten. I want to have it to just keep the setting that I put in there. I tried a few solutions I found using google. like supersede domain-name "xxx", prepend domain-name-servers xxx.xxx.xxx.xxx; This does'nt work. I also tried to just chmod the file to... (4 Replies)
Discussion started by: jld
4 Replies

6. AIX

resolv.conf and DNS configration

Guys, I have enabled the resolv.conf to be configured with our DNS Network and it's configured when I ping any hostname in my Network from the server it's giving me the hostname of that machine (witch mean it's working fine ) but Im facing slowness in my connection when I rename... (13 Replies)
Discussion started by: ITHelper
13 Replies

7. UNIX for Dummies Questions & Answers

resolv.conf

Hi everyone A quick question during a audit this was determined to be a security issue In the resolv.conf there is a . At the end of the domain name Like this domain mydomain.com. I which to understand the function or significance of the . thk (3 Replies)
Discussion started by: Ex-Capsa
3 Replies

8. Shell Programming and Scripting

resolv.conf

HI ALL I am making a script,That will does the following,I am in search of ideas 1.Script will comment all existing the entries in resolve.conf 2.Add new entries like this abc.example.com 192.168.1.x I can use sed to add comment. (8 Replies)
Discussion started by: aliahsan81
8 Replies

9. SuSE

Suse 10 resolv.conf

I want to have 7 search domains in my resolv.conf, but it seems to like only the first six. I read somewhere that the OS will only recognize the first 6 (or the first 154 characters). Is that the case with SUSE 10? thx -Kevin (2 Replies)
Discussion started by: kjbaumann
2 Replies

10. IP Networking

/etc/resolv.conf

I am new to unix. I have edited the /etc/resolv.conf. It shows domain name ip address ip address These are the same ips of the dns I use for windows. Still I get no name resolution on the internet. I can ping external ip's is there anything else I need to check? (1 Reply)
Discussion started by: rpnhavoc
1 Replies

Featured Tech Videos