Visit Our UNIX and Linux User Community


dns and resolv.conf


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers dns and resolv.conf
# 8  
Old 07-25-2002
dsl-bt-router - 217.37.41.254

linksys-vpn - 192.168.2.254


At first it seemed that you had a SCO server connecting to a DSL modem - but from your last post, I believe you are actually connected to the linksys-vpn router - please confirm you have no physical connection to dsl-bt-router - only physical connection to linksys-vpn.

Is there internal DNS being used? If so, try putting that nameserver in your /etc/resolv.conf and allow your DNS to work correctly (remove the dsl-bt-router from the nameserver entry). What is your IP? What routes are set up on your system?
# 9  
Old 07-25-2002
Hi RTM,,
Thanx for all your help with this,, there is no physical connection to the bt router ,,,only to the vpn router.We have 2 offices at different locations ,, which are connected together via dsl and the vpn routers,, our local ip's are 192.168.1.??? and 192.168.2.??? . We dont have a dns server on our network ,,

The ip on the unix box is 192.168.2.100

and the routes on the system is 192.168.1 192.168.2.254


Hope this helps,,,

Thanx again

b03der
# 10  
Old 07-25-2002
You might try setting up a default route. See this link on pcunix.com SCO FAQ. If you are running a version lower than 5.0.6, then build a startup script to do the command each time a reboot is done.
# 11  
Old 07-26-2002
Hi RTM ,,
Thanx for all your help i had added the route ,, but not as the default route ,, once added all is ok ,,,can't thank you enough for all your help ,,


Cheers

b03der,
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #60
Difficulty: Easy
BCD stands for 'Binary Coded Decimal'.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Configure resolv.conf and nsswitch.conf

Hi, I've installed Solaris 11.3(live media) and configured DNS. Everytime I reboot the server, resolv.conf got deleted and it created a new nsswitch.conf. I used below to configure both settings: # svccfg -s dns/client svc:/network/dns/client> setprop config/nameserver = (xx.xx.xx.aa... (1 Reply)
Discussion started by: flexihopper18
1 Replies

2. Ubuntu

Resolv.conf not getting updated regularly!

Hi All! I am using Ubuntu 12.04 with LXDE. This is office's allocated laptop. I have a problem here now, my /etc/resolv.conf file is not getting updated automatically whenever I am switching network, i.e. home or office. I have to do it manually every-time, I manually input the office's DNS,... (3 Replies)
Discussion started by: nixhead
3 Replies

3. UNIX for Dummies Questions & Answers

DNS server - /etc/resolv.conf file issue

Hi, Am trying to configure DNS server and trying to keep the information in /etc/resolv.conf file as: search server nameserver 192.168.0.10 when i restart the network service with #service network restart, resolv.conf file is changing as: nameserver 192.168.0.10 search server -... (5 Replies)
Discussion started by: raosr020
5 Replies

4. Red Hat

Issue on resolv.conf

Hi all, :( I am facing issue while I have updated in resolv.conf, after nework service restart, it was automatically deleted IP from resolv.conf file. Could you please let me know what is the reason resolv.conf deleted any IP which I have manually updated, but it store only my router IP... (3 Replies)
Discussion started by: Pradipta Kumar
3 Replies

5. Ubuntu

resolv.conf

Hi, My resolv.conf keeps overwritten. I want to have it to just keep the setting that I put in there. I tried a few solutions I found using google. like supersede domain-name "xxx", prepend domain-name-servers xxx.xxx.xxx.xxx; This does'nt work. I also tried to just chmod the file to... (4 Replies)
Discussion started by: jld
4 Replies

6. AIX

resolv.conf and DNS configration

Guys, I have enabled the resolv.conf to be configured with our DNS Network and it's configured when I ping any hostname in my Network from the server it's giving me the hostname of that machine (witch mean it's working fine ) but Im facing slowness in my connection when I rename... (13 Replies)
Discussion started by: ITHelper
13 Replies

7. UNIX for Dummies Questions & Answers

resolv.conf

Hi everyone A quick question during a audit this was determined to be a security issue In the resolv.conf there is a . At the end of the domain name Like this domain mydomain.com. I which to understand the function or significance of the . thk (3 Replies)
Discussion started by: Ex-Capsa
3 Replies

8. Shell Programming and Scripting

resolv.conf

HI ALL I am making a script,That will does the following,I am in search of ideas 1.Script will comment all existing the entries in resolve.conf 2.Add new entries like this abc.example.com 192.168.1.x I can use sed to add comment. (8 Replies)
Discussion started by: aliahsan81
8 Replies

9. SuSE

Suse 10 resolv.conf

I want to have 7 search domains in my resolv.conf, but it seems to like only the first six. I read somewhere that the OS will only recognize the first 6 (or the first 154 characters). Is that the case with SUSE 10? thx -Kevin (2 Replies)
Discussion started by: kjbaumann
2 Replies

10. IP Networking

/etc/resolv.conf

I am new to unix. I have edited the /etc/resolv.conf. It shows domain name ip address ip address These are the same ips of the dns I use for windows. Still I get no name resolution on the internet. I can ping external ip's is there anything else I need to check? (1 Reply)
Discussion started by: rpnhavoc
1 Replies

Featured Tech Videos