Visit Our UNIX and Linux User Community


FTP access problems


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers FTP access problems
# 1  
Old 06-07-2002
FTP access problems

Current setup:
I am running Solaris 8 and PROFtpd. I have my network functioning correctly. The server can be pinged from any machine on the network. There is no firewall between the client and the server. The proftpd service is running using the correct and only proftpd.conf file in standalone mode with no virtual host. From the ftp server, I can ftp it, log in, etc.

Problem:
When I try to ftp to the same server from another machine, it connects saying, "Connected to 196.x.x.x..", waits for about a minute, and gives a message "Connection Closed by Remote Host"

I have checked my proftpd log file and it does not show any activity. I was able to connect without problems before. I had to change the net configuration to work on another network. After I did this, I started having problems.

What could I be missing? Thanks for you help.
# 2  
Old 06-07-2002
I have not used PROftp on Solaris but you can check that /etc/hosts.allow is allowing the different network and check the configuration files for PROftp for the same thing. It looks like that new network isn't allowed.
# 3  
Old 06-07-2002
I do not have a hosts.allow or hosts.deny. Do I have to have one?
# 4  
Old 06-07-2002
You don't have to have it - simply stating it in case you forgot to change it when you moved to the new network.

Suggest you look at what you changed - that is where the problem is.

If you have more info - like exactly what you did (step by step) -post back.
# 5  
Old 06-07-2002
I really did not do much. I physically patched it into a different network. changed hostname.elxl0, hosts, defaultrouter, netmasks to work with the new network restarted and was able to ping away at it. I just couldn't ftp it. Port 21 is the only port showing to be open it. Shouldn't FTP have 20 open also? I have since moved it back to the original network and changed all the settings back and still have the problem.???
# 6  
Old 06-10-2002
To answer my own post:
Proftpd by default does a reverse DNS lookup on the IP of the client. In my proftpd.conf file I set the following...
UseReverseDNC Off
IdentLookups Off

I restarted the ftp service and that worked. I found this info in the FAQ of proftpd.org's website under the slow logins question. I guess the Reverse DNS feature wasn't finding my private ip in the DNS server's database.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #408
Difficulty: Medium
The Cygwin distribution contains thousands of packages from the Open Source world including most GNU tools, many BSD tools, an X server and a full set of X applications.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

ftp access without shell access

Hi all, I'm using AIX v 5.3 I want to create system users to access through ftp or sftp and restrict those users into specific directory and don't traverse the whole file system just to be restricted within a directory and don't get shell access . i don't want to use any other third party... (7 Replies)
Discussion started by: h@foorsa.biz
7 Replies

2. Shell Programming and Scripting

FTP problems

Hi All, I am ftping to a windows box where i will be going to a specific directory and check whether file is existing or not. If file exists, get the file to my UNIX box else, say that file didn't exist and touch a new file in UNIX box. Here is what i tried the code: This is FTP script. ... (2 Replies)
Discussion started by: reddybs
2 Replies

3. Shell Programming and Scripting

Problems with ftp

Hi all, I am taking log files every 15 min from remotemachine. My code is ; FRONTEND_HOME=/home/hai/jjsjs/Frontend_log cd /dsd/sds/sdsds/FrontEnd ftp -n 10.22.144.32 << END_INPUT >> /root/scripts/tracking/ftp_frontend.log 2>&1 user hai hai asc cd $FRONTEND_HOME prompt mget logger.log.*... (4 Replies)
Discussion started by: subin_bala
4 Replies

4. Solaris

how to deny ftp access

Hi , I want to deny ftp access to some user. Currently I don't have /etc/ftpusers file. From the man page , i can modify the login shell at /etc/passwd to invalid one. How to add it ? replaced with /dev/null or something. If you have any other method to disabled it . Pls show me. My FTP is... (10 Replies)
Discussion started by: skully
10 Replies

5. UNIX for Dummies Questions & Answers

FTP access

Folks; I'm working on building ACL for our Solaris 10 box. I'm going to use LDAP for authentication. We have a mounted drive on that server & users would like to be able to write to it. We need to restrict the write access to that mounted drive on the box to be only through FTP, so if they... (13 Replies)
Discussion started by: Katkota
13 Replies

6. UNIX for Dummies Questions & Answers

Problems with simultaneous access to a server

Hello, I'm working in a project where several procedures are programmed using UNIX scripts. One of these scripts is launched in several threads. When performing these threads an scp command to another server it gives out. This error happens only sometimes, others not and each time for a... (5 Replies)
Discussion started by: Hector_Saura
5 Replies

7. UNIX for Dummies Questions & Answers

Access Problems

Hi all, newbie to forums here. There's this server with HP-UX, / partition at 100%, won't allow logins, so i've tryed to mount every possible directory through NFS, ftp, sftp, ssh, cu, rcp (to replace files i know are big with an empty one) and nothing. Any other suggestion on how to access... (1 Reply)
Discussion started by: Luis Solorzano
1 Replies

8. UNIX for Dummies Questions & Answers

FTP Access

How to restrict ftp user to move to the parent directory of his home directory. Any suggestions will be appreciated. O.S Sun solaris Regards (3 Replies)
Discussion started by: sehgalniraj
3 Replies

9. UNIX for Dummies Questions & Answers

Ftp Problems

I ahev 4 Unix servers, if i FTP into any one of the from another, and try to ( cd /user) i get a message stating that no such directory....id i cd into anyother directory like /bin it works... So why only for the /user it is not working on FTP ?? What is more annoying is that if i telnet... (1 Reply)
Discussion started by: BAM
1 Replies

10. UNIX for Dummies Questions & Answers

ftp problems

ok folks, hopefully you can shed some light on this for me. I have wu-ftpd running on a Mandrake 7.2 box. No matter what I do (ie. editing ftpusers, allow/deny files, etc, etc...) I cannot gain access to that machine by way of FTP. I consistently get errors stating "530 Login Incorrect". ... (3 Replies)
Discussion started by: ober5861
3 Replies

Featured Tech Videos