Booting in read-only


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Booting in read-only
# 1  
Question

I just got a couple of Solaris boxes (real old, but free) and one of them is booting and says it is in read only mode. I ran fsck but with no change is there some option on fsck I need to use or what could this be? Thanks for any help

# 2  
Question

Quote:
Originally posted by jwbrown
I just got a couple of Solaris boxes (real old, but free) and one of them is booting and says it is in read only mode. I ran fsck but with no change is there some option on fsck I need to use or what could this be? Thanks for any help

Hi,
This could be a problem with the root slice..So boot from the CD and try checking ur root slice using fsck.Or there might be a script in one of ur RC directories which boots the os in read-only mode.Write again.
# 3  
As I recall, mounting disks read-only is a normally a function of the mount command. For example, in the /etc/fstab file (file system table) there are flags which can be used to specify 'read-only' when booted/mounted. You might find your similar file (not sure where it is on Solaris) and check to see the mount flags.
# 4  
Under Solaris that file would be /etc/vfstab.
# 5  
read only

Okay, to boot from the cd is there anything special I most do? On pc's you have to adjust the cmos settings, anything for SUN?

Also, I did look at the /etc/vfstab file, but I don't now what would make be read only...Would it be possible to show me an example of the read only setting?

Thanks for all the help to all.
# 6  
Also

I don't know if this will change anything, but the OS is 4.1.2. I am going to upgrade this but I first need to fix this. Thanks
# 7  
To boot from the CD, simply put the CD in the drive, as toor type halt to bring you down to the OK prompt (or press "stop" & "a" at the same time). From the OK prompt, type;
boot cdrom
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #239
Difficulty: Easy
In March 1970, the ARPANET reached the East Coast of the United States, when an IMP at the Department of Energy in Washington, DC was connected to the network.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Errors while booting

sol10 sendmail : unable to qualify domain name (local host) ---- using short name sol10 sendmail : My unqualified host name (local host) keystore version failure (3 Replies)
Discussion started by: nash
3 Replies

2. Solaris

Dual Booting - Solaris image CD doesn't read in BIOS

I am trying to install solaris 10-x86 as second OS on top of Windows XP. I have downloaded iso image from Oracle website and burned into bootable cd. when I loaded into CD-drive and made changes in BIOS to boot from CD. Its not reading from CD drive. After restarting the system with CD(solaris... (8 Replies)
Discussion started by: SunSolars_admin
8 Replies

3. UNIX and Linux Applications

Problems with booting

Hi, I've just installed Centos 5.3 x86_64 into a CPU. I've done a yum update to update the version to Centos 5.4. I then installed mysql, php, apache and phpmyadmin into the system. After the installation of phpmyadmin the screen suddenly goes blank, but the monitor is still on, and the cpu... (0 Replies)
Discussion started by: anaigini45
0 Replies

4. Solaris

Error while booting the os

ater successfully completeing my solaris 10 installation i am not able boot the machine properly . my machine is continously rebooting after switching on the machine. what the problem ? is it the boot process problem or some other if any body got the solution mail it my email id (11 Replies)
Discussion started by: ravinder singh
11 Replies

5. UNIX for Dummies Questions & Answers

problem booting

Dear List, While I was adding second hard disk to my system, I changed the /etc/fstab file by adding the following line: /mnt/sdb1 /dev/sdb1 ext3 default 2 1 Now system does not boot and gives the following error: Checking filesystems /: Clean, 309260/18495840 files, 1064776/18486790... (2 Replies)
Discussion started by: siavoush
2 Replies

6. Solaris

booting from CD

Hello.. I am Still Learing Solaris .. when i try to Install Solaris 8 from its CD...i pressed STOP + A and i get a OK prompt screen. I then typed, "boot cdrom" and i am getting this error message. " FATAL: system is not bootable, boot command is disabled." How do we enable the boot... (5 Replies)
Discussion started by: vr76413
5 Replies

7. Solaris

booting problem

any one can help me. my system running on solaris 2.7. recently there is sudden power failure while system running. after that unable to boot the system. it is giving comment that "can not open /etc/path_to_inst" and then returning back to "OK" after comment of termination. The processor is... (10 Replies)
Discussion started by: prabir
10 Replies

8. Solaris

Solaris m/c not booting

My Solaris machine is not booting.It just stops at the point Boot device: /pci@1e,600000/ide@d/disk@0,0:a File and args: Whether i try boot or boot -s it is stopping at this point.. I tried boot cdom -s.It went into single user mode but I am not able to run a fsck in this mode. Right... (1 Reply)
Discussion started by: lydiaEd
1 Replies

9. Linux

Problems booting RH 8

I installed RH8 on Thinkpad R51. The install went smooth, but when I tried to boot, it hanged at: PCI_IDE: unknown IDE controller on Pci bus 00 device f9, VID=8086, ID=24ca PCI: Device 00:1f.1 not available because of resource collisions. PCI_IDE: (ide_setup_pci_device:) could not enable... (0 Replies)
Discussion started by: etc
0 Replies

10. UNIX for Dummies Questions & Answers

Booting

Hi all, I've managed to get Mandrake 9 installed by disconnecting my 2 windows' drives. When I reconnect them Mandrake wants to take over. I figure it's time for the BootManager, or should I use a Linux specific one like Lilo? Or have I already stuffed up by not running Lilo at time of... (2 Replies)
Discussion started by: onestepto
2 Replies

Featured Tech Videos