Visit Our UNIX and Linux User Community


Why won't my script run?


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Why won't my script run?
# 1  
Old 04-10-2002
Why won't my script run?

On the following script that I get an error when I try to execute as root:

#./mv_log.sh
bash: /root/util/mv_log.sh: Permission denied


#!/usr/bin
datetag=`date --date='1 day ago' +"%b%d%Y"`

logname=`find /opt/bea/wlserver6.1/config/*/logs/ -iname 'access.log0*' -mtime -1 -print`

mv $logname $logname.$datetag


It will run just fine if I do this

# . ./mv_log.sh

What am I missing? I would like to run this from crontab.
# 2  
Old 04-10-2002
Try checking the file permissions on that script, and changing it as necessary to have execute permissions. Smilie

you could do a "chmod +x mv_log.sh" and it should run.
# 3  
Old 04-11-2002
The first line:
#!/usr/bin
should be #!/usr/bin/sh or #!/usr/bin/ksh, or which ever shell you use.
When run as a script (./script_name), it tries to use /usr/bin as an interpreter, which of course a directory can not do.
When you source it ( . ./script_name ), it takes the # to mean it's a comment, so ignores it and executes the rest.
# 4  
Old 04-11-2002
Also, dont forget to give the full filepath from root in the crontab file (in addition to changing the mode of file as told by doeboy)
# 5  
Old 04-11-2002
Got it working ... Thanks.

The file has permissions set to 770.

I changed to #!/bin/bash and that fixed it.

Thanks LivinFree, doeboy, & inpavan.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #120
Difficulty: Easy
The UNIX certification mark is commercially licensed by AT&T.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Bash script won't run because hardware won't produce display

Can anyone offer any advice on how to modify the script below to work on a new system we have, that has no graphics capability? We admin the system through a serial RAS device. I've tried running the below script through the RAS and through an ssh -X session. It failed with something like "GTK... (3 Replies)
Discussion started by: yelirt5
3 Replies

2. UNIX for Dummies Questions & Answers

tip: Simple script won't run in cygwin - vim editor involved

I ran into this issue and thanks to various postings in various forums, was able to figure out the solution but didn't see one posting that laid the whole issue out cleanly. So thought the following might help others ... ------------------------------------------------------------------------... (2 Replies)
Discussion started by: oxysep
2 Replies

3. Solaris

smc won't run on a regular user

Hi All, I'm getting this all the time with a regular user (after I do su - and smc): It appears you are attempting to run the graphical Solaris Management Console from a terminal which does not have a suitable 'DISPLAY' environment. Please check your 'DISPLAY' settings and that the user... (5 Replies)
Discussion started by: itik
5 Replies

4. UNIX for Dummies Questions & Answers

Made command into a script but now won't run

Hello, After seeing in a Unix cheatsheet that I could add commands into a file and run that file as a command to save on typing, i tried it with this: #! /bin/csh # Backup website excluding directories that do not change rsync -e "ssh -p 2222" -axzvc --progress --stats --compress-level=9... (9 Replies)
Discussion started by: patwa
9 Replies

5. UNIX for Dummies Questions & Answers

Cron won't run properly

I am new to unix, and this is my 1st post on this board. Looking for some advice about a cron job in my server. I am running a cron task that references a script which runs several other scripts and compiles them into a report and emails it to me. If I run the script manually, I will... (2 Replies)
Discussion started by: Steeler_fan
2 Replies

6. UNIX Desktop Questions & Answers

SuSE 8.0...I can't get SaX2 to start on Hercules 128 and YaST2 won't set up X either.

I'm trying to set up a school Linux computer and use Samba to link it to Windows NT. Pentium-133 Hercules 8 meg Stingray 128/3D I'm not too familiar with SuSE's config tools (more used to Mandrake) and so am having some trouble configuring X. SaX2 just won't start, even when I use "sax2... (1 Reply)
Discussion started by: HumanBeanDip
1 Replies

7. UNIX for Dummies Questions & Answers

Backup Exec agent won't start... PLEASE HELP!

Backup Exec Agent won't start.... Question: Has anyone had any previous experience working with Backup exec for Unix? I'm running SCO Openserver 5.0.5 and Backup Exec agent Version 5.01 Revision 5.032 Basically, these are the commands I'm issueing and here is the output. # cd etc # cd... (1 Reply)
Discussion started by: PatMcCoy
1 Replies

8. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

9. UNIX for Dummies Questions & Answers

mandrake 8.0 experts...how come it won't accept changes to security settings??

well after a possible hack last week that was a pain in the as* i have reinstalled and i am setting up my security settings before i connect to the internet this time... problem is that when i try to change the security setting using in the control setting the left panel (where the change is... (2 Replies)
Discussion started by: justchillin
2 Replies

10. UNIX for Dummies Questions & Answers

How to subtract 2 hours from 'date' in shell ( /bin/sh ) script ?

I write a sh script that zip and copy to tape all files that older then 2 hours. 1. The way I choose is - touch a file with "now - 2 hours", then use fine with '! -newer' 2. Do you have any other idea to do it ? tnx. (1 Reply)
Discussion started by: yairon
1 Replies

Featured Tech Videos