Unix 10.2 Backup Problem

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Unix 10.2 Backup Problem
# 1  
Old 01-29-2008
Unix 10.2 Backup Problem

We have an older HP Unix 10.20 system that we rarely ever use anymore. Most of our jobs on it are from 1994 to 2002. Anything after that is on Windows XP. The Unix system was backed up religiously every day. Because of space constraints some of the jobs were removed from the system after a complete tape backup.

About a year ago the tape backup failed internally. (A spring and tray mechanism that ejects the tape). We ordered a new one that was identical to the old and hooked it up and tried to backup. Everything worked ok. The problem we have is now two fold. Any old tapes we have, including the archive stuff removed from the system, doesn't seem to work with this tape drive. It keeps giving the “out of phase” error. I was in the process of trying some of the other backups we have that are even older to find this one particular job when we developed another problem. As soon as I enter the command to restore something off of the tape I get the following message:

“End of Volume”
“If you want to go one, type device/file name when ready”

I have restarted the system and still get this message. It is not even hitting the tape drive or trying the tape.

The command to backup the system originally is:

Find filename | cpio -ovxdB > /dev/dds

The command I am using to restore is:

cpio -ivxdB ‘filename' < /dev/dds


cpio -ivxdBR ‘filename' < /dev/dds

System is using HP Unix 10.20 with DAT tape drive

To summarize problem 1 is an out of phase error on older tapes with new backup drive. Problem 2 developed after man attempts to solve problem 1 and gives the “End of Volume” message after immediately starting restore sequence.

Any help would be appreciated as I am no UNIX or Computer Expert.

# 2  
Old 01-29-2008
You dont say much about the system..
Which make things difficult to be of any help...
OK the OS is a hpux 10.20 but what kind of boxe? (and so hardware...)
was the original DAT an internal tape (which then would be /dev/rmt/0m... and so you should find your /dev/DDS being a link...)
Now has is it plugged on the box?
Who did the connecting?
# 3  
Old 01-29-2008
The system is a HP B132L with two external hardrives and an external tape drive. The tape Drive is last in the chain. It is a HP C2954D which is identical to the one it repalced. The tape does work. If I type backup at the command prompt it will immediately begin writing files to the tape drive. It just won't operate in restore mode.
# 4  
Old 01-29-2008
Not sure what to advise you (english isnt my language so forgive my mistakes...)
- backup isnt what we can call a standard command, I suppose you will see by typing file <path>backup as a script... and so I dont know what it does exactly...

- I suppose to go through as I would with such issue:
Get a tape head cleaner and have a go at cleaning the device
Prepare a new tape and insert it in the device

I dont know what commands are on a B class (worksation serie 700) I know only 800 (servers) but if you have fbackup/frecover command I would do a man and try to use these commands
Also tapes depending of which device was used DO NOT rewind after... and this may be why you cannot restore

I would do an ioscan -funC tape and it should display something like:
/sm/doc # ioscan -funC tape
Class I H/W Path Driver S/W State H/W Type Description
tape 0 8/16/5.0.0 stape CLAIMED DEVICE HP C1533A
/dev/rmt/0m /dev/rmt/c1t0d0BEST
/dev/rmt/0mb /dev/rmt/c1t0d0BESTb
/dev/rmt/0mn /dev/rmt/c1t0d0BESTn
/dev/rmt/0mnb /dev/rmt/c1t0d0BESTnb
You should have your device on /dev/rmt/XmY
Y= <blank>, b, n, nb
the meaning of Y is b for best n for no rewind
the idea is once we know what device to use, lets say /dev/rmt/1m
we use the no rewind device in order to use the mt command
once ready lets see if the tape is at the beginning:
mt -t /dev/rmt/1mn rew
# What is the result? (is it rewinding? proving you were at the end of writing explaining why it had nothing the restore?)
mt -t /dev/rmt/1mn offl to after, eject the tape.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Ubuntu

Backup setting problem

the way that i use to backup my server is using the script below in ssh. mysqldump --opt -Q -u username -p password > /var/www/squiro/sql/database.sql but i want to set the server backup everyday at 1pm in same folder. is that set it in crontab-e? how to set it? (3 Replies)
Discussion started by: mampwamp
3 Replies

2. Shell Programming and Scripting

rsync backup mode(--backup) Are there any options to remove backup folders on successful deployment?

Hi Everyone, we are running rsync with --backup mode, Are there any rsync options to remove backup folders on successful deployment? Thanks in adv. (0 Replies)
Discussion started by: MVEERA
0 Replies

3. Ubuntu

problem in backup

Hi I am using Ubuntu back up program to the back up automatic. Problem is that recently the app start to fail. I get the following message: Traceback (most recent call last): File "/usr/bin/duplicity", line 1359, in <module> with_tempdir(main) File "/usr/bin/duplicity", line 1342,... (1 Reply)
Discussion started by: programAngel
1 Replies

4. Shell Programming and Scripting

Please : Script Backup Problem

I have script but not work.. ===================================== #!/bin/bash # backup Backup_Dirs="/home/test" Backup_Dest_Dir=/tmp Backup_Date=`date +%b%d%y` #Create Backup tar cvzf $Backup_Date.tar.gz $Backup_Dirs $Backup_Dest_Dir ====================================== What's... (1 Reply)
Discussion started by: mbah_jiman
1 Replies

5. Shell Programming and Scripting

Problem with backup script

Hi, Following is the script I made for backing up Cpanel server. ================================================ #! /bin/bash rsync -raopguzl --delete --exclude "*.tar.gz" --progress --delete-excluded root@$hostname:/$otherdir/$i/ /mnt/iscsi/$hostname/home/$i done ... (6 Replies)
Discussion started by: mohitmoudgil
6 Replies

6. UNIX and Linux Applications

Problem with Database backup

Hi! This is my first post and im not that familiar with UNIX but I'll try to explain my problem.. I have a server here at work running Open UNIX Release 8.0.0 It has a special application on it that I'm trying to run a database backup on. For the last 2 weeks this has failed.. Usually the... (2 Replies)
Discussion started by: TaZ
2 Replies

7. UNIX for Dummies Questions & Answers

Tape Backup Problem?

Hi. Can someone please tell what the following tape error message means: Read end of medium on output If you want to go on, type device/file name when ready This message comes after the terminal displays a few files from the directory I'm trying to backup. The command I'm running is: ... (1 Reply)
Discussion started by: cstovall
1 Replies

8. UNIX for Advanced & Expert Users

Backup problem---Again

I tried backing up my mailserver on my nsrhost using solstice backup 5.5.1 software. After creating the usual custom settings, and starting the backup procedure using the group control button, backup initializes but the group backup becomes suspended. When i click on the details radio button in... (4 Replies)
Discussion started by: lealyz
4 Replies

9. UNIX for Advanced & Expert Users

Backup problem---Again

I am running my solstice backup 5.5.1 server on a solaris 2.6 platform. I have a remote client ; my mailserver also running solaris 2.6. I created a unique pool and group for my mailserver, but when i label to pool, mount and run backup, it doesnt backup my mailserver, rather it gives me error... (10 Replies)
Discussion started by: lealyz
10 Replies

10. UNIX for Dummies Questions & Answers

backup problem

Hi all what may be the cause when i try to restore the backup (TAR) It's giving error tar block size =1 directory checksum error please suggest as soon as possible try n learn praful (4 Replies)
Discussion started by: Prafulla
4 Replies
Login or Register to Ask a Question