Visit Our UNIX and Linux User Community


Using Linux on/in a home network


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Using Linux on/in a home network
# 1  
Old 12-18-2007
Tools Using Linux on/in a home network

I recently received an e-mail from "the faculty" at Unix-dot-Com and I was reminded of this notable resource for folks learning about Unix and its clone, Linux. I hadn't posted anything in two years and during that time, I have been working, in my spare time, on a home network combining two Linux computers and one with Windows XP-SP2. I still don't know if I can call myself an expert, but the solution to that printer problem mentioned in my last posting seems pretty obvious today. Smilie

Two critical points in my work over the past two years have been "discovering" the smb.conf SAMBA configuration file and that not all Linux distros(and versions of distros) are created equal.

Mandriva Linux 2005 LE was not a good choice for what I was trying to do back then(integrate a Linux computer into an existing Windows network as a Linux "newbie"). Ubuntu Linux(versions 6.10, 7.04 and 7.10) currently does a lot of this intergration "out of the box", as well as installing and configuring SAMBA. That doesn't mean that more current versions of Mandriva Linux wouldn't be better or that I wouldn't have done better with those older versions if I had known then what I know now.

However sobering--or even unpleasant--it may be, when you run into the limits of your knowledge, you have the opportunity to learn something new and, hopefully, valuable.

Recently, I have run into something that has me perplexed.

I have a Wi-Fi(IEEE 802.11g) segment within my home network. My home network is interconnected by a Linksys WRT-54G switch-router/wireless access point. Using the same hardware which I have now, I could locate a desktop machine(running Windows XP-SP2) anywhere in my house and it could both use WEP(it's better than nothing) encryption and Wi-Fi. But when I put Ubuntu Linux 6.10 on that same "box", the signal strength which the client "saw" seemed to drop and I couldn't connect to the router without disabling WEP. This same behavior has continued through Ubuntu Linux versions 7.04 and 7.10, too. If I moved the desktop machine using Linux into the same room as the router, I found that I could again use WEP. Frankly, I haven't tried WPA or any of the other encryption standards for Wi-Fi. My current working assumption is that any form of encryption will require a little more signal strength to work properly.

To answer an obvious question, I have thought of buying a Wi-Fi signal booster, but I haven't tried that yet.

In my current configuration, I have disabled WEP, but I'm using MAC Address Filtering and I have disabled ESSID broadcast, which probably furnishes adequate security for a moderately large city in Southern Oregon, which is where I live. On the other hand, if I were still living in the San Francisco Bay Area, I would expect to be "smashed like a toad in the road" without some form of encryption on the Wi-Fi segment of my home network.

Does someone know of anything in Ubuntu Linux or its drivers which could account for this? Do you have any suggestions outside of suggesting that I stop being so "cheap" and buy a Wi-Fi signal booster? Has anyone had similar problems with signal strength, Wi-Fi and Linux?

Last edited by Annatar; 12-18-2007 at 01:17 PM..
Annatar
# 2  
Old 12-20-2007
I would suggest you ask your Mandriva and Ubuntu questions in their respective forums.

Ubuntu Forums
Mandriva Club Forum

Cheers....Cassj
# 3  
Old 12-24-2007
Here Is What I Did About This

Smilie Even I sometimes solve a problem in the simplest and most direct way. On a recent shopping trip to Fry's Electronics in Wilsonville(Oregon), I purchased a Hawking Omidirectional Antenna for $24. (To be candid, I also bought myself three PS/2 keyboards and a package of fifty slim CD jewelcases, but that is another story.)

Within a couple of hours of arriving home, I restarted my wireless networking with WEP Encryption and installed the new antenna on my desktop machine(Wolfsberg). When I did this, everything worked perfectly, although I am still not sure what caused the original problem. Here are some of the possibilities:
1. A driver issue--one note in the Ubuntu Wikipedia suggested a radical change in the driver setup, using an "NDISWRAPPER" moeity;
2. The original antenna which came with the Linksys 802.11g/PCI card was perhaps in a bad physical location, on the back of a fairly large(full tower PC) metallic case and next to several wires at its back(video, audio output and USB trackball)--the current antenna is a couple of feet away and on top of my "lab bench".

I would like to thank CASSJ for his suggestion. I did, in fact, check those resources out, although my stated problem was solved by a different route, this time.
Annatar
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #10
Difficulty: Easy
Charles Babbage was a British mathematician and inventor, known as the 'Father of the Computer'. He designed a mechanical computer called the Analytical Engine which was an early forerunner of the modern computer.
True or False?

9 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Setting up a home network for learning Linux

I am working on learning Linux, and somebody suggested setting up Linux on a separate computer, and searching for answers to whatever may be needed, on a different computer plugged in to the Internet. I have a Windows 7 PC, plugged in to a cable modem, and an old notebook, Compaq Presario R3000... (5 Replies)
Discussion started by: AdultFoundry
5 Replies

2. IP Networking

DHCP and DNS on a home network

Let's say I have a home network containing a server that acts as the resident gateway and serves dhcp and dns requests. Laptop A is frequently connected and disconnected from the network as it is used as a travel computer. Is there a secure way to make sure that whenever laptop A is connected to... (3 Replies)
Discussion started by: Zygomorph
3 Replies

3. IP Networking

Help building a home network needed.

I have one computer with internet connection and printers that I would like to connect to another computer to use as a practice/test Server. I would like the server to access the other computer by a direct connection of some sort because I don't see the point of aquiring the hardward (ethernet... (5 Replies)
Discussion started by: theKbStockpiler
5 Replies

4. IP Networking

ssh into home network

I am trying to ssh from my computer at work into my home PC. My work computer is running mac os x 10.6.3, home PC is running ubuntu. At home I have multiple PC's hooked up through a router and modem. I have gone into the router settings and set up port forwarding to forward ports 22 and 175 to... (9 Replies)
Discussion started by: bluejayek
9 Replies

5. Linux

Need help w/home network

Hello world! I'm writing to you from Chile, Southamerica, and need a little help with my tiny home netwk. Hope you can give me a hand because this thing is breaking my balls. This is what i have: 1 windows box with XP pro (server) 1 linux box with DSL (box) 1 wrt54gl router with dd-wrt... (1 Reply)
Discussion started by: juanpedro
1 Replies

6. UNIX for Dummies Questions & Answers

Need help to configure routing on home network

I have a Windows laptop and a Sparc desktop. I'm trying to toy around with routing. If have always on broadband from BT. My router ipaddress is: 192.168.1.1 This router uses DHCP. My Laptop Ip is as follows: Ethernet adapter Local Area Connection: Connection-specific DNS Suffix . :... (2 Replies)
Discussion started by: Kongowea
2 Replies

7. IP Networking

Printer Sharing on a Mixed(Windows/Linux) Home Network

Sometimes you get the tiger...but sometimes he get you and this latest home network “project” of mine has gnawed on me pretty badly. Perhaps you can offer some technical help. It will be heartily appreciated. I have a small home network initially comprising two computers running Windows... (1 Reply)
Discussion started by: Annatar
1 Replies

8. Windows & DOS: Issues & Discussions

XP Pro: home network

having trouble with my home XP Network. I have 2 machine running xp but the server cant access or see the second computer. Both can ping each other and i have file and printer sharing installed. HD'S are sharded. Any ideas ? (2 Replies)
Discussion started by: perleo
2 Replies

9. IP Networking

home network not working!

i just linked 2 100MHz Linux kernel 2.4.2 boxes togeather using a direct cable connection, on two 3Com PCI network cards, using the EtherLink III chipset. Unfortuanately, when I boot both PCs, i get a loading interface: eth0 for five minutes, then a failed flag. No networking suppt. in windows,... (2 Replies)
Discussion started by: boris888
2 Replies

Featured Tech Videos