Visit Our UNIX and Linux User Community


bus error (coredump)


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers bus error (coredump)
# 1  
Old 12-12-2007
bus error (coredump)

Hi all,

I am getting bus error problem in SunOS. Can you please help me out in this regard.
Actually, my entire code till the last line has been executed. But after tht i am getting a bus error. Please help me.

Thanks in advance.
Charu.

Last edited by blowtorch; 12-12-2007 at 03:42 AM..
# 2  
Old 12-12-2007
Hi charu, I suggest you start a new thread for a problem if you do not get a solution after searching through older threads. I have split the thread and seperated your post.

Can you explain in more detail here? Are you getting a bus error only when you login through telnet? Does the error occur even if you do nothing? Or is this error coming from your own program?
# 3  
Old 12-12-2007
My program is written at the client end and this program sends some data to the server side...and also update some database. Everything is working fine...till the updation as well. Infact, just before the closing braces of main() I had given a print statement, tht is also getting executed properly. But however, i get the bus error after tht. So I am unable to find the reason.
# 4  
Old 12-12-2007
I suggest you open the program and the core dump with a debugger.
# 5  
Old 12-12-2007
My code uses CORBA. So, its a CORBA with C++. Well, when I ran the executable using dbx I found the following error. Couldnt comprehend what it means. Kindly help.

$> dbx EprovInputClient core
program terminated by signal BUS (invalid address alignment)
(dbx) where -q
=>[1] CORBA::PPTR::_marker(void) const
[2] COTClass::unload(void)
[3] CORBA::LoaderListClass::~LoaderListClass(void)
[4] __STATIC_DESTRUCTOR(void)
[5] _fini()
[6] 0xef7cae28()
[7] 0xef7caf0c()
[8] _exithandle()
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #996
Difficulty: Medium
Major Unix vendors, including Sun Microsystems, HP, IBM, and SGI, have been selling virtualized hardware since before 1990.
True or False?

10 More Discussions You Might Find Interesting

1. Programming

Bus Error: 10...Help please!

Hi all, I am writing a phonebook program to store names and number using a list. Here is the code for the function which allows the user to enter the name and number (where the error occurs). //THIS FUNCTION ADDS A NEW ENTRY TO THE phonebook_list void insert(void){ //variables int... (5 Replies)
Discussion started by: kdejan
5 Replies

2. Programming

Bus error

Hi everyone, I have a GUI project and when I run it and left in idle state for a long time(there is nothing done, just opened GUI, no more actions),I get bus error after trying to do anything with it. I've tried to build it in debug mode and use gdb, but I don't get any error in debug mode.It... (3 Replies)
Discussion started by: sisi
3 Replies

3. HP-UX

Bus Error

I am getting bus error when i include "#!/bin/ksh". If i remove interpreter then script is working. Can anyone explain this and how can i avoid this error? Operating System is HP-UX B.11.23 U 9000/800 1091834454 (2 Replies)
Discussion started by: anbu23
2 Replies

4. HP-UX

Need help on Bus error(coredump)

Hi all, I am quite weak in C but I need to get some work done. Hope someone can help me out. I keep getting this error when i try to run my C application in my HP-UX 10.20 machine. Some code snippet: Month(DBTime) =====This is a function which will return variable "CutOffTime" to be use... (5 Replies)
Discussion started by: Vision©
5 Replies

5. UNIX for Advanced & Expert Users

Segmentation (CoreDump) error !!

Hi all, I am trying to create few directories using script and its giving me segmentation error. #!/bin/ksh createDirectories() createDirectories() { cat dirs | \ while read line do mkdir... (16 Replies)
Discussion started by: varungupta
16 Replies

6. UNIX for Advanced & Expert Users

Bus error(coredump) while running SQL*Loader in HP Unix 11

Hi All, I am getting coredump error, when I try to execute Oracle SQL*Loader from Shell script in Unix environment. But SQL*Loader from local machine runs fine with same database. SQL*Loader: Release 9.2.0.6.0 - Production on Mon Apr 23 05:23:47 2007 Copyright (c) 1982, 2002, Oracle... (3 Replies)
Discussion started by: srinivas_paluku
3 Replies

7. Programming

BUS error

Hi! I've got a program which runs fine under Linux, but I have compiled it to run under SunOS 5.8 in a Sparc computer, and now it sometimes fails with "bus error". Ussing gdb I surfed to the error line, which is *pointer = some_vector; where some_vector is a 16 byte struct (4 integers)... (1 Reply)
Discussion started by: shesatmine
1 Replies

8. UNIX for Advanced & Expert Users

Bus Error(coredump)

Hi, I am using HP-UX. While i try to run the Sqlplus command using the shel script in encounter the following error: <shell script name>: some number Bus Error(coredump) What may be the reason behind this. I read few previous threads in this forum where i found some similar case. There it was... (2 Replies)
Discussion started by: Jayesh
2 Replies

9. UNIX for Dummies Questions & Answers

Bus error(coredump

aix 5.3 ML1 system was functioing well, when suddenly telnet session hung and then I got the following message "Bus error(coredump)" would appreciate if anyone would assist as to what to do next. (3 Replies)
Discussion started by: Student37
3 Replies

10. UNIX for Dummies Questions & Answers

Bus Error

This may belong in the C Programming forum, but here goes anyway... What would cause a bus error? I searched google for a cause, but came up with some conflicting reports... Could it be caused by disk space? A lot of the pages I found mentioned linking with the incorrect versions of the... (4 Replies)
Discussion started by: LivinFree
4 Replies

Featured Tech Videos