Root cannot change /home permission

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Root cannot change /home permission
# 1  
Old 10-31-2007
Root cannot change /home permission

I'm a root but i couldn't change /home directory permission or group. i'm getting operation not permitted.
Any help?
# 2  
Old 10-31-2007

/home is manged by the autofs daemon to mount the home directorys of the user.
You can change it by change the auto files /etc/auto*
Best regards
# 3  
Old 10-31-2007
I see two files "auto_home & auto_master"
what changes i can make?

auto_home says:

auto_master says:
/net -hosts -nosuid,nobrowse
/home auto_home -nobrowse
# 4  
Old 10-31-2007
Delete the last entry inside the auto_master or hash it out!

# /home auto_home -nobrowse

Best regards

# 5  
Old 10-31-2007
I did the changes. then i restarted autofs daemon with no luck.

root 3457 0.0 0.1 4392 988 ? S 10:03:43 0:00 /usr/lib/autofs/automountd
root 3458 0.0 0.1 4736 1728 ? S 10:03:43 0:00 /usr/lib/autofs/automountd
# 6  
Old 10-31-2007
Maybe you need a reboot of the system?!
If it is solaris 10:
svcadm restart svc:/system/filesystem/autofs:default

Best regard joerg
# 7  
Old 10-31-2007
It worked. Thanks a lot
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Can a root role change the root password in Solaris 10?

i do not have root on a solairs 10 server , however i do have the root role, i was wondering if I can change the root password as a a role with the passwd command? I have not tried yet. and do i have to use the # chgkey -p afterwards? i need to patch is why i am asking. thanks (1 Reply)
Discussion started by: goya
1 Replies

2. HP-UX

Sudo entry required to set permission similar to ROOT without using password (PASSWD) change optio

Hi All I had installed sudo in HP UX 11.3 and it is working fine but not able to make entry required to set permission similar to ROOT without using password (PASSWD) change option for define user in /etc/sudoers file Please help if some know the syntex? :confused::wall: (2 Replies)
Discussion started by: deviltech
2 Replies

3. Shell Programming and Scripting

Find users with root UID or GID or root home

I need to list users in /etc/passwd with root's GID or UID or /root as home directory If we have these entries in /etc/passwd root:x:0:0:root:/root:/bin/bash rootgooduser1:x:100:100::/home/gooduser1:/bin/bash baduser1:x:0:300::/home/baduser1:/bin/bash... (6 Replies)
Discussion started by: anil510
6 Replies

4. BSD

FreeBSD abnormal permission changes in /home

Hi, I have a bit of a headache with a server doing some rather mysterious yet static changes to permissions in /home. The server in question is a FreeBSD server. It's an older beast with quite a few custom tweaks and now I'm stuck with it :-) The problem is that some of the directories in... (2 Replies)
Discussion started by: brightstorm
2 Replies

5. HP-UX

could not able change permission of /home dir

Hi i am new to this admin area . i have created user with name as "ab" and gave home dir as /home/ab . when i tried to create the /home/ab dir , i got he following error. "mkdir: Failed to make directory "/home/ab"; Operation not applicable " Thanks in advance . (1 Reply)
Discussion started by: expert
1 Replies

6. Solaris

how to change /export/home/user dir to /home /user in solaris

Hi all i am using solaris 10, i am creating user with useradd -d/home/user -m -s /bin/sh user user is created with in the following path /export/home/user (auto mount) i need the user to be created like this (/home as default home directory ) useradd -d /home/user -m -s /bin/sh... (2 Replies)
Discussion started by: kalyankalyan
2 Replies

7. Solaris

cant able to change permission in a DIR as root user

Hi my directory not accepting any commands. its simply telling permission denied. i tried ( cp, mv, rm ) as roor i want to set default permissons to this DIR please find the Logs below. dr-xr-xr-x 1 root root 1 Jun 1 09:04 AP1_ROP ( original dir) root> chmod 777... (5 Replies)
Discussion started by: vijayq8
5 Replies

8. Solaris

root can not change the permission of old oracle archive directory in solaris 8

I am using oracle 9i with sun solaris 8 on Sun E 250 server.earlier we are taking backup of oracle archive files on /orabackup which archive file are stored with ...arc.Z extension. now we have changed the archive backup when we are trying to delete earlier directory... (3 Replies)
Discussion started by: mahanalok
3 Replies

9. Shell Programming and Scripting

how to display the permission of the home directory

can anyone tell me how to display the permissions of a users home directory. can i use ls -l but it only gives the permissions of the files and directories inside the directory..:confused::confused::confused::confused: (9 Replies)
Discussion started by: nadman123
9 Replies

10. UNIX for Advanced & Expert Users

ssh home directory permission

Hi All, I am using sftp to transfer files between two unix machines. As per my knowledge, in order to use public key authentication, the remote user's home directory permission should be set to 750 ( basically group and others should not have write permission ). Is there any way to over ride... (1 Reply)
Discussion started by: shihabvk
1 Replies
Login or Register to Ask a Question