Visit Our UNIX and Linux User Community


Mandrake 8.1 + W98SE Problem


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Mandrake 8.1 + W98SE Problem
# 1  
Old 01-25-2002
Question Mandrake 8.1 + W98SE Problem

Sup
Ok, here is the problem.
I bought Linux Manrake v.8.1 Power Pack Edition
I booted it up, and got to the partitioning part of the installation. As Manrake users would know, there are several options that you can install with. There is Custom Patitioning, Format and load w/ Linux on it, add to existing Linux Partition, re-size from windows partition, and several others that are irelevent. Since my parents like windows (WIMPS), I had no choice but to do the Re-size from existing partition. Promlem #1: Option isn't there! There is no option for me to do this, but it IS in the manuel. So I talk to tech support, and they say to get some software and use that to create a partition...So I do. So I get Partition Magic, and create a Linux partition. So I go back the to the installer, and it recognizes it. I get the OS installed without a hitch. Then I gotta restart. Problem #2: Windows doesnt show up on the boot screen. There are only 3 options. 1. Boot Linux. 2. Boot Linux into Safe Mode. 3. Rescue (Or something similar, bad memory). So I figure, I'll get into Linux and find out how to get into Windows later. So I click Boot Linux. Takes quite a while to load, but no longer than Windows, so I'm starting to feel pretty good about this. Problem #3 I get to the text based OS! There is nothing in the book about this, and it keeps constantly refreshing. I can log in, but I can't get into the GUI. So I gave up. I uninstalled it. Problem #4 STILL HAD THE BOOT SCREEN. So from there what I did is popped in my W98SE CD, and re-installed Windows without formatting. My computer is running fine now (at least all that can be expected from Windows), but I want to know what went wrong. All help is greatly appreciated. Thanks in advance guys!

Justin

Gateway Essencial 550
Pentium III 550 mHz
320 Meg SDRAM
14.3 Gig HD
nVidia TNT2 32 Meg Video Card
# 2  
Old 01-28-2002
install mandrake

I have installed mandrake before Ver 6.x last year on a Dell system and didn't experience any problems.

Let me tell you how I did it.

My box was a Dell Latitude P3 500MHZ 13G 128Mb memory, 16 MB Diamond Viper Video Card.

I believe that I started by loading the Partition Magic, included with mine. I configured the new linux partition by shrinking my existing 13G hard drive and creating a 4GB Linux partition.

Then I booted with the Linux install disk in the drive and the CD in the CDROM. It came up with the install and I did it as directed.

However, near the end of the install, I chose to boot Linux from a disk, LILO disk, and not from within the system during startup. This way I can boot normally to WIN98SE if I remove the disk from my A drive.

Regarding your text only question. My Linux came up with the "windows" emulation with my video card. You may want to check the release of Linux you bought to make sure that the hardware is compatible.

Hope my experience helps you.



Smilie
# 3  
Old 01-28-2002
Well we all got to learn somewhere don't we? I've been there done most of that!

When you didn't have windows in the boot option thats because your 'lilo' couldn't see windows. You need to edit the lilo it can be found in "/etc/lilo" (so at console type "vi /etc/lilo") in there you need to add the lines for lilo to see windows to boot. Before editing this file though you need to know what hdaX your windows partition is on! E.G hda1=windows hda2=linux hda3=swap etc etc! Once you've added the correct lines into lilo go to "/etc/sbin" and just type "lilo" that should then make the changes and tell you if it has ben added correctly or if there was a problem! Make a backup of the lilo file before you write it!

With the graphics problem and screen could be because you picked the wrong graphics chipset in the install. At the console type "xconfigurator" then you can change the configuration of your linux box! (just a little tip if you type "xcon" then hit {tab} it should finsih the command off as long as only one command will end with "figurator" if 2 commands end with just the "fig" part in it, it still wont work)

Still after deleting linux your lilo if still there. This is due to your lilo be written into the master boot record (MBR). Few ways you can clean this out. Best easy way I have found is using the only thing Bill Gates made that is good. A windows 98 startup disk. Put the disk in boot the computer at DOS prompt type "fdisk /mbr" That should clean your MBR. Don't have to boot from it but if you can't get to a DOS prompt any other way boot from if!

Well hope that helps you out a little.

:-)
merlin
# 4  
Old 01-29-2002
THANX ALOT GUYS

YOU GUYS ARE GREAT! I havnt installed it yet and probably can't because my parents dont want me screwing up the computer any more than M$ Winblows already has. I think I'm gonna buy a refurbished dell and work up from there. Im gonna have fun! Thanks again guys. Keep up the good work!

BTW: Should I go with Celeron, a PIII, or a P4?
Also: How do I get to the command prompt during the install?
THANK AGAIN!
# 5  
Old 01-29-2002
One note about your Mandrake install... I have a similar setup (Mandrake 7.0 and Windows 98) and it works fine, but i hosed the 98 side the first time i did it. As merlin said, you have to edit lilo or possibly grub in your case to recognize the windows boot record.

Secondly, you can usually choose whether you will start up in the text-based OS or the graphic based OS... personally, i like the text-based because it's easy to do some quick and easy tasks before i head into the graphical based side. If you're not comfortable with the text-based, you might want to familiarize yourself with it, because it's the most powerful portion of Linux and you can become very efficient and productive with it.

Personally, I'd stick with an AMD processor, but that's just me... if i had to pick betweent the PIII and P4, or even (the dreaded) celeron, i'd say it's based on your needs and funds.

I'm guessing you're talkin about a command prompt during the install... which with mandrake, i'm not sure you can do, unless you do the entire instill from the command line (which again, i'm not sure if you can do that)
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #308
Difficulty: Easy
The first computer bug was created by a broken keyboard input.
True or False?

10 More Discussions You Might Find Interesting

1. Linux

Mandrake 8.00 installation/Booting problem...Plz Help

Hey everyone, I'm new to the forum. I have a problem with Mandrake 8.00; i have installed it on my old PC with no problems (none mentioned) but on re-booting after the installation it just hangs after listing the devices: Hard Disk, CD-ROM & Floppy A. I have installed it on Packard Bell with... (2 Replies)
Discussion started by: sybella1
2 Replies

2. Linux

mandrake

I just installed mandrake 9.2, and all I want right now is for gaim to allow me to use msn.. The version I got now is 0.59.? and I have tried to get the latest version but when I downloaded the rpm it said that there were errors... can someone help... for my rpm packaging I have went to Urpmi and... (3 Replies)
Discussion started by: flimzzy
3 Replies

3. SuSE

mandrake problem

ihave mandrake 9.2 (will upgrade soon to 10) but anyways, i can't get the Hard drive or the CD-ROM or Floppy to show up on the desktop. can anyone help me out? (11 Replies)
Discussion started by: linux_newbe
11 Replies

4. UNIX for Dummies Questions & Answers

mandrake 10

i just got mandrake 10 and i installed xine the latest why does it crash my xserver and how do i fix this problem in mandrake 8 - 9.2 i had no problmes with xine until now with 10 (2 Replies)
Discussion started by: amicrawler2004
2 Replies

5. UNIX for Advanced & Expert Users

Problem with installing mandrake 7.2

I was trying to install mandrake 7.2 in my newly brought used intel pentium III processor with no operating system installed in it. In the boot sequence in the BIOS there is no "boot from the cdrom" option so I made a "boot disk" to boot from the floppy drive. While booting from the floppy I got... (2 Replies)
Discussion started by: cyno
2 Replies

6. UNIX for Dummies Questions & Answers

need help mandrake os

my hdd root dir keeps dumping on me but when i install i use native linux format i i lost again yesterday is there a recovery methead? or a safe mode that i can go into ? i made a boot disk is it wise to let the formater program to auto alcate? give me a 5gb root drive and a 37gb home i relly... (1 Reply)
Discussion started by: amicrawler2000
1 Replies

7. UNIX for Dummies Questions & Answers

Mandrake

I read the old posts about dual booting windows and linux, and I just wanted to clarify something: If I buy the mandrake version of linux, will that by itself partition the hard drive, or do I still have to get a copy of partition magic? If the mandrake version can do it, is it an easy process? ... (6 Replies)
Discussion started by: luke314pi
6 Replies

8. UNIX for Dummies Questions & Answers

mandrake and os X

can i run mac os X stuff in mandrake? on a intel computer? (1 Reply)
Discussion started by: amicrawler
1 Replies

9. UNIX for Dummies Questions & Answers

Here's the fix for the SiS 7012/7018 sound problem in Mandrake 8.2

Edit your /etc/modules.conf file to either remove or comment out the two lines : alias sound-slot-0 snd-card-intel8x0 above snd-card-intel8x0 snd-pcm-oss ...and replace them with the following line: alias sound i810_audio ....viola! After saving and rebooting, now I gots da sound!... (0 Replies)
Discussion started by: DownSouthMoe
0 Replies

10. UNIX Desktop Questions & Answers

Mandrake 8.1

Hi all, I have copied three .ISO files for Mandrake 8.1 from a Linux DVD onto my work LAN. They are: Mandrake81-cd1-inst.I586.iso Mandrake81-cd2-ext.I586.iso Mandrake81-cd3-supp.I586.isoThey're all +650M in size and I'd like to know what I need to do in order to create the three CD's... (3 Replies)
Discussion started by: Cameron
3 Replies

Featured Tech Videos