Visit Our UNIX and Linux User Community


scp error


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers scp error
# 1  
Old 01-16-2002
scp error

I am looking for a way to transfer entire folders from a Unix server to my mac OS X system. I am trying to use scp with the command % scp -r (user@host):dir . and it diesn't seem to work. I get the error "protocol error: mtime.sec not delimited" Thanks for any help.
# 2  
Old 01-16-2002
It looks (by your prompt) that you're using the csh, or a variant thereof. I'm not very familiar with scp, but a quick google gave me two results - one of them follows:
http://mail-index.netbsd.org/netbsd-...0/02/0016.html
The other was similar, but posed as a question and provided no answer.

Hope this helps a little...
# 3  
Old 01-16-2002
I have already found this myself but it doesn't help very much. Are there any other options for transferring entie dir's?Smilie
# 4  
Old 01-16-2002
What about tar / ftp ?
Code:
tar zcf ./mydir.tgz /path/to/mydir
ftp my_box
     user passwd
     put mydir.tgz
     bye
telnet my_box
     user passwd
     tar zxf mydir.tgz
     exit

It's a little more work, but you also have even more control over each step... Good in a pinch, and reliable if both services are running... If you still want to be secure, see if you can get sftp and ssh up and running - they should come with the shh distribution.
# 5  
Old 01-16-2002
This looks interesting but could you give me a little better description of how I can impliment this? As you can see I am new to unix, but thank you for your time!
# 6  
Old 01-17-2002
Basically, you use tar (used originally to create Tape ARchives) to bundle one or more files or entire directories into a single file. Then you can ftp them to the remote machine. After that, you can log in (using telnet or ssh) to the remote machine, and unpack the file wherever you want it.
For more exact info for your system, check out the man pages for ftp, telnet, and tar.

(A useful command, just in case:
man man)
# 7  
Old 01-17-2002
Tools

I'll give it a try thank you!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #757
Difficulty: Medium
The MOSFET is the least common semiconductor device in digital and analog circuits.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Error during scp

Help needed for scp error. I tried to scp a file from a server to another with scp command, but I receive a error message "Non-Interactive Shell Disallowed!". I do not know what did I do wrong, please assist. I have done this before on other servers and have never faced this error. Both are... (2 Replies)
Discussion started by: kwliew999
2 Replies

2. UNIX for Dummies Questions & Answers

scp error when using wildcard

Hello, Every time my script runs I want it to go and copy all the files from a remote server directory to my local directory. Whenever I have files in the remote directory the command scp -p $proxy_user@$proxy_server:"$remote_dir/*" ${local_dir} executes with 0; when I have no files in the... (2 Replies)
Discussion started by: rdogadin
2 Replies

3. UNIX for Dummies Questions & Answers

scp error while trying to copy files

Hi, I am trying to copy files from one server to other using the below code. scp -B -p user@remoteserver:/tmp/abc.txt /landing/files The above command is failing with error You're not allowed to run 'scp -p -f /tmp/abc.txt ' When I am using scp -B -p , why am I getting error msg as scp... (2 Replies)
Discussion started by: Nikhath
2 Replies

4. UNIX for Dummies Questions & Answers

SCP error: No such file or directory

Hi, I am trying to do scp using the following script: #!/usr/local/bin/bash BUILDDATE=20120220 for line in `cat arch_host_plat_src_dest` do src=`echo $line | cut -d: -f4` dest=`echo $line | cut -d: -f5` echo scp -p /builds/${BUILDDATE}/Integration/$src ... (1 Reply)
Discussion started by: Technext
1 Replies

5. UNIX for Dummies Questions & Answers

scp throws error

My script is like STAMP=$(perl -e '($ss, $mm, $hh, $DD, $MM, $YY) = localtime(time() - 100); printf "%04d%02d%02d%02d%02d", $YY + 1900, $MM + 1, $DD, $hh, $mm') touch $STAMP /sasdata/copydata/ find /sasdata/copydata -type f ! -newer /sasdata/copydata/ -print > output3.txt awk '{print "scp ... (6 Replies)
Discussion started by: tushar_spatil
6 Replies

6. UNIX for Dummies Questions & Answers

Ftp/scp Command Error

Hi, How to use ftp/scp command with password containing @ symbol. Ex: ftp xyz:xyz@sun@11.211.111.11:/export/backups/ Exception I got: unknown host or invalid literal address Note: I dont want to change the password. Regards, Vinodh' Kumar (5 Replies)
Discussion started by: vino_hymi
5 Replies

7. Shell Programming and Scripting

Error using SCP command

Hi - I've a UNIX script which contains a scp command to copy a file to another server: scp <source path> <destination server:/path> (scp dir1/file1.dat server2:/dir1/subdir1) The job which is running this script is getting failed with error message "Remote copy Failed - Error Code: 7". When... (0 Replies)
Discussion started by: salselor
0 Replies

8. Debian

error using scp

hello fiends , i am facing this for the first time regarding the scp. when i am copying file1 from one machine to another machine in the same LAN scp file1 192.168.4.40:/root i am geting the error as /root/.bashrc: line 17: toilet: command not found /root/.bashrc: line 19: toilet:... (1 Reply)
Discussion started by: pradeepreddy
1 Replies

9. UNIX for Dummies Questions & Answers

cygwin scp script error

I'm using cygwin scp to copy a file down from a AIX server to my laptop. I've got he script working from the command line. The file I'm copying is Processed.Apr21 and I'm copying it to /event_transfer folder on my laptop. scp username@149.131.224.104:/var/Tivoli/logs/Events/processed.Apr21... (3 Replies)
Discussion started by: cav.turbo
3 Replies

10. Solaris

SCP error - tcsh: No such device

I am trying to transfer a file between two Solaris machines using SCP. I tried different options, like forcing remote host to use SCP version 1 and SCP version 2. Using IP address for remote host instead of hostname. But nothing helps. Moreover, there doesnt seem to be much of a help available on... (2 Replies)
Discussion started by: jayesch
2 Replies

Featured Tech Videos