get error while compiling apache with php module

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers get error while compiling apache with php module
# 1  
Old 11-26-2001
get error while compiling apache with php module

hi, i'm compiling apache with php module after i finish compile mysql-4.0.0-alpha.
i do it as the follow steps after untar'ed them in the same directory,
1) cd apache_1.3.22

2) cd php-4.0.6
./configure --with-mysql=/usr/local/mysql \
--with-apache=../apache_1.3.22 \
make install

3) cd apache_1.3.22
./configure --prefix=/usr/local/apache \

but i get the following error messages:

modules/php4/libphp4.a(internal_functions.o): In function `php_startup_internal_extensions':
/home/pub/php-4.0.6/main/internal_functions.c:56: undefined reference to `mysql_module_entry'
collect2: ld returned 1 exit status
make[2]: *** [target_static] Error 1
make[2]: Leaving directory `/home/pub/apache_1.3.22/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/home/pup/apache_1.3.22'
make: *** [build] Error 2

i compile them on debian linux and sunos5.7, but always get the same error messages ;(
could somebody help me? please

Last edited by jApHEth; 11-27-2001 at 01:09 AM..
# 2  
Old 11-28-2001
You might check to see if the library files exist.... for example did you build libphp4.a or check to see if it exists?
# 3  
Old 11-29-2001

Hi, finally i've compiled them successfully!
the reason is the "mysql-4.0.0-alpha", maybe it's the php's fault, who knows Smilie, whish the next version of php can support that.
i just recompile mysql 3.23 instead of mysql 4.00-alpha, so the php module can load the mysql funciton correctly, also apache can be made correctly.Smilie

thank you Neo!
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Solaris install php as an apache module

Hi, I need to install php 5.5.30 as an apache (2.4.17) module on Solaris 10. Please any help is wellcome. Some aditional info: /usr/sfw/bin/gcc -v Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs bash-3.2# g++ -v Reading specs from... (1 Reply)
Discussion started by: lbslbs
1 Replies

2. Solaris

Compile PHP as an Apache module on Solaris

Hi, I need to install php 5.5.30 as an apache (2.4.17) module on Solaris 10. Please any help is wellcome. Some aditional info: /usr/sfw/bin/gcc -v Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs bash-3.2# g++ -v Reading specs from... (0 Replies)
Discussion started by: lbslbs
0 Replies

3. Web Development

Apache module development on apache 2.2

Hi, I'm new to developing modules for Apache. I understand the basics now and can develop something simple which allows a 'GET' request to happen, but what I want to do is actually 'POST' information to my site. I know the basic POST Request works and I can see that it is post by looking at... (2 Replies)
Discussion started by: fishman2001
2 Replies

4. UNIX for Dummies Questions & Answers

Issue Enabling DAQ's NFQ Module while Compiling

Hello All, OS: OpenSuSE 12.3 x86_64 A little while back I installed Snort 2.9.6 and was trying to use the NFQ module along with it for packet acquisition but got errors that the module is not present. If I run: # snort --daq-list Available DAQ modules: pcap(v3): readback live multi... (0 Replies)
Discussion started by: mrm5102
0 Replies

5. Red Hat

Error while starting Apache after compiling PHP and Curl

Hello, I am facing an issue while starting the apache server after compiling php and curl. Below are the versions i am using. php-5.2.17 httpd-2.2.17 curl-7.16.0 CentOS5.5x64 Compiling above packages without curl working very fine but when trying to compile php with curl below error is... (1 Reply)
Discussion started by: sunnysthakur
1 Replies

6. Web Development

<Apache>error when compiling CPP modules

Hi, I am working on Linux Platform. I am just trying to port a CPP module to apache as a module. When I try to build the Apache , it throws an error as follows libtool: unrecognized option `-DLINUX=2' Later I did some search and changed the file under the "build" directory of... (0 Replies)
Discussion started by: ashabb
0 Replies

7. UNIX for Advanced & Expert Users

drbd module compiling error for Kernel

Hi I am trying to install drbd8 via apt-get on ubuntu10 sudo apt-get install drbd8-source password for vishals: Reading package lists... Done Building dependency tree Reading state information... Done drbd8-source is already the newest version. drbd8-source set to manually installed. 0... (0 Replies)
Discussion started by: vishal_vsh1
0 Replies

8. UNIX and Linux Applications

Apache module compilation error

I'm trying to compile an apache module (a tutorial module, Apache 2 Module Tutorial - GNU Build Tools and the Development Environment) and I get errors like this: apr.h:273: error: expected ´=´, ´,´,´;´,´asm´ or ´__attribute__´ before ´apr_off_t´ those errors occur like 30 times in different... (4 Replies)
Discussion started by: hjalle
4 Replies

9. HP-UX

errors while compiling c++ module

hello everyone, here i attempting to compile a c++ module . I am using the following command make -d dummyCHARGP. i am using the gcc compiler .my os is HP-UX 11.11. here i am getting the following errors. errors: ======= /swtemp/usbs/cc/unix-ce/root/subsys/include/main.h:146:... (1 Reply)
Discussion started by: mannam srinivas
1 Replies

10. Solaris

Error on compiling php for GD on SOLARIS 10

Hi everyone, I have SUn E250 server running solaris 10. I have installed apache 2 + MySQL + PHP-5.1.4 following the guidelines on this website Excellent document for first time installation. Now, because I wanted to use Coppermine Photo Gallery, I... (9 Replies)
Discussion started by: callingrohit
9 Replies
Login or Register to Ask a Question