Visit Our UNIX and Linux User Community


automated back up problem


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers automated back up problem
# 1  
Old 11-20-2001
CPU & Memory automated back up problem

Hi..
I am using HP UX 11.0

i want to make automated back up from SAM back up tool....

so i mentioned the file systems and back up device /dev/rmt/0m and time 0:00 and days of the week........

but it was not successful.....the back up job was not started on specified time.....

i am in doubt if any thing else i have to do........

please suggest....

thanks
Praful
# 2  
Old 11-20-2001
When you use SAM to setup a backup, it creates some files and set up a cronjob for you. Look in root's crontab to see if it got added. I just used SAM to setup a backup on HP-UX 11.0. The job is "/usr/sam/lbin/br_backup...." So was that job added to your root's crontab? Is cron running? My job says it will write logs to /var/sam/SAM_br_msgs so I would check that file. If the cronjob exists, it probably tried to run and wrote some error messages.

So the things to check are:

1) did SAM install a cron job?

2) does /var/adm/cron/log say if the job was attempted?

3) what errors are in the job's own logfile?
# 3  
Old 11-20-2001
Perderabo,

I believe that the path is /usr/lib/cron/log for the CRON execution log on HPUX 11.x.

I know it is a nit-picky item, but might save Prafulla some time.

Also, Prafulla, while in SAM I think you can view the SAM log after it executes your commands under OPTIONS --> VIEW SAM LOG. It has time parameters and other options you can set.

Smilie
# 4  
Old 11-20-2001
Now that I think about it, there is a much more reliable way to edit the crontab for root.

execute these commands.

crontab -l > tempcron
vi tempcron
crontab tempcron

This is easy and safe and you always have a copy of your CRON in case you accidentally blow it away.

Smilie
# 5  
Old 11-20-2001
Quote:
Originally posted by Kelam_Magnus
Perderabo,

I believe that the path is /usr/lib/cron/log for the CRON execution log on HPUX 11.x.

No, /var/adm/cron/log is the correct path. It moved starting with hp-ux 10.x. However /usr/lib/cron is a symlink to /var/adm/cron for people who are used to the old path. HP does want us to start using the real path since the symlink may disappear in the future.
# 6  
Old 11-20-2001
Thanks for the update. I was not aware of that change.
# 7  
Old 11-21-2001
Lightbulb

Hi.....

This is the crontab -l

30 23 * * 1,3,5 /usr/sam/lbin/br_backup DAT FULL Y /dev/rmt/0m /etc/sam/br/graph
XCAa02548 arbor1 Y 1 N > /var/sam/SAM_br_msgs 2>&1 #sambackup
30 23 * * 2,4 /usr/sam/lbin/br_backup DAT FULL Y /dev/rmt/0m /etc/sam/br/graphUF
Aa02548 arbor Y 1 N > /var/sam/SAM_br_msgs 2>&1 #sambackup


THIS IS /VAR/ADM/CRON/LOG

root 12102 c Tue Nov 20 23:30:00 IST 2001
root 12102 c Tue Nov 20 23:30:37 IST 2001 rc=4

AND IF U SEE THE BKPLOG IT IS ONLY SHOWING ONE LINE

2048 0/

when i am trying to see the listing frm tape....

frecover -f /dev/rmt/0m -I /tmp/bkplog

it is showing the same one line 2048 0/

IS THIS THE COMMAND TO SEE THE LISTING?


now if i don't want to make the backup by SAM tool wht i have to do make it run at a specified time?

i have to just edit crontab -e and put the timing in proper faomat....that's all...or i have to run any specific demon..

please suggest
prafulla
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #476
Difficulty: Medium
A Zettabyte (ZB) is 1,180,591,620,717,411,303,424 bytes.
True or False?

10 More Discussions You Might Find Interesting

1. Homework & Coursework Questions

Back quote problem

Use and complete the template provided. The entire template must be completed. If you don't, your post may be deleted! 1. The problem statement, all variables and given/known data: Print out problem with line follow: echo There are '$cat $fname | wc -l' contacts in database how do I replace... (2 Replies)
Discussion started by: scopiop
2 Replies

2. Shell Programming and Scripting

Automated e-mailer problem

I am trying to write a bash e-mailer script on a host that has a bunch of CPUs and makes use of all of them. It e-mails a huge list of people, so I wanna save time running this script if I can. for uid in `echo $members` do ( ... /usr/sbin/sendmail -t < $tmp ... ) & done waitWhat... (5 Replies)
Discussion started by: stevensw
5 Replies

3. Shell Programming and Scripting

Shell Scripting Problem - Invalid Back Reference

Here is the question... Create a new script, sub2, taking three parameters... 1.) the string to be replaced 2.) the string with which to replace it 3.) the name of the file in which to make the substitution ...that treats the string to be replaced as plain text instead of as a regular... (1 Reply)
Discussion started by: johnhisenburg
1 Replies

4. Shell Programming and Scripting

Problem in Concatination of string in bash scripts containing back slashes.

My script is as follows: #!/bin/bash STR1="test" echo $STR1 STR2="/bldtmp/"$STR1 echo $STR2 STR3=$STR2'/tmp' echo $STR3 output i am geting ---------------- test /bldtmp/test /tmptmp/test but my need is: ------------------ test /bldtmp/test (1 Reply)
Discussion started by: dchoudhury
1 Replies

5. Shell Programming and Scripting

Puzzling Problem: Going back to the previous directory

Hi, I am trying to figure out if there is a way to make linux take me back to the previous directory I was working in. For instance, I am in /home/username/directory1 Then if I cd into /home/username/directory1/temp1/temp2/temp3 I would like to immediately go back to the previous... (2 Replies)
Discussion started by: Legend986
2 Replies

6. UNIX for Advanced & Expert Users

p570 - Problem bringing it back up

I have a p570 server with 2 LPARs on it. One of my colleagues did a firmware upgrade on it over the weekend but I have not been able to bring it back online since. I go to activate the partition from the HMC and it gets stuck on the C20082FF operator panel and just freezes from there. Does... (2 Replies)
Discussion started by: KeesH
2 Replies

7. UNIX for Advanced & Expert Users

problem while getting the response back..plz help

Hi ALL: I am not able to get the response back from weblogic in the shell script. The weblogic server in different account. I am able to login to that account and bring the server up but while doing a ping, the script is failing. While the same script is running fine if I run it on the account... (1 Reply)
Discussion started by: splax
1 Replies

8. Shell Programming and Scripting

Roll back problem

Hi, I have 5 sub processes which are updating and commiting different records of a single table.I have a problem here.I want to rollback all the transaction if any one of processes fails.Can any one of you gurus suggest how to go about it ? Thanks Tushar Johri (3 Replies)
Discussion started by: tushar_johri
3 Replies

9. UNIX for Dummies Questions & Answers

553 config error: mail loops back to me (MX problem)

I recieve 553 5.3.4 mail.xxxx.com config error: mail loops back to me (MX problem?) when I try to send email from client . The message reaches the server and dies there I'm using sendmail 8.12.9 on OpenBSD 3.3. I can check mail on client with no problem Thanks for any help (5 Replies)
Discussion started by: bluehell
5 Replies

10. UNIX for Dummies Questions & Answers

back up problem

Hi all I am facing some problem taking INCREMENTAL Back up of file systems...........Actually i have mounted the file system of one server in another server..as i don't have tape drive in both servers...............i am using HPUX(L class and C class)servers.. can any one help me ... (1 Reply)
Discussion started by: Prafulla
1 Replies

Featured Tech Videos