Visit Our UNIX and Linux User Community


cp multiple files to fd0


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers cp multiple files to fd0
# 1  
Old 11-15-2001
cp multiple files to fd0

Hello all.

I want to copy multiple files to a floppy. My distr. version is Mandrake 8.0.

If i use [ cp file /dev/fd0 ] , all is ok and the file is copied to disk

If i use
[ cp file1 file2 /dev/fd0 ] , I receive an error stating that /dev/fd0 is not a directory. I understand that /dev/fd0 is not a directory.

Is there a way to copy multiple files to the floppy ?

If yes, how would you copy all files in a particular directory to a floppy ?

And if the floppy already contains a file, how can you add another file to the floppy without overwriting the existing files already on it?
# 2  
Old 11-15-2001
Hi,

You must first mount the floppy in order to copy files to it.
I don't know if Mandrake has any easy way to automatically mount a floppy on demand with a click of a button or something like that. (I never used it before)

Generally I've always just done everything using UNIX commands from a command prompt.

Check out the mount(1) man pages for information.

-John
# 3  
Old 11-15-2001
It is mounted. I can copy a single file to the floppy, but can not copy multlple files to it.
# 4  
Old 11-15-2001
Where did you mount it to? /dev/fd0 is the device file... not a mount point.

a common example of a mount point would be like /mnt/floppy or something like that.
# 5  
Old 11-15-2001
I mount the floppy with command:

mount /mnt/floppy

To see whats on the floppy i use:

cat /dev/fd0
# 6  
Old 11-15-2001
If you mounted the floppy to /mnt/floppy, then cd to /mnt/floppy to see and manage files on the disk. You can copy, edit, rename, remove files from that directory to access the floppy.
# 7  
Old 11-15-2001
Thanks, moving into the /mnt directory and working from there helped alot.

One strange thing though, the Linux book that i am reading specifically says to use
[cp file /dev/fd0 ] to copy a file to a floppy. Actually you need to use [cp file /mnt/floppy] and since
/mnt/floppy is a directory and /dev/fd0 is not; saving multiple files using just one command was allowed.

BTW, Mandrake graphical interface automatically mounts the floppy when you put it in. They call it 'supermount'
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #998
Difficulty: Medium
Hooksafe is a hypervisor-based light system that safeguards a computer's kernel from rootkit attacks.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

sed parser behaving strange on replacing multiple words in multiple files

I have 4000 files like $cat clus_grp_seq10_g.phy 18 1002 anig_OJJ65951_1 ATGGTTTCGCAGCGTGATAGAGAATTGTTTAGGGATGATATTCGCTCGCGAGGAACGAAGCTCAATGCTGCCGAGCGCGAGAGTCTGCTAAGGCCATATCTGCCAGATCCGTCTGACCTTCCACGCAGGCCACTTCAGCGGCGCAAGAAGGTTCCTCG aver_OOF92921_1 ... (1 Reply)
Discussion started by: sammy777888
1 Replies

2. Shell Programming and Scripting

Removing carriage returns from multiple lines in multiple files of different number of columns

Hello Gurus, I have a multiple pipe separated files which have records going over multiple Lines. End of line separator is \n and records going over multiple lines have <CR> as separator. below is example from one file. 1|ABC DEF|100|10 2|PQ RS T|200|20 3| UVWXYZ|300|30 4| GHIJKL|400|40... (7 Replies)
Discussion started by: dJHa
7 Replies

3. Shell Programming and Scripting

Grep strings on multiple files and output to multiple files

Hi All, I want to use egrep on multiple files and the results should be output to multiple files. I am using the below code in my shell script(working in Ksh shell). However with this code I am not attaining the desired results. #!/bin/ksh ( a="/path/file1" b="path/file2" for file in... (4 Replies)
Discussion started by: am24
4 Replies

4. Shell Programming and Scripting

Create Multiple UNIX Files for Multiple SQL Rows output

Dear All, I am trying to write a Unix Script which fires a sql query. The output of the sql query gives multiple rows. Each row should be saved in a separate Unix File. The number of rows of sql output can be variable. I am able save all the rows in one file but in separate files. Any... (14 Replies)
Discussion started by: Rahul_Bhasin
14 Replies

5. Shell Programming and Scripting

Run one script on multiple files and print out multiple files.

How can I Run one script on multiple files and print out multiple files. FOR EXAMPLE i want to run script.pl on 100 files named 1.txt ....100.txt under same directory and print out corresponding file 1.gff ....100.gff.THANKS (4 Replies)
Discussion started by: grace_shen
4 Replies

6. UNIX for Dummies Questions & Answers

Run one script on multiple files and print out multiple files.

How can I run the following command on multiple files and print out the corresponding multiple files. perl script.pl genome.gff 1.txt > 1.gff However, there are multiples files of 1.txt, from 1----100.txt Thank you so much. No duplicate posting! Continue here. (0 Replies)
Discussion started by: grace_shen
0 Replies

7. Shell Programming and Scripting

Column extraction from multiple files to multiple files

I have roughly ~30 .txt files in a directory which all have unique names. These files all contain text arranged in columns separated by whitespace (example file: [#YY MM DD hh mm WDIR WSPD GST WVHT DPD APD MWD PRES ATMP WTMP DEWP VIS TIDE #yr mo dy hr mn degT m/s m/s m sec ... (5 Replies)
Discussion started by: aozgaa
5 Replies

8. Shell Programming and Scripting

awk, multiple files input and multiple files output

Hi! I'm new in awk and I need some help. I have a folder with a lot of files and I need that awk do something in each file and print a new file with the output. The input file name should be modified when I print the outpu files. Thanks in advance for help! :-) ciao (5 Replies)
Discussion started by: gabrysfe
5 Replies

9. UNIX for Dummies Questions & Answers

Using AWK: Extract data from multiple files and output to multiple new files

Hi, I'd like to process multiple files. For example: file1.txt file2.txt file3.txt Each file contains several lines of data. I want to extract a piece of data and output it to a new file. file1.txt ----> newfile1.txt file2.txt ----> newfile2.txt file3.txt ----> newfile3.txt Here is... (3 Replies)
Discussion started by: Liverpaul09
3 Replies

10. UNIX for Advanced & Expert Users

FD0 error code 30

Hi I am new to this forum. Iam facing very strange problem in sco open server 5. when i try to mount the fd0 it just says "fd0 writeprotected, read only error code 30" I changed the floppy drive. even I check the /dev/fd0 permissions it is read and wirte. I changed the floppies also. but... (6 Replies)
Discussion started by: Pritpal singh
6 Replies

Featured Tech Videos