Visit Our UNIX and Linux User Community


crontab problem


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers crontab problem
# 15  
Old 11-08-2001
Thanks for your replies guys,

I can NOT log in, using THAT password. But I can LOG IN switching from the root user with 'su - oracle'. If THAT is the password as you said and the password expired , isn't strange that I can switch from the root account?
This is the only way that I can use the oracle account, and it is working fine.

Thanks again.
# 16  
Old 11-08-2001
su'ing from root will always work since no password
is required. From root, you can change the orecle user password

# passwd oracle
# 17  
Old 11-08-2001
Yes, but as the password is no longer valid for that user shouldn't be nice to have a warning or something?
The thing is that even the account is inactive logs me in like this:
and all the functions are working. If this is the case, then I only need to reset the password and the crontab will run fine, correct?

<pre>

isgsi01(root)9: su - oracle
Sun Microsystems Inc. SunOS 5.7 Generic October 1998
$ whoami
oracle

</pre>
# 18  
Old 11-08-2001
Well... "root" is GOD on most (if not all) flavors of UNIX
so you can pretty much do anything and you woun't
get much if any warnings.

I assume that if oracle's cron job is not running
because of an expired password then reseting it may in
fact work however I have not actually tried this.

I say... give it a shot. Smilie
# 19  
Old 01-29-2002
Lightbulb Cron job problem

1. Run the cron from root and not from oracle
2. prefix su -c oracle to the script that you want to run in cron

this will actually run the cronjob as root by su it to oracle before running the script.

hope this would help you.

we are doing exactly the same on our systems.

Milind.
# 20  
Old 03-31-2002
Lightbulb Crontab Usage & ToubleShooting.....

Hi

------------------------------------------------------------------------------------
CRONTAB USAGE : For Using "crontab" utility to Edit Cron Files
using Vi as the Editor, perform the below mentioned Steps.

# EDITOR=vi; export EDITOR;
# crontab -e <username>

U will get a Vi Editor Screen for editing the mentioned User's Cron File. { Only use this way to edit any Cron File, as directly editing the Cron files might corrupt the File }

------------------------------------------------------------------------------------
CRONTAB TROUBLESHOOTING : If Ur Cronjob is not getting executed correctly, Then check for the below mentioned....

1. Check for the Permissions of the Cron File and Syntax of its contents.

# ls -l /var/spool/cron/crontabs/
total 4
-r-------- 1 root other 310 Mar 31 12:50 backup_user
-r-------- 1 root root 424 Feb 21 21:41 root

2. Check the UserName Entries present in the below mentioned Files.

/etc/cron.d/cron.allow
/etc/cron.d/cron.deny

3. Check whether Daemon for Cron is running or not.

# ps -ef |grep cron |grep -v grep
root 183 1 0 Mar 28 ? 0:03 /usr/sbin/cron

4. If the Daemon is not running, Restart the Daemon as mentioned below

# /etc/init.d/cron stop
# /etc/init.d/cron start

5. If U are executing any customised Shell Scripts using Cron,
then U have to check whether proper Execute Permissions are
provided for that Cron User.

------------------------------------------------------------------------------------

If U still face any problem, Kindly get back with Proper Error Messages updated in the /var/adm/messages File.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #487
Difficulty: Easy
A program's entry point is always defined by a main function or method.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

problem with crontab

hi all does any on has explanation for this result bash-3.00$ crontab -e "/var/tmp/Ex1kayUW" No space left on device The crontab file was not changed. bash-3.00$ (2 Replies)
Discussion started by: osmannix
2 Replies

2. UNIX for Advanced & Expert Users

crontab problem

hi.. i have a program (tf.sh), and i want what it runs automatically with a "lapsus" of 2 hours. (1,3,5,7,9,11,13,15,17,19,21,23 hrs.) i know what i have to do it using crontab, but i donīt know how to do it. i have the next idea, but the problem is what it doesnīt run on my server... (11 Replies)
Discussion started by: DebianJ
11 Replies

3. AIX

Crontab problem

Hi to all. Guys, i have a truble with oracle user crontab. He work if i'm do 0-59 * * * * echo LOL> ~/test.txt But not work if me set realy norm date For example 14 17 28 12 * echo LOL> ~/test.txt In 17:14 28 December . In log file /var/adm/cron/log nothing.... Please... (3 Replies)
Discussion started by: jess_t03
3 Replies

4. Shell Programming and Scripting

Problem in crontab

Hi All, Am facing an issue while updating the crontab.Getting below error while updating the cron. cron/tmp.XXXX5fXBR6: No space left on device crontab: edits left in /tmp/crontab.XXXXEJX5gw Is there any file where i need to alter using root user so that i can update the cron. TIA... (9 Replies)
Discussion started by: Ashok_oct22
9 Replies

5. Shell Programming and Scripting

Crontab Problem

Dear All , I have .sh script wich has the following inside getFileName=Listportfolio.txt.`date +'%Y%m%d` ftp -n 172.10.10.1<<EOF user xxx xxx bin cd /home/gbs/FTP_Script get /home/gbs/FTP_Script/$getFileName bye EOF EOF when I run the... (3 Replies)
Discussion started by: habuzahra
3 Replies

6. UNIX for Advanced & Expert Users

crontab problem

hi all while using crontab -e im receiving 754 as output im unable to add a entry in crontab crontab -l is working fine OS: sun5.8 can some one please assist me (4 Replies)
Discussion started by: NIMISH AGARWAL
4 Replies

7. UNIX for Dummies Questions & Answers

problem with crontab

i added to my crontab file: * * * * * echo "hello" it works, i receive a message into my /var/mail/username and i receive: bob in addition to a large text add-on any help appreciated (1 Reply)
Discussion started by: cleansing_flame
1 Replies

8. UNIX for Dummies Questions & Answers

Problem with crontab

I'm trying to get crontab to run a script, but to test crontab I tried out a very simple command: `echo bob` here is my crontab file (I edited it by using `crontab -e`): ----------------- #!/bin/sh 23 10 * * * echo bob and at 10:23 every day I get a new message: in /var/mail/a... (3 Replies)
Discussion started by: cleansing_flame
3 Replies

9. Shell Programming and Scripting

crontab problem

HI, i am working on linux. i have crontab problem i wrote a small script and put it in a crontab . but the script is not running.. i have given following way in crontab -e 02 06 * * * /bin/csh /home/vr_test.csh but the above script is not running please rectify my... (26 Replies)
Discussion started by: rajan_ka1
26 Replies

10. UNIX for Dummies Questions & Answers

Problem with Crontab

I have a server running 5.9 and I'm trying to cron in the following. 00 01 * * 7 cd /data/apache/logs && find . -type f -name "access.*" -mtime +1 -print |xargs rm > /dev/null 2>&1 But I keep get the following error.... 00 01 * * 7 cd /data/apache/logs && find . -type f -name "access.*"... (2 Replies)
Discussion started by: Zak
2 Replies

Featured Tech Videos