Visit Our UNIX and Linux User Community


what is the 'whatis' command?


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers what is the 'whatis' command?
# 1  
Old 10-23-2001
what is the 'whatis' command?

I am kind of new with Unix and I really need some help. Can you please tell me what the 'whatis' command is? and what does it do?

Let's say that I have a file which I want to delete, what command will I need to use?

If I have a directory that I want to delete all files from what command do I use?

What is the difference from deleting a directory, and deleting a directory and all its subdirectories beneath it? What command do I need to use?




Thankx,
# 2  
Old 10-23-2001
whatis - describes what function a command performs...
To find out what the ls command does, enter:
whatis ls

This produces the following output:
ls(1) -Displays the contents of a directory.

rm - deletes a file or a directory.
To delete a file...
rm myfile


To delete a directory...
rm -r mydir


Reading the man pages will give you this information
and much more...

man whatis
man rm
# 3  
Old 10-23-2001
Thank you rwb1959.
# 4  
Old 10-24-2001
And there's always:
whatis whatis
# 5  
Old 10-25-2001
PHP Is it not there in Hp-Unix?

I could not find this whatis in HP-Unix B 11. and can anybody tell me the difference between man and whatis ?
sskb
# 6  
Old 10-25-2001
Re: Is it not there in Hp-Unix?

Quote:
Originally posted by sskb
I could not find this whatis in HP-Unix B 11. and can anybody tell me the difference between man and whatis ?
HP-UX picked up the old System V man command back in the early 80's and they don't seen to want to change. HP's man stuff is a little weird because of it. HP is missing both the whatis and apropos commands. But you can get them back with simple aliases:

alias whatis="man -f"
alias apropos="man -k"
# 7  
Old 10-25-2001
I only got error when I tried them. Is that because of Installation problem?

$ man -k ls
/usr/share/lib/whatis: No such file or directory
$ man -f ls
/usr/share/lib/whatis: No such file or directory
sskb
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #484
Difficulty: Medium
A compiler transforms source code into object code, a floating point number format that machines understand.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

What are the differences between 'bash' and 'sh'

Hopefully this doesn't come off as too much of a "newbie" question or a flamebait. But I have recently begun working with a Sun Solaris box after having spent the past five years working with RedHat. From what i can tell, thing look fairly similar and the 'man' command is some help. But I've... (7 Replies)
Discussion started by: deckard
7 Replies

2. UNIX for Advanced & Expert Users

How to remove a file with a leading dash '-' in it's name?

Somehow someone created a file named '-ov' in the root directory. Given the name, the how was probably the result of some cpio command they bozo'ed. I've tried a number of different ways to get rid of it using * and ? wildcards, '\' escape patterns etc.. They all fail with " illegal option --... (3 Replies)
Discussion started by: GSalisbury
3 Replies

3. UNIX for Dummies Questions & Answers

VI 'go to position #' command

I apologize is this is somewhere else but I did look.... Is there a command to goto position # x within the VI editor? I've seen where you can search for a particular char string but I need to go to position 200 within a record (tired of counting positions)...:) Thanks in advance... (2 Replies)
Discussion started by: hedrict
2 Replies

4. IP Networking

BELKIN 'F5D5020' 16bit PCMCIA - FreeBSD HOWTO

Hey all, I've bought a few bits from Belkin who seem quite happy to support FreeBSD! Last time I bought a UPS from them and it's still going well :D I saw this on their website that the 16bit PCMCIA card was supported under FreeBSD: http://www.belkin.com/network/F5D5020.html I went to my... (0 Replies)
Discussion started by: WIntellect
0 Replies

5. UNIX for Dummies Questions & Answers

quoting echo 'it's friday'

echo 'it's friday' why appear the > (3 Replies)
Discussion started by: yls177
3 Replies

6. UNIX for Advanced & Expert Users

Terminal 'Local Echo' lost on Modem Dial-out

Can anybody help me? I am developing a utility for automating message paging to a BT alphanumeric pager. I am using a USR 56K Fax-modem connected to /dev/cuab on a Sun Ultra-10. I am using the UNIX 'tip' utility to connect to the modem and I have configured the modem as follows: Baud Rate:... (2 Replies)
Discussion started by: mybeat
2 Replies

7. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

8. UNIX for Dummies Questions & Answers

'find' command question

my solaris text talks about the 'find' command... it further goes to talk about an "action" used with the find command. I am completely confused as to what the {} do with the find comand. the explanation is this: "A set of braces, {}, delimits where the file name is passed to the command from... (2 Replies)
Discussion started by: xyyz
2 Replies

9. Programming

i can't use 'make' in my computer?

I need to compile a file,but 'make' does not work.please tell me how to use it or need which tools? (3 Replies)
Discussion started by: dsun5
3 Replies

10. UNIX for Dummies Questions & Answers

sed 's/~/\^J/g' how to get "^J" on same line as rest of the command.

when ever i type it in it always looks like so echo $file | sed 's/~/\ /g' how can i get it on one line? (6 Replies)
Discussion started by: Optimus_P
6 Replies

Featured Tech Videos