Visit Our UNIX and Linux User Community


Admintool


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Admintool
# 1  
Old 10-18-2001
Question Admintool

Hi,

Does anyone here know where I can find out what commands admintool runs while adding a new user and setting up the account? Reason being is the script I am writting, I can add the user create the path. But it wont set the path for the user. The password well it wont add without interaction from the user, which isn't what I want.

Also after creating a user in my script I had a look at all the files it called and created. Then created a user in admintool the looked at all the files it created. Well there is a huge difference in what was done between the two.

Simple things like the .Xauthority, .dtprofile and so on. I need to know all the manual commands that admintool uses to create those, and how its created. I want to be able to do what admintool does including all the background tasks without having to use the graphical interface. Just all run smooth in the background.

If anyone has any idea's please let me know and thanks in advanced.

I'm mainly just after where documentation can be found on how to do this because I haven't been able to find anything that can help me out all the way.

Once again thanks for those who can help me.

Smilie
merlin
# 2  
Old 10-18-2001
You have to play around with the 'useradd' command.

man useradd.

Also there is an original directory in /etc/skel

All the files in there should be copied manually when you add a new user.
That is what the admintool does, but not only
After the new user logs in for the first time, XAuthority and some other file are created.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #789
Difficulty: Medium
Steve Wozniak was employed at Sun Microsystems before he founded Apple Computers.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

HP Printer without SMC, Admintool, or Jetadmin

Jetadmin fails saying that it is not a network printer despite the fact that it is and can be pinged from UNIX. I am administering this remotely (long remote, I can't go there soon) and can't run smc or admintool. Any help configuring this spooler would be appreciated. (1 Reply)
Discussion started by: TT Fan
1 Replies

2. UNIX for Advanced & Expert Users

Does admintool write to eeprom?

Hi: I was setting up a modem on an Ultra5 running 2.6. (yes I know, how quaint) There are 15 systems that are interlinked but not accessible to the outside world. This will end soon with new updated sun systems but until then the system needs to be accessed by the outside world. Hence the... (1 Reply)
Discussion started by: mndavies
1 Replies

3. Solaris

Admintool

How can I solve this admintool Error: Can't open display: (4 Replies)
Discussion started by: iwbasts
4 Replies

4. Solaris

what happened to admintool?

what happened to admintool in Solaris10? (2 Replies)
Discussion started by: mndavies
2 Replies

5. Solaris

Admintool and rpc call

Hi all, I'm trying to launch admintool via an export DISPLAY. i get the message: Received communication service error 4: Remote procedure call timed out: program = 100087, version = 10 Just to say, i don't use nis/nisplus on my server... What to do? Thanx Jason (17 Replies)
Discussion started by: penguin-friend
17 Replies

6. UNIX for Advanced & Expert Users

Printer Error with Admintool

Hi I have a unix box [ Solaris 2.5.1 , sparc staion 5_10 ) I could successfully configure a LOCAL printer using lpadmin -p XX -v /dev/term/a But when I tried to do local printer configuration with admintool, ( as root user ) it throws up error. " add printer failed ". Also when I... (4 Replies)
Discussion started by: shibz
4 Replies

7. UNIX for Dummies Questions & Answers

Admintool

I am new to unix....How do I enable XWindows... Or for that matter, use Admintool. .....Pls. help. Thanks. PS. I am running Solaris 8. (3 Replies)
Discussion started by: d4jtwvb
3 Replies

8. UNIX for Dummies Questions & Answers

admintool : error display..

hi, i did the following 1) which admintool /bin/admintool 2) admintool Error: Can't open display: how to set the display then? i am using netterm to telnet to my sun server. (6 Replies)
Discussion started by: yls177
6 Replies

9. UNIX for Dummies Questions & Answers

problem with admintool

hi, after i execute admintool, i got the below "Error, cant open display" what is wrong? thanks (5 Replies)
Discussion started by: yls177
5 Replies

10. UNIX for Dummies Questions & Answers

sun solstice, admintool, smc

hi, i tried these sun command on a sun0s 5.7 but get the "cant open display" message. please advise. i am using netterm to telnet. (5 Replies)
Discussion started by: yls177
5 Replies

Featured Tech Videos