Visit Our UNIX and Linux User Community


UID problem


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers UID problem
# 1  
Old 10-09-2001
UID problem

I'm teaching myself UNIX, so bear with me! Smilie

I created two user accounts on my box. One day I shut down the system using "shutdown -h 1". The system shut down cleanly.

A few days I rebooted the box, no problem.

But root is the only account that can log in. The other 2 user accounts can't.

CapsLock is off. Both accounts appear where they belong, with encrypted passwords. Fingering both accounts says they never logged in. If I SU to the first account it says it isn't there (grek sez it is), but I can SU to the 2nd account. And when I exit, it exits to the FIRST account that it said ain't there! From there I can exit back to root.

::shrug::

I also created two new accounts, and neither of them could log in, either. :/

And reassigning passwords doesn't work.

Help?

>>>>>>>Chris
# 2  
Old 10-09-2001
A couple of questions...

1- what "flavor" of unix/linux are you using?
2- how did you create the new user accounts (i.e. useradd, vi
password file, etc.)?
# 3  
Old 10-09-2001
Quote:
Originally posted by rwb1959
A couple of questions...

1- what "flavor" of unix/linux are you using?

2- how did you create the new user accounts (i.e. useradd, vi
password file, etc.)?
Flavor = TurboLinux 6.0 Server Lite (comes up in env as "Linux-Gnu")

Created the accounts by "useradd", then passwd <uid>.

They used to work!

Oh, and I forgot: When I try to log those accounts in, it gets a message that says the system is going down last September 30th.

>>>>>>>>>>Chris
# 4  
Old 10-09-2001
Has your system ever been attached to the internet
prior to that first shutdown you mention?
Was ftp or telent active?

What I'm driving at here is that you may have been cracked
since you mention you get the powerdown message when you
try to login with the other users. You also mention that
these logins had worked previously. You may also want
to check what your system is doing with ps and who as well as
taking a look in /var/log/messages and /var/log/secure for any
abnormalities (i.e. large block of garbage).

If none of this is true, I don't know what else may be the
cause. You seem to have added new users properly...
useradd then passwd
...however, my recommendation would be the same...
save all your important data and configuration files then
wipe the disk clean and reinstall Linux. Before you connect
to the internet, be sure to secure (if not turn off) ftp and telnet.
# 5  
Old 10-09-2001
Nope, never been on the 'net. No FTP, TFTP, or Telnet. It's not on a network at all in fact; it's a standalone box I built for me to learn UNIX on.

When I "who", I only get root. "ps" only gives me information on tty1 (root) and lists only login, bash, and ps under CMD. Obvious I guess, root's the only account logged in, right?

(remember, I'm still learning this!)

The powerdown message, I've been getting even when I had X-Window running and unsuccessfully tried to log into Linux (although the date has since changed).

/var/log/messages list multiple listings of:

... localhost syslogd 1.3-3: restart
(and)
... localhost --MARK--

/var/log/secure lists all of the account authentication errors.

Thankfully, this is only a learning computer, so if I DID need to blow away Linux and reinstall, no problem. I may just replace it with Redhat 6 instead; I've got that, too. (if I do, do I have to reformat, or can Redhat 6 overwrite TurboLinux and use the same partitions I have set up?

Makes perfect sense to secure (if not turn off) ftp and telnet. Is it hard to do?

BTW, thank you for having the patience to deal with a newbie like me! Smilie

Best,

>>>>>>>>>>Chris
Author: "Sabrina Online: The Story"
www.furnation.com/chrisfoxx
# 6  
Old 10-09-2001
No problem Chris. I and all the other folks
participating on this forum are glad to be
of any help we can Smilie

I'm sorry I haven't been much help on your
problem. If your machine has never been
connected to the "outside", It would be safe
to say that your system has not been compromised.
I would say... remove the users (userdel) and
re-add them (useradd) but you have already tried
that. If you don't mind re-installing or going
to RedHat, I would say... do so and go ahead
and reformat the disk (it may come up with bad
blocks or something). On securing telnet and ftp,
you can simply edit your /etc/inetd.conf file
and you should see two lines like...
ftp stream tcp nowait root /usr/sbin/tcpd in.ftpd -l -a
telnet stream tcp nowait root /usr/sbin/tcpd in.telnetd
...simply insert a "#" (no quotes) in the very
beginning of the line. Once this is done, you
will need to "tell" inetd to re-read the file.
run the "ps" command to find the PID do...
# ps -ef | grep inetd
root 569 1 0 Jul10 ? 00:00:00 inetd
# kill -HUP 569

...the above shows my inetd PID as 569. You would
substitute whatever PID your system shows.
This will turn off those services. When you get
more adventurous, check out the man page
for hosts_access(5) use: man 5 hosts_access
and you can set up the /etc/hosts.allow and
/etc/hosts.deny files to allow ftp and telnet
access to very specific systems or ranges of
IP addresses only. Don't forget to uncomment
the lines in /etc/inetd.conf and HUP inetd
again.

I know it's alot of stuff to assimilate so
I hope I haven't created more confusion Smilie
# 7  
Old 10-10-2001
Security! Yay!

http://www.linuxnewbie.org/nhf/intel...ity/index.html

I recommend the "Securing you Home Maching" section first. It won't cover you 100%, but it's a good start for new-comers to the Unix world. Check out the rest of the site as well, and when you get a little more comfortable with your newfound Unix skills, don't be afraid to check out www.linuxdoc.org.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #389
Difficulty: Medium
Rocky Mountain BASIC (RMB) is a dialect of the BASIC programming language created by AIX.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

UID Admin

Hi All, I have to give permission to one of the groups called as "ABC" as like the permissions of the group "UNIXADM". Could you please some one help on this issue ? (3 Replies)
Discussion started by: ramareddi16
3 Replies

2. Solaris

Changing uid value

Hi, I want to change user id gefadm ,uid=0(root) gid=0(root) to uid=16649(isaadmin) gid=16284(dstage), how can i change this uid ,gid one value to another value. Please provide the steps how can i change , uid=0(root) gid=0(root) to uid=16649(isaadmin) gid=16284(dstage). Thanks in advance for... (2 Replies)
Discussion started by: sridhardwh
2 Replies

3. AIX

More than 1 UID 0

Hi, Can any one please tell what are the risks of having more than one users having UID 0 (root)? Thanks Naveed (9 Replies)
Discussion started by: naveedaix
9 Replies

4. UNIX for Dummies Questions & Answers

Duplicated UID

Hi folks! I need you help to discover what's the impact of a duplicated UID in an operating system. What's the meaning when someone put in different users the same UID? (3 Replies)
Discussion started by: phcostabh
3 Replies

5. Shell Programming and Scripting

UId

is tty command opens a process in the system if yes then why process got the userid????? (5 Replies)
Discussion started by: Mac91
5 Replies

6. Shell Programming and Scripting

uid script help

i need a script to process a password file and based on the UIDs in the password file, generate the new UID that is 1 greater than the highest uid. i have some script logic but i dont really understand it. any help? #!/usr/bin/perl ########################################## #... (3 Replies)
Discussion started by: livewire06
3 Replies

7. Shell Programming and Scripting

checking uid

How do i go about getting the uid of the user and verify ? if then echo "You are not a superuser, please login as a superuser" exit1; fi the above code doesn't work. can some guru please help me. 1. how to get the uid of the user ? i know by typing id but how to... (7 Replies)
Discussion started by: filthymonk
7 Replies

8. AIX

UID not to be reused

Hello I want to find out how I can make sure in AIX that the UIDs cannot be reused Until after 6 Months after the user has left. Thanks, Noori (4 Replies)
Discussion started by: noori
4 Replies

9. UNIX for Dummies Questions & Answers

Reversing UID's

Is it possible given a uid to determine information about the person with the uid? An example would be simple information regarding what group and the name of the person associated with that uid. It seems there is probably an easy staring me in the face but i cant seem to find it... (3 Replies)
Discussion started by: dreaming1
3 Replies

10. AIX

UID Change

Currently, I have about 7 servers and the uid for a given person is different on each server. I want to make the uid's the same for a given username on each server. I know how to change the uid via smit, but when I do the previous uid number shows up as the owner for the files of that username.... (4 Replies)
Discussion started by: mcateriny
4 Replies

Featured Tech Videos