Visit Our UNIX and Linux User Community


./configure error


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers ./configure error
# 1  
Old 09-28-2001
Network ./configure error

Hey, i'm trying to use httptunnel and it won't let me configure it. here's what the cmnd line gives me:

[macaddictg4:/httptunnel-3.0.5] pbg4% ./configure
creating cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... no
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking for mawk... no
checking for gawk... no
checking for nawk... no
checking for awk... awk
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH

know how to make this work? i'm new at unix.

-Kris
# 2  
Old 09-28-2001
*cc is your compiler. It turns all that text stuff into a usable (hopefully) binary. It's possible that you have the whereis utility installed on your machine. If so, type:
whereis cc at the prompt. Can you post the results of that back here? Also, while you're at it, what Unix are you using (uname -spmr. If that doesn't work, just use uname -a)? And could you type:
echo $PATH, and post the results along with it?

Hopefully, the shell just doesn't know where to find cc, and you won't have to install it...
# 3  
Old 09-28-2001
the whereis cc command didn't work. here is the result of what unix i'm running.
[macaddictg4:~] pbg4% uname -spmr
Darwin 1.3.7 Power Macintosh powerpc
[macaddictg4:~] pbg4% uname -a
Darwin macaddictg4 1.3.7 Darwin Kernel Version 1.3.7: Sat Jun 9 11:12:48 PDT 2001; root:xnu/xnu-124.13.obj~1/RELEASE_PPC Power Macintosh powerpc

-kris
# 4  
Old 09-28-2001
Suggestion: Go to www.gnu.org and install the gcc compiler and associated glibs (next release):

http://www.gnu.org/directory/gcc.html

Read this FAQ:

http://gcc.gnu.org/install/specific....erpc-*-darwin*
# 5  
Old 09-28-2001
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #717
Difficulty: Medium
A universal Turing machine can calculate any recursive function, decide any recursive language, and accept any recursively enumerable language.
True or False?

9 More Discussions You Might Find Interesting

1. High Performance Computing

FFTW - ./configure --enable-mpi error.

Hello I am trying to install fftw3.3.3 on an HPC system. The system has openmpi installed ( though we can choose between a variety of mpi distributions). However, while ./configure step of fftw, there is an error. The relevant section of the output is: checking whether to build shared... (3 Replies)
Discussion started by: abhi34101
3 Replies

2. Shell Programming and Scripting

[Solved] Configure: error: invalid value of canonical target

Hi Everyone, I am trying to connect GDB-7.5.50-1 to the target but I am getting an error configure: error: invalid value of canonical target .In addition I gave the command ./configure --target=xyz --build= xyz --host=xyz. Furthemore the host and the build system are compeletly running but... (0 Replies)
Discussion started by: Heeka
0 Replies

3. Red Hat

Error to configure Squirrelmail IMAP Proxy

Hi there.. :D I"m new in Linux. Trying to install squirrelmail-imap_proxy-1.2.7 on Red Hat WS 4. Errors from ./configure as shown below: # ./configure checking whether make sets $(MAKE)... yes checking for gcc... gcc checking for C compiler default output file name... a.out checking... (5 Replies)
Discussion started by: che.din
5 Replies

4. Solaris

configure: error: no acceptable ld found in $PATH

When i configure apache(2.2.15) on solaris-8 server it producing following error <configure: error: no acceptable ld found in $PATH configure failed for srclib/apr > please help me any to fix this error. :confused: ---------- Post updated at 09:44 PM ---------- Previous update was... (0 Replies)
Discussion started by: kalpeer
0 Replies

5. Infrastructure Monitoring

configure nrpe and nagios error

   (1)check the service of nrpe   # libexec/check_nrpe -H 59.26.240.63   NRPE v2.8.1    (2)check the resource of nrpe's host   # libexec/check_nrpe -H 59.26.240.63 -c check_df   DISK OK - free space: / 8241 MB (77% inode=98%); /var 5239 MB (95% inode=99%); /usr 11971 MB (86%... (0 Replies)
Discussion started by: zhengsenlin
0 Replies

6. Ubuntu

./configure command Error while trying to install GCC compiler on unix machine

Hi, I need to install the GCC compiler on a my Linus machine. First step is to run the ./configure command and here we need to specify ./configure --target="target machine name (CPU type-Manufacturer-OS) or other way would be just give the command ./configure and it guesses the target name... (11 Replies)
Discussion started by: viji19812001
11 Replies

7. Solaris

PZ help :configure: error: cannot find output from flex; giving up

While installing amanda server,i got the following error ## checking lex output file root... configure: error: cannot find output from flex; giving up. when i execute # which lex i got /usr/ccs/bin/lex setting the pathg does not work too After this i tried intalling flex in my /opt... (0 Replies)
Discussion started by: bullet350
0 Replies

8. Solaris

[need help] error after configure network card at v890 sparc

hi experts, i have some problem with my server v890, i had config the network with ce0,ce1 and eri0 but after reboot the server have this error messages display : WARNING: ce0: fault detected external to device; service degraded WARNING: ce0: xcvr addr:0x01 - link down configuring IPv4... (2 Replies)
Discussion started by: bucci
2 Replies

9. UNIX for Dummies Questions & Answers

./configure error

my compiler won' t let me configure. This is what occurs when I type ./configure Alex@BADPERSON /postgresql-7.2.1 $ ./configure loading cache ./config.cache checking host system type... i686-pc-cygwin checking which template to use... win checking whether to build with locale support... no... (3 Replies)
Discussion started by: achink125
3 Replies

Featured Tech Videos