Visit Our UNIX and Linux User Community


CDE problem


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers CDE problem
# 1  
Old 08-30-2001
Network CDE problem


I created a general use account on my Sparc system. The problem is this:

I did a "useradd -g general -G sysadmin -d /usr/home/sameer sameer" (after I made the directories)

But it seems that no .profile or other files were written to this directory.

Now what's happening is when I try to login through the graphical login and use CDE it starts to load and then kicks me out.

Can anyone tell me how to solve this problem... W/O making an account using "admintool". I really want to learn the commands.
xyyz
# 2  
Old 08-30-2001
Try this

useradd -m -g group -G group1 user

Good Luck
# 3  
Old 08-30-2001
being you created the dir. manually i am going to assume you didnt not set the proper permissions.

also check /etc/skel this is the dir where all new users get there files. so if you want every new user to get a welcome.note you can put it in there and it will be put in there dir. when there account is made.

if there is a default logon profile make sure they have the proper env. settings to run the CDE env. compair theres with a known good one.
# 4  
Old 08-31-2001
if you create a user using the "useradd" command (in solaris), it copies the local.profile from /etc/skel into the user's home directory, but it doesn't rename it to .profile. because it doesn't rename it, the .profile or any other user initialization file isn't read upon login. creating a user using admintool or something other than the command line copies the initialization file and renames it.

if the person can't login period, check the ownership of the home directory (if you created this mannually, then more than likely root still owns it). using the -d option with the useradd command alleviates the task of having to create the home directory mannually because it does this for you.

on top of all that, if everything else is fine, yet the user still doesn't get CDE when they login, then check to see if $HOME/.dtprofile is configured properly or even exists. hope this all helps.
# 5  
Old 08-31-2001
or in the /etc/skel have a .profile already in there.
# 6  
Old 09-01-2001
thanks for all the help... but I found a "-k /usr/skel" parameter copied the files from skel to the directory.... and now it works. Smilie

thanks again Smilie
xyyz
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #224
Difficulty: Easy
In September 2019, according to NetMarketShare, Windows had just over 87% of the global desktop market, followed by Linux at close to 10%, and macOS in third place at around 2%.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Solaris 8 CDE Problem

All, I'm running Solaris 8 on a Sparcbook. One of my users, when logging in, defaults to Open Windows desktop rather than CDE. All other users get logged into CDE just fine. Is there a file or something that tells the system what default login is? I'm confused as to why it's just for this one... (4 Replies)
Discussion started by: leosmith78
4 Replies

2. Solaris

Connect to SunOS CDE from another CDE

I have two CDE desktop accounts on different server (called this CDE#1, CDE#2) on the same network. However, my current setup is connecting to the Solaris CDE#1,CDE#2 via Citrix. My plan is to connect to CD#1 and then somehow connect to CDE#2. How do I do this? I am just a regular user... (0 Replies)
Discussion started by: tthach830
0 Replies

3. UNIX Desktop Questions & Answers

How to migrate Solaris 10 CDE config to HP-UX CDE.

Hello, Do you guys by any chance know what is the best (if any ) way to move CDE configuration from a SOLARIS 10 machine to HP-UX? Just the config (actions, text files etc). Thanks in advance! (0 Replies)
Discussion started by: binary0x01
0 Replies

4. Solaris

Solaris 10 CDE problem - The DT messaging system could not be started

A Google search with: +Solaris +"The DT messaging system could not be started" returns 138 hits. All of the relevant possible solutions are in this document. My apologies for such a long document but I thought I would try to minimize the resolution attempts that I've already tried. System... (1 Reply)
Discussion started by: rpollard001
1 Replies

5. Solaris

Problem Starting CDE

hi, I have installed Solaris 10 from dvd. I have a 1.8GHz processor and 512mb RAM. When I start it, a message is displayed that Xserver cannot be initialised. Please tell me how to start computer in GUI mode, because it logs me into console mode. Regards Rochit (4 Replies)
Discussion started by: rochitsharma
4 Replies

6. UNIX for Advanced & Expert Users

Please Help with Tru64 CDE problem

When using the GUI we are unable to bring up the window for printer. We go through Applications/configuration/print this is the window that will not work all the other windows work ! Would anyone have any idea how to correct this and make the print window appear ???? (0 Replies)
Discussion started by: mlucas
0 Replies

7. HP-UX

root login problem in cde

Hi All, I m facing a problem that, i m not able to login as root user on cde on hp-ux 11.00, i can login as root on commond line as well as telnet. Thanks in Advance for help. Regards, Awadhesh (2 Replies)
Discussion started by: Awadhesh
2 Replies

8. HP-UX

CDE login Problem for root user only

Hi All, I m facing a problem that, i m not able to login as root user on cde on hp-ux 11.00, i can login as root on commond line as well as telnet. Thanks in Advance for help. Regards, Awadhesh (1 Reply)
Discussion started by: Awadhesh
1 Replies

9. UNIX for Dummies Questions & Answers

Cde

Hi There, easy one for you. I am using Solaris 7 on my desktop at home and I don't want to invoke the CDE environment when I boot up. I want it to just boot up to the command line to save on memory. What do I have to do in order to do this? Thanks for your help. (2 Replies)
Discussion started by: gerwhelan
2 Replies

10. UNIX for Dummies Questions & Answers

Cde

Hi, I'am new to SCO unix and their CDE desktop interface. Yesterdag i installed a unixware 7.11 system, but when I log in as a normal user and click on any icon in CDE i keep getting the same erro, talkback connection failed... what does this means??? I cant even shutdown the machine from... (1 Reply)
Discussion started by: zzero
1 Replies

Featured Tech Videos