Visit Our UNIX and Linux User Community


glib and gaim


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers glib and gaim
# 1  
Old 08-16-2001
glib and gaim

i'm trying to install gaim from source on suse linux. it has some problems finding the right version of glib during the configure script. the error looks like this:

checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.0...
*** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no

i just finished installing glib 1.2.9 without any problems. glib-config tells me i am using 1.2.9.

any ideas on how to fix this error would be greatly appreciated.

okay,
-nydel
# 2  
Old 08-16-2001
checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.0...
*** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best



I think you installed glib 1.2.9 when you have glib 1.2.10 in your system without uninstalling it first. The problem here is glib-config returns version 1.2.9 (one that you installed ) but when searching for libs it founds glib 1.2.10 which was in the system before.

I had the same problem before when I tried to install GTK+. I installed glib 1.2.10 (from source) without uninstalling the old one and GTK+ configure script complained version conflict. I fixed this by editing /etc/ld.so.conf . I placed /usr/local/lib (where my glib 1.2.10 was installed ) top in the list and run 'ldconfig'.


But recommended way to fix this error is to uninstall glib first.
rpm -e --nodeps glib
Make sure 'glib-config' returns no version thereafter.

Then reinstall glib. You can install glib either from the SUSE CD or download the latest from http://www.gtk.org


HTH
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #243
Difficulty: Easy
The starting point for host-to-host communication on the ARPANET in 1969 was the 1822 protocol.
True or False?

4 More Discussions You Might Find Interesting

1. Linux

glib-devel-2

Hi I want to install glib-devel-2.xx on suse 9 linux. I downloaded from below site, Index of /pub/gnome/sources/glib/2.24 and installed using normal configure,make,make install. Am I correct or something else is required? Thanks. (4 Replies)
Discussion started by: upengan78
4 Replies

2. Solaris

GLib 2.14.1

Hi, I have downloaded the glib 2.14.1 package from sunfreeware.com and installed it with pkgadd. However, glib-config --version shows the old version which is 1.2.10. I tried using crle but it just blew stuff up. I also tried glib-config --prefix=/usr/local but it doesn't seem to stick. I need... (2 Replies)
Discussion started by: cshore
2 Replies

3. SuSE

Gaim connect to MSN exchange

Is it possible for GAIM to connect to an MSN Exchange Instant Messaging server? (5 Replies)
Discussion started by: dhinge
5 Replies

4. Linux

Asking for gaim

Hello all users in this forum. I trye to update my gaim protocol for getting to msn messenger with Linux Mandrake KDE 3.1. Please help me. (2 Replies)
Discussion started by: itasm
2 Replies

Featured Tech Videos