Visit Our UNIX and Linux User Community


GLib 2.14.1


 
Thread Tools Search this Thread
Operating Systems Solaris GLib 2.14.1
# 1  
Old 10-15-2007
Question GLib 2.14.1

Hi,
I have downloaded the glib 2.14.1 package from sunfreeware.com and installed it with pkgadd. However, glib-config --version shows the old version which is 1.2.10. I tried using crle but it just blew stuff up. I also tried glib-config --prefix=/usr/local but it doesn't seem to stick. I need to upgrade GTK+ so I can in turn upgrade Glade but can't do so until glib shows the correct version. Has anyone came accross this problem before? Do I need to uninstall the old version of glib? If so, how do I go about removing it? I'm a Windows guy so all this console work is killing me. Smilie
# 2  
Old 10-15-2007
$ man pkgrm
# 3  
Old 10-17-2007
I removed glib 1.2.10 by doing pkgrm SUNWGlib. I no longer have glib-config so I can't tell what is going on. I reinstall glib 2.14.1 but still didn't have it. When I try and install GTK+ 2.10.14 I get the below error. I added /lib:/usr/lib:/usr/X11R6/lib to the LD_LIBRARY_PATH and did the same in ld.so.conf. There is no ldconfig on my box. The issue still remains. Smilie

checking for GLIB - version >= 2.12.0... no
*** Could not run GLIB test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding GLIB or finding the wrong
*** version of GLIB. If it is not finding GLIB, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error:
*** GLIB 2.12.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.

Previous Thread | Next Thread
Test Your Knowledge in Computers #147
Difficulty: Easy
Linus Torvalds released the Linux kernel as free software under the GNU General Public License in 1991.
True or False?

2 More Discussions You Might Find Interesting

1. Linux

glib-devel-2

Hi I want to install glib-devel-2.xx on suse 9 linux. I downloaded from below site, Index of /pub/gnome/sources/glib/2.24 and installed using normal configure,make,make install. Am I correct or something else is required? Thanks. (4 Replies)
Discussion started by: upengan78
4 Replies

2. UNIX for Dummies Questions & Answers

glib and gaim

i'm trying to install gaim from source on suse linux. it has some problems finding the right version of glib during the configure script. the error looks like this: checking for glib-config... /usr/local/bin/glib-config checking for GLIB - version >= 1.2.0... *** 'glib-config --version'... (1 Reply)
Discussion started by: nydel
1 Replies

Featured Tech Videos