Visit Our UNIX and Linux User Community


Problem with a script in crontab


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem with a script in crontab
# 1  
Old 06-08-2011
Problem with a script in crontab

Hi guys,

I have a shell script which i have put on crontab to run every min. Problem is that is isn't running.

But if i run the script from the existing location it runs perfectly.

but if i got out of the directory and run it giving the path. it doesn't work.

sh script_name.sh ---- works
sh /home/...../script_name.sh --- doesn't work.


this is the contend of the shell script

Code:
#!/bin/bash

export JAVA_HOME=/home/******/jdk1.5.0_07
export APP_HOME=/home/******/EmailProcess/bin
nohup $JAVA_HOME/bin/java -classpath .:$APP_HOME/lib/commons-discovery.jar:$APP_HOME/lib/commons-logging.jar:$APP_HOME/lib/activation.jar:$APP_HOME/lib/ojdbc14.jar:$APP_HOME/lib/commons-email-1.0.jar:$APP_HOME/lib/mail-1.3.3.jar  startSendEmails

need to know what is the issue.
Thanks for the help in advance.

Last edited by pludi; 06-08-2011 at 12:20 PM..
# 2  
Old 06-08-2011
what is the error message ??
exp file cannot be found or permission denied

may be the cron tab user don't have a permission to start the script. ??
you can check it bycreate a script in the same directory as you cron script and forward the output to a log file.

# 3  
Old 06-08-2011
The problem most likely is that you're including '.' (the current directory) in the classpath, but cron usually starts a script using /tmp or /var/tmp as the current directory. cd to your home directory first, after that it should work as intended.

If not, please post a meaningful error message, for example the message cron sends as email when a process fails.
This User Gave Thanks to pludi For This Post:
# 4  
Old 06-08-2011
Thanks pludi after adding cd dir to the script it worked.

 

Previous Thread | Next Thread
Test Your Knowledge in Computers #63
Difficulty: Easy
Blackberry was the first company to use the Emoji for mobile devices.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Script problem when running on crontab

Hi guys! I created a backup script that works fine when I run manually, but when I put a crontab job to execute it the result are not the expected. (not a time problem). Here is my script: bash-3.00# cat /bk_tool/backup2.sh #!/usr/bin/csh clear set DIR_HOST='SCP08' ... (3 Replies)
Discussion started by: andredemartini
3 Replies

2. Shell Programming and Scripting

Problem with perl script on crontab

Hi everybody, I have a perl script. I want to run it as a cron job every 10 minutes. I insert the command into crontab , using crontab -e. The problem is, I didnt get any output from script inside crontab, whereas when I run it manually through 'perl myscript.pl' it running well. Here is the cron... (2 Replies)
Discussion started by: franzramadhan
2 Replies

3. HP-UX

Problem with script arguments in crontab

I have a script scheduled in cron as shown below. 16 12 * * * /users/mydir/bin/process_master.ksh `date '+%Y%m%d'` >> /users/mydir/process_master.out This script executes correctly when invoked on command line, but doesn't work the same when scheduled in crontab. Crontab is working fine... (3 Replies)
Discussion started by: mk1216
3 Replies

4. Solaris

crontab problem

online* 22:25:22 svc:/system/cron:default cron service not able to start i tried to disble it is not working. showing online* status. thanks (1 Reply)
Discussion started by: sunnybee
1 Replies

5. Shell Programming and Scripting

Problem with crontab running a script

I am trying to use the CRON utility in Fedora 11 & CentOS... I intend to run a script which pops up a warning message every hour and i made the following entry using "CRONTAB -e " * * * * * sh /bin/myscript.sh But this does not seem to be running. Another thing to note is that,... (4 Replies)
Discussion started by: Vabiosis
4 Replies

6. Linux

Problem with crontab + bash script

Crontab: 16 14 * * * /root/bin/./empty_mail.sh >> /root/bin/log.txt L=`mailq |grep -c frozen` echo "${NUMMAIL} frozen mail to be removed from the mailq" #echo "Press Enter to continue" #read CONTINUE echo -en "-> " for i in `mailq | grep frozen | awk '{print $3}'` ; do exim4 -Mrm $i... (1 Reply)
Discussion started by: wessberg
1 Replies

7. UNIX for Dummies Questions & Answers

Variable problem in script when using crontab

Hi, this is my first shell script. Anyway i am trying to ftp files from one machine to another. The name of the script is ifsftp_orabkp. The code is as follows: HOST="122.122.122.22" USER="ftp_ftp" PASSWD="ftp.222222" Y1=`(perl -e '@y=localtime(time());printf... (11 Replies)
Discussion started by: dazz
11 Replies

8. Shell Programming and Scripting

problem running shell script (for oracle export) in crontab

Hello Gurus, I've been tasked with solving a problem at my new job and I'm stumped. We've got a script that dynamically builds an oracle export parameter files and then runs export from the shell. it runs fine when using the shell, but will NOT run (fails in one spot everytime) when entered... (1 Reply)
Discussion started by: jsheehan223
1 Replies

9. Solaris

Unix script Problem with crontab

Hi Experts, Am facing some problems with script (Sun solaris 9). My script (sqlplus.sh)looks like this. . . ............................................... set 'date' dd=$3 export dd mon=$2 export mon yyyy=$6 export yyyy cd /oracle/P47/saparch... (8 Replies)
Discussion started by: vrjalli
8 Replies

10. Shell Programming and Scripting

Problem with executing a script scheduled in crontab

Hi I have written a shell script(in Solaris) in which following logic is there..... i=1 while read control do key=`echo $control | awk -F$DELIMITOR '{ print $1 }'` echo "Key Values" ${key} i=`/usr/bin/expr $i + 1` done < $CONFPATH/$CONFFILE when i execute it at prompt it... (4 Replies)
Discussion started by: Amardeep
4 Replies

Featured Tech Videos