Visit Our UNIX and Linux User Community


compiling


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers compiling
# 1  
Old 07-31-2001
Question compiling

would anyone know of a good online tutorial on compiling and installing tarballs? i'm looking for one that assumes that you know very little to nothing about unix.
# 2  
Old 08-01-2001
it is 99.9% ALWAYS coverd in the file labeled README or INSTALL and usually assumes you know nothing about unix so EVERYONE can do it.

this is the best place to start.

if you are trying to install a package on solaris look into the man pages for:

pkgadd
pkgrm
pkginfo
# 3  
Old 08-03-2001
First you untar the file. I suggest you first examine the tar file by doing something like a: tar tvf filename.tar or tar tvzf filename.tar.gz or tar tvzf filename.tgz whatever works for you.

This allows you to view how the file will be untarred, just to be safe. Normally, the distribution will untar into it's own directory, but sometimes (not often) it just dumps 'not so nicely'.

After you find out that it untars nicely (or you create a directory to untar) you then do a tar xvf filename.tar or tar xvzf filename.tar.gz or tar xvzf filename.tgz whatever works for you Smilie

Then, you cd into the directory and then follow Optimus's idea to read the README or INSTALL file. This is a text file and you should read carefully, perhaps even print, go to the couch, and relax and read.

Normally, good tarfiles will have a command you run in the root directory that says ./configure or something like that. This script will do lots of genius system checking and automatically create the Makefile . Most of the times, that is all you have to do. make then make install .

However, you might like to install things in different places than the default, need to link special libs, add special compile time features, etc. This is all nicely documented in any good README or INSTALL file.

There are other ways..... but the description above is bare bones, no frills, untar, configure, make and make install.

Enjoy! This is a well established UNIX tradition that is fun and easy after you get the hang of it !!! As Optimus says, the key is to read the README first file.

BTW: The programmers have spent a lot of time to create the ./configure scripts to generate the Makefile. They work super hard to make this error free in a cross-vendor cross-compiler world, and they give great things away for FREE!! This is really a core UNIX cultural trait. It is both the strength of UNIX and a weakness. The strength is that it is free. The weakness is that free is not normally a commercially viable model, so you don't call and scream at the person who wrote the code and gave it away for free.... you spend some time working out the difficulties because the time you spend on your install debug is a fraction of the time the programmer spent in writing your free code that does all the wonderful things you like.

This cultural model is actually one of the greatest achievements of the Internet age, if you ask me, and a tribute to the unselfishness of the technical community as a whole. As you might agree, this is a rare trait in the modern world.

Respect and Honor the Tradition
# 4  
Old 08-03-2001
thanks, that was inspiring and helpful. Smilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #704
Difficulty: Medium
Under the same-origin policy, a web browser permits scripts contained in a first web page to access data in a second web page, but only if both web pages have the same origin.
True or False?

10 More Discussions You Might Find Interesting

1. Linux

kernel compiling

Hello, I have several questions to get awnsered about the newer linux kernels (2.6.25) and above. 1st question: Ive read that the newer kernels you can compile the marvell sd8686 driver from the source. can anyone confrim this? only binaries i see for that driver are for 2.6.24 and im already... (0 Replies)
Discussion started by: old noob
0 Replies

2. HP-UX

Problem in HP-UX compiling

Hi When im trying to do make --version and make --help in HP-UX it throws error Make: Unknown flag argument -. Stop. a soft link is present in this directory /usr/bin/make and hard link is in /usr/ccs/bin/make what could be the reason can any1 ..please tell me how to solve this... (1 Reply)
Discussion started by: vasanthan
1 Replies

3. Programming

Compiling with Dll in HP Ux

Hi all, I had trouble compiling my application with a custom dll, the error appear to be some undefined reference to the functions i had created in my dll. Is there a need to update any environmental variable such as LD_LIBRARY_PATH as in linux system. Please advise. One more thing is do... (2 Replies)
Discussion started by: dwgi32
2 Replies

4. Solaris

Compiling programs

Hi guys i have posted a thread months ago and a guy called dukenuke or smething like that told me that i have to install Sun Studio if i want to be able to compile programs. I have installed Sun Studio 12 and put it in my PATH but no success compiling anything. when i download some source (tar.gz)... (2 Replies)
Discussion started by: saveka
2 Replies

5. UNIX for Advanced & Expert Users

re-compiling

I have a problem. How can I be sure that the binary currently in production is the binary originally produced by the compiler? I ask because recompiling the sources (ALL sources + stripping away the metadata: strip ...) does not give the same result. I am pretty sure that I wasn't hacked! ... (5 Replies)
Discussion started by: aViking
5 Replies

6. HP-UX

compiling the RRDtool

I tried to compile the RRDtool on HP-UX (IA56). I have gcc-3.4.3 and perl 5.8.0 I got this: Writing Makefile for RRDs cd perl-shared && make /opt/perl/bin/perl /opt/perl/lib/5.8.0/ExtUtils/xsubpp -typemap /opt/perl/lib/5.8.0/ExtUtils/typemap RRDs.xs > RRDs.xsc && mv... (2 Replies)
Discussion started by: Kalin
2 Replies

7. AIX

compiling with aix 5.1

Hello, i will compile php and apache on an aix 5.1. Configure works fine. When i start the make the following error appears: /usr/include/sys/context.h:155: parse error before "sigset64_t" /usr/include/sys/context.h:158: parse error before '}' token make: 1254-004 The error code from the... (1 Reply)
Discussion started by: n-may
1 Replies

8. Programming

compiling

I am new to unix so please forgive ignorance. I am running openbsd-2.9 and need some help. All the software I run was added via the package system openbsd has. There have been times when I need an app. But it was not in the openbsd ports and or packages system. I usually just wait for it to show up... (1 Reply)
Discussion started by: Blunt_Killer
1 Replies

9. UNIX for Dummies Questions & Answers

compiling qt

i am trying to compile and install free qt for x11 2.2.4 in order to use kde 2.1. i'm using freebsd 4.3 i currently have XFree86 installed and working. i followed these instructions: ftp://ftp.trolltech.com/qt/source/INSTALL i get through the unpacking fine and i set my .profile. --... (2 Replies)
Discussion started by: nydel
2 Replies

10. Programming

C compiling

I recently loaded SuSE on my intel comp. I am presently taking a walk down memory lane from my days at UofT. I was fiddling round with cc and the gcc compilers. I wrote a basic basic basic program . I tried to compile it as I remember doing in Uni. The problem is that it can't find the header... (5 Replies)
Discussion started by: cantcatchme
5 Replies

Featured Tech Videos