Visit Our UNIX and Linux User Community


xfree86 configuration


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers xfree86 configuration
# 1  
Old 07-31-2001
xfree86 configuration

I've been trying to configure XFree86, and the first times that I have, it will only run at 320x? resolution.. I have an ATI card, and I've tried using the /stand/sysinstall graphical configuration method, and I've tried xf86config as well, both render the same results. that was before i reinstalled everything, i wiped the partition and reinstalled FreeBSD, upgraded it and recompiled the kernel (which i did before too). now, when I try to configure xfree86, and it displays "attempting to start server.." it just stops, like it is frozen, and nothing happens.

I know what graphics card I have, and I know what resolution/frequency my monitor can handle, but it's not working out at the moment. I'm not going to give up until i get it to work, so any suggestions are welcome. thank you for your time.
# 2  
Old 07-31-2001
i had the same problem with my ati radeon. did you try this:

XFree86 -configure

? that was the only thing that worked for me....it pretty much automatically detects everything.
# 3  
Old 08-01-2001
thanks, i'll try that
# 4  
Old 08-06-2001
Error

Hello,

I have been trying to load SuSE on my machine.
Details are as follows:

Tyan tiger 133 dual PIII 700's

1.5 GB RAM

4-20 GB IBM DTA HDD' (set as IDE)

Asound Gold ISA card

generic 24X CD-ROM Drive

ATI Radion Rage Pro graphics accelerator W/ 34MB of onboard RAM

EMC 21" high end monitor (that I don't have the drivers for.)

Epson color stylus 600 printer

Logitech Quick cam

HP colorado 8 GB Tape backup

Here is the issue I am having:
I blew away the Windose 2000 server that was running AD and was an DFS on Raid 5.

When I loaded SuSE I got to a screen that was to configure x11.
I set the video card to generic and at the next screen set the ram to 3400K.

I cannot find my monitor in the list that SuSE gives so I picked settings that are close to what I use.

KDE or Gnome will not load.
I used YasT2 to reconfig the X11R6 file but this got me to a loop detailing that I need a virtual link to my /usr/bin directory from the /var/bin directory.

I made the limnk and it directly went back into the X11R6Configure file and started again to get me into this mad loop.

I blew away the SuSE install and re-loaded Windose 2000 Server to get back online "as I am a newbee at UNIX and it's commands."

I humbly ask these questions.
1. What would be the easiest way to install this SuSE server package?

(I am willing to get a-whole-nother graphics card and monitor if this is what is causing all the issues. )

2. Is getting a Sun Microsystems unit for this install worth the cash layout?

Thank you in advance.


 

Previous Thread | Next Thread
Test Your Knowledge in Computers #730
Difficulty: Medium
The first version BASIC language was released on 1 May 1964.
True or False?

9 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Old XFree86 configuration error

Hello experts, I installed an old linux distribution and i'm having troubles with the XFree86 server. The thing is, when i run XF86Setup, X server and windows actually works, because i can get the graphical configuration screen, but when i'm "done" and save the changes to the config file... (1 Reply)
Discussion started by: semash!
1 Replies

2. BSD

XFree86 4.5 problem

Hello, i have a S3 Trio64V+ card. I installed last release of XFree under FreeBSD 5.4. I do xf86config, but when i try startx i have this error: nsinternal# startx XFree86 Version 4.5.0 Release Date: 16 March 2005 X Protocol Version 11, Revision 0 Build Operating System: FreeBSD... (1 Reply)
Discussion started by: jamesf
1 Replies

3. BSD

again XFree86

hi everybody i installed FreeBSD 5.x on a box with a video card Diamond SpeedStar A90 and a Fujitsu Siemens Monitor B772-1 when i do "startx" it gives me something like this: fatal error: no devices detected no screen detected i'm lost...i don't know what to... (3 Replies)
Discussion started by: hmaiida
3 Replies

4. BSD

Problems with Xfree86

Hi to all! I'm very novice in Unix/Linux. I installed FreeBSD 4.10 in my pentium II 450mhz 64MB 4.300GB more than 5 times and the error continues... In the line mode i type "startx" (to enter in X)...but show me a message : FATAL SERVER ERROR NO SCREENS FOUND X CONNECTION TO :0.0... (6 Replies)
Discussion started by: israel
6 Replies

5. UNIX Desktop Questions & Answers

X.Org and XFree86

X.Org just released a new version of their X (X11R6.7). Besides Liscense stuff, what is better about X.org then XFree? What is better about XFree then X.org? Also: Will my fglrx (ATI) or nvidia drivers (designed for XFree86 4.3) work on X.org? (2 Replies)
Discussion started by: punkrockguy318
2 Replies

6. UNIX for Dummies Questions & Answers

compiling XFRee86 4.2.0

i am currently trying to compile XFree86 under redhat 7.3. i am used to ./configure make make install, but i know that xfree86 is very different. what are the basic steps for building it. i already have read the documentation, but it wasn't of much help. it was erroring out on the imake. i don't... (1 Reply)
Discussion started by: choasforages
1 Replies

7. UNIX Desktop Questions & Answers

Installing XFREE86 4.2 question

Hi folksss.. I will ask similiar to my previous post. Have anyone successfully install XFree86 ver. 4.2 on FREEBSD 4.5 from scratch ??? If U do, please provide step by step how U do it. Do U use graphic user interface to setup the hardware configuration or DOS configuration ? I... (2 Replies)
Discussion started by: helpme2
2 Replies

8. UNIX Desktop Questions & Answers

XFREE86 4.2 question

Hi folkss... I just install Freebsd 4.5 mini disk which install only the core FREEBSD system nothing else. I then want to install KDE 3.0 so I install XFREE86 4.2 and I installed both of these programs successfully with pkg_add "filename.tgz" I also install wrapper.tgz for "startx"... (1 Reply)
Discussion started by: helpme2
1 Replies

9. Programming

XFree86

So where do we post questions about developing for X? Or do we just not do that here? (2 Replies)
Discussion started by: Gekko
2 Replies

Featured Tech Videos