Visit Our UNIX and Linux User Community


Dns


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Dns
# 8  
Old 06-29-2001
heh sorry optimus Smilie

I had a nightmare with DNS a while back, and spent countless times retstarting the named daemon on a client, only to find out that it should not have been running anyway - hence diverting my attentions down the incorrect route. Just wanted to save someone else the hassle! Smilie

By the way Dlongman optimus has given me the idea that you may want to check the syslog on the nameserver and check that named loaded the zonefile for the host you are pinging correctly, without any errors, and if not then send a HUP to named to restart Smilie

Regards.
alwayslearningunix
# 9  
Old 06-29-2001
Well I've been able to use nslookup and query the DNS server successfully. (even able to query domain names outside of our domain)

Any ideas why

ping proxy1.compassgroup.com doesn't work?

compassgroup.com is our local domain
ensured that proxy1 has been defined on the DNS server.

I can ping proxy1 and it works(defined in the host file)?

Thanks

# 10  
Old 06-29-2001
try this and tell me if you find the address you can not resolve in there.

Code:
#nslookup
>ls -a compassgroup.com > company.dnstables

this should dump the companys tables to that file name now just search for the host your looking for to ensure for your peice of mind that it is in there.

also

if you can ping proxy1.compassgroup.com then name to ip translation HAS to be working. but if you get a failed response then that part is down.

if you can ping proxy1.compassgroup.com via its IP then you know the name to ip part is not working.

if you CAN NOT ping it at all then the host is a) down b) not in the tables.

another side note: now there were talkig about dns my co-worker is like yeah were using new dns servers im like we are? my servers are still running on the old ones. hes like yeah the windows stuff was tossed into a diff. domin. i was like IC so we tried the new dns server and what not. all but one worked. cuz i am gunna bet it is not in the tables.

looks like our problem was a zone transfer problem.

Last edited by Optimus_P; 06-29-2001 at 03:34 PM..
# 11  
Old 06-29-2001
Well here is what i found:

NSLOOKUP

>ls -a compassgroup.com
[[192.9.202.100]]
Host or domain name Alias
>

Now if i just enter
>proxy1
Server: [192.9.202.100
Address: 192.9.202.100

Name: proxy1.compassgroup.com
Address: 192.9.202.155

Proxy1 is defined on the DNS server using an A record

Here's the story on PING

ping proxy1.compassgroup.com - does not work
ping proxy1 - works
ping 192.9.202.155 - works

Any ideas?

Don
# 12  
Old 06-30-2001
CPU & Memory Step-By-Step

OK. Let's work this problem step-by-step for our friend DLongan Smilie

Questions for DLongan:

Who has configuration control of the DNS nameserver you
are using?

If it you or your friend, please post the /etc/named.conf file or /etc/named.boot file (or similar file) so we can take a look.

BTW: My test results:

Code:
www# nslookup

> server 192.9.202.100 
Default Server:  [192.9.202.100]
Address:  192.9.202.100

> proxy1
Server:  [192.9.202.100]
Address:  192.9.202.100

*** [192.9.202.100] can't find proxy1: No response from server

> proxy1.compassgroup.com 
Server:  [192.9.202.100]
Address:  192.9.202.100

*** [192.9.202.100] can't find proxy1.compassgroup.com: No response from server
> ls -d compassgroup.com
ls: connect: No route to host
*** Can't list domain compassgroup.com: Unspecified error

Results looks like your DNS server is not working or configured properly.
# 13  
Old 07-02-2001
Neo,

The name server only serves our intranet, I am glad to see that you weren't able to access it!

Its a winnt 4.0 box, and it's functioning as a forwarder. I can ping using FQDN from other win boxes. I don't have another unix box to try from.


Here is the dns config
;
; Database file compassgroup.com.dns for compassgroup.com zone.
; Zone version: 56
;

@ IN SOA compassnt.compassgroup.com. itsupport.compassgroup.com. (
56 ; serial number
3600 ; refresh
600 ; retry
86400 ; expire
3600 ) ; minimum TTL

;
; Zone NS records
;

@ NS compassnt

;
; Zone records
;

chicago A 192.9.203.1
classic A 192.9.202.140
compassnt A 192.9.202.100
email A 192.9.202.100
intranet A 192.9.202.155
intuity A 192.9.202.130
proxy1 A 192.9.202.155
resumix A 192.9.202.120
www A 63.162.128.17


Any suggestions would be greatly appreciated,

Don
# 14  
Old 07-02-2001
Since we can't access it, we can't check how it is working from the outside. Sorry, I could help you if your DNS server was UNIX.

 

Previous Thread | Next Thread
Test Your Knowledge in Computers #102
Difficulty: Easy
Unix, Linux and other Unix-like operating systems are a family of computer operating systems that are derived from DOS.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

DNS client added to DNS server but not working

Hi, We have built a new server (RHEL VM)and added that IP/hostname into dns zone configs file on DNS server (Solaris 10). Reloaded the configuration using and added nameserver into resolv.conf on client. But when I am trying nslookup, its not getting resolved. The nameserver is not able to... (8 Replies)
Discussion started by: snchaudhari2
8 Replies

2. Red Hat

dns

how do we update dns zone file entries without restarting named demon (5 Replies)
Discussion started by: abhay1983
5 Replies

3. Red Hat

DHCP & DNS - Clients get IP but don't register in DNS

I am trying to setup a CentOS 6.2 server that will be doing 3 things DHCP, DNS & Samba for a very small office (2 users). The idea being this will replace a very old Win2k server. The users are all windows based clients so only the server will be Linux based. I've installed CentOS 6.2 with... (4 Replies)
Discussion started by: FireBIade
4 Replies

4. Red Hat

DNS A-Record point to another DNS

Hi, I have a question on how to point the DNS server-1's A-record to second DNS server, which is DNS server-2. So, the computer can access other domain which only listed in the DNS server-2. The scenario is as follow: http://img689.imageshack.us/img689/6333/12234.png How to configure this... (4 Replies)
Discussion started by: Paris Heng
4 Replies

5. UNIX for Advanced & Expert Users

DNS server choice: Windows DNS vs Linux BIND

I'd like to get some opnions on choosing DNS server: Windows DNS vs Linux BIND comparrsion: 1) managment, easy of use 2) Security 3) features 4) peformance 5) ?? I personally prefer Windows DNS server for management, it supports GUI and command line. But I am not sure about security... (2 Replies)
Discussion started by: honglus
2 Replies

6. Solaris

Solaris DNS Client For Microsoft DNS Server

hey guys, how to add soalris box as a microsoft DNS Client ? and how to register in the microsoft DNS ?? i managed to query from the DNS server after adding /etc/resolve.conf and editing /etc/nsswitch.conf but i need to register the soalris server (dns Client) into Microsoft DNS automatically.... (3 Replies)
Discussion started by: mduweik
3 Replies

7. IP Networking

Dns

I would like to set up a DNS on my system, just to learn really, how difficult and what all is involved in the set up? How difficult? (6 Replies)
Discussion started by: jo calamine
6 Replies

8. UNIX for Dummies Questions & Answers

DNS Server help

Hi, I would like to create an internal webpage for my company that would only be viewable when connected to the VPN or internal network. I want a webpage like newsite.company.com. Is there a way to do this. We obviously already have www.company.com, but how would I go about creating the newsite.... (1 Reply)
Discussion started by: ejbrever
1 Replies

9. UNIX for Dummies Questions & Answers

Dns

I just bought a unix dedicated server from a company so that i can host websites on that server. I wanted to configure it but I have no clue :confused: as to where to start. If some one can just guide me to the right direction, i would greatly appreciate it. megnote (1 Reply)
Discussion started by: megnote
1 Replies

10. UNIX for Dummies Questions & Answers

Dns

Is there a website to go to that gives you a set of instructions to set up DNS from start to finish? I need it for a Solaris 8 box on the Intel platform side. (3 Replies)
Discussion started by: Deuce
3 Replies

Featured Tech Videos