Sftp Umask


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Sftp Umask

Hi All,

in my HP-UX 11.11 , there is an parameter of SFTP_UMASK at env,
but How do we use it ?

I tried with type : SFTP_UMASK=022
and when I type : env
the SFTP_UMASK value has changed to 022 .

but when I send a file with use SFTP from other pc/server .
It still umask 077 (chmod 700) on the file .

What should I do If I need to set one user to get an umask=022 when the file comes from SFTP ??


Thx
-dju
# 2  
I would have thought this would be a server side configuration.
# 3  
yes , correct..
this parameter is on my server..

I would like to set SFTP umask on my server.
so, If there any files come from other to my server. it will be automatically have permission 744.


thx
-dju
# 4  
Quote:
Originally Posted by mdjuarsa
it will be automatically have permission 744.
Normally umask works the opposite way, it shows the bits that won't be enabled.
# 5  
Am not too sure, but can you try setting the umask in the profile of the userid with which you are connecting to the server? I have faced a pretty similar problem, but we had to implement a complicated solution...
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #175
Difficulty: Medium
ENIAC was one of the first electronic computers and occupied 167 square meters, weighed 27 tons and consumed 150kW of electricity.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Umask help!

Hi guys, I want all new files and directories created, or copy file give this permisson "rwxrwx---", with chmod i do this with octal value "770". If i execute "umask 770" the permissons is not the same with new or copy file. How can i configure this command? I do not understand the "man... (1 Reply)
Discussion started by: Xedrox
1 Replies

2. Shell Programming and Scripting

Help for umask

Hi, I want to set umask value only for vi editor. If I create new file using vi editor, then automatic permission should be 777. I want to set umask 000. Please help me. Thanks in advance (2 Replies)
Discussion started by: mnmonu
2 Replies

3. AIX

UMASK

How do I change the umask for a NIS user? Thanks steve (1 Reply)
Discussion started by: steve.lavoie
1 Replies

4. UNIX for Dummies Questions & Answers

umask for internal-sftp users ?

Hello, Running Debian 5. SSH version 5.1p1-5. How do I set umask for sftp only users ? Users are jailed - that means they use internal-sftp: # cat /etc/ssh/sshd_config .......... Match group group1 ChrootDirectory /home/%u X11Forwarding no AllowTcpForwarding... (2 Replies)
Discussion started by: vilius
2 Replies

5. UNIX for Advanced & Expert Users

umask

Hi, Please, let me know how the umask is working? As per my understanding is aprt from subtracting from 666/777, logical gate operation is performing. Ex: If I set uname 011, it gave the permission like 666 for file. Request you to explain which gate's operation performed. $uname 011... (4 Replies)
Discussion started by: Nagapandi
4 Replies

6. UNIX for Dummies Questions & Answers

Umask

I need to set a umask of 022 for my ssh sessions, or within my profile. I have set the umask in both bash_profile and bashrc. and when i run umask i get 0022 but when i create a file i get, # touch test.txt # ls -l test.txt -rw------- 1 root root 0 Apr 26 12:25 test.txt it seems like... (1 Reply)
Discussion started by: felix001
1 Replies

7. Solaris

umask

Due to urgent requirement to resolve some permission issues , I wish to set solaris 8 server so that any file written is on 777 . I guess need to set umask , how to set it ?? (7 Replies)
Discussion started by: falcon16
7 Replies

8. UNIX for Dummies Questions & Answers

umask

Hi, I have a doubt on the umask values. Why is the UMASK value is different from file and directory? Suppose if the umask value is 0022. The file permissions for a newly created file is 644 and the file permissions for a newly created directory is 755. My doubt is why can't it be the... (1 Reply)
Discussion started by: praveen_b744
1 Replies

9. Linux

help on umask

hai guys , i am having problem in getting the knowledge about umask. actually when i am putting command as umask some value is coming like 0022 by defalut. we can change its value also. but the main thing is thye file permisiion actually depends upon umask.how is it depends upon umask i want to... (6 Replies)
Discussion started by: suvendu4urs
6 Replies

10. AIX

Umask help

I changed the umask in /etc/security/user to 027. I changed the umask in /etc/profile to 027. My current shell is ksh. My .profile doesn't make any changes to umask or call other scripts that change umask. Running AIX 5.3 I still get a umask of 022 instead of the expected 027. I have no... (1 Reply)
Discussion started by: x96riley3
1 Replies

Featured Tech Videos