Visit Our UNIX and Linux User Community


GNOME Desktop - Setting missing from dconf-editor?


 
Thread Tools Search this Thread
Special Forums UNIX Desktop Questions & Answers GNOME Desktop - Setting missing from dconf-editor?
# 1  
Old 03-05-2014
GNOME Desktop - Setting missing from dconf-editor?

Hello All,

Last night I installed OpenSuSE 12.1 (i586) on a HP Mini 110 laptop. And I selected GNOME as my Desktop during install...

So I was trying to customize some things about the desktop, for example adding the Maximize/Minimize/Close options to the titlebar of a window.

I did this exact customization on an OpenSuSE 12.3 server running GNOME as well. What I did to get this on that server was:
Quote:
- Open 'dconf-editor'
- Navigate to org > gnome > desktop > wm > preferences.
- Now, in the preferences section I have the option to customize the look and feel the windows. Including the Option "button-layout".
So when I try this exact same thing on the 12.1 laptop I don't have the "wm" option to navigate to...

Does anyone know why I would be missing this option, is there a package I need in order to do this?

Any thoughts or suggestions would be much appreciated!

Thanks in Advance,
Matt
# 2  
Old 03-05-2014
Is the tweak tool loaded?
Code:
$ yum -y install gnome-tweak-tool $ gnome-tweak-tool

Try something like
Code:
dconf write /org/gnome/shell/overrides/button-layout '":minimize,maximize,close"'

google for other options
This User Gave Thanks to blackrageous For This Post:
# 3  
Old 03-06-2014
Hey, thanks for the reply...

Ok so I installed the gnome-tweak-tool and changed the setting for:
Code:
Shell >> Arrangement of buttons on titlebar:  FROM-->'Close Only'   TO-->'All'

But nothing seemed to change from doing that... I also tried rebooting after the change but nothing changed then either.

So I then tried the dconf command you posted, and after running the command I checked the dconf-editor GUI and it is showing under Shell > Overrides > button-layout... But after restarting still nothing changed...

I think there has got to be something I'm missing on the laptop that the 12.3 srv has... Maybe metacity? I noticed it running on the server.
I'll try some more stuff in the mean time, but if anyone else has any ideas please feel free.

Thanks Again,
Matt

---------- Post updated 03-06-14 at 02:31 PM ---------- Previous update was 03-05-14 at 06:27 PM ----------

Ok I figured it out!!
It took me a while to get it working but it is finally working...!!

I had to change the settings in the GConf-Editor. The setting to fix this was under:
Code:
/ > desktop > gnome > shell > windows > button_layout

After making the change here I needed to logout and log back in and it fixed my window's titlebar to have all 3 buttons now.
Also, since the laptop is a HP Mini with a mini screen I also adjusted the font size for all the windows, but I don't really remember where that setting was...?

I could have sworn I had tried changing the button_layout setting before and it was giving me an error so I thought it was weird that it worked this time, but I
found out why that wasn't working at the time either. I had been trying to change this from the wrong location in the GConf-Editor... I was attempting to
change this from:
Code:
/ > schemas > desktop > gnome > shell > windows >  button_layout

But I was getting this error:
Quote:
Currently pairs and schemas can't be edited. This will be changed in a later version.
Thank goodness I found that setting in that other location!

But thanks for the help and suggestions!

Thanks,
Matt

Previous Thread | Next Thread
Test Your Knowledge in Computers #728
Difficulty: Medium
Bjarne Stroustrup was awarded the Computer Pioneer Award for pioneering C++.
True or False?

7 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Backup & restore Gnome Desktop and all settings in Gnome

Hi I'm looking for scripts to backup & restore Gnome Desktop and all settings in Gnome. (0 Replies)
Discussion started by: ccc
0 Replies

2. Fedora

Missing some System Settings from Gnome

Hello, I just installed Fedora 16 and wanted to add some apps to startup but realized System settings has only a small setup of utilities and does not have option for adding apps to startup. Also it's missing some other icons that I see on my Rhat 6.2 . I'm logged in as user from admin group but it... (2 Replies)
Discussion started by: susja
2 Replies

3. Solaris

Persistent Security Banner on Gnome Desktop

I'm looking for options for displaying a persistent, security banner on a Solaris 10 workstation running JDS that would display at the top of each workspace for all users, have the option to change the color and the capability to add text to the banner. The company I work for has used JEDI for... (5 Replies)
Discussion started by: ArizonaTraveler
5 Replies

4. SuSE

SLED 10.2 Default gnome desktop generation

Hi! Does anyone know where to alter the default gnome setup that SLED 10.2 does? I work for a big company and we have a huge issue with SLED adding the "main-menu" gnome panel applet thingie.... /opt/gnome/lib/gnome-main-menu/main-menu Is there any way to exchange this process for ex the... (0 Replies)
Discussion started by: Esaia
0 Replies

5. Shell Programming and Scripting

set EDITOR=vi -> default editor not setting for cron tab

Hi All, I am running a script , working very fine on cmd prompt. The problem is that when I open do crontab -e even after setting editor to vi by set EDITOR=vi it does not open a vi editor , rather it do as below..... ///////////////////////////////////////////////////// $ set... (6 Replies)
Discussion started by: aarora_98
6 Replies

6. UNIX for Dummies Questions & Answers

Umask, in Desktop(gnome)

I want user, have umask 007, i just add in .bashrc and working, but our user using GDM for login, so I just add umask in /etc/profile. Is ther other way to put umask than in /etc/profile if using GDM? How to make .bash_profile with our define(default with my setting). Thank you. (1 Reply)
Discussion started by: blesets
1 Replies

7. UNIX for Advanced & Expert Users

Gnome desktop crash log

Hi All, When ever gnome desktop crashes, is it write errors to any log files? if yes please let me know log file name and path for the same. Thanks in advance for your inputs. Regards Bachegowda (0 Replies)
Discussion started by: bache_gowda
0 Replies

Featured Tech Videos