Can't open boot device..


 
Thread Tools Search this Thread
Operating Systems Solaris Can't open boot device..
# 1  
Old 10-10-2013
Can't open boot device..

Hello Forum,
I'm really in a fix now,

I'm getting this error message now, seems like the boot block is damaged?
When I do
Code:
probe-all

the system freezes...
Can any one guide me as what to do next?
System is Solaris 8 running Open Boot PROM 4
System also does not have a cd/dvd rom drive...

Thanks you for any suggestions...
Code:
ok show-disks
a) /pci@1f,0/pci@1,1/ide@d/cdrom
b) /pci@1f,0/pci@1,1/ide@d/disk
q) NO SELECTION
Enter Selection, q to quit: b
/pci@1f,0/pci@1,1/ide@d/disk has been selected.
Type ^Y ( Control-Y ) to insert it in the command line.
e.g. ok nvalias mydev ^Y
         for creating devalias mydev for
/pci@1f,0/pci@1,1/ide@d/disk
ok boot /pci@1f,0/pci@1,1/ide@d/disk
Boot device: /pci@1f,0/pci@1,1/ide@d/disk  File and args:
Can't open boot device

Code:
ok show-devs
/SUNW,UltraSPARC-IIe@0,0
/pci@1f,0
/virtual-memory
/memory@0,40000000
/aliases
/options
/openprom
/chosen
/packages
/pci@1f,0/pci@1
/pci@1f,0/pci@1,1
/pci@1f,0/pci@1,1/sound@8
/pci@1f,0/pci@1,1/SUNW,m64B@2
/pci@1f,0/pci@1,1/usb@5,3
/pci@1f,0/pci@1,1/network@5,1
/pci@1f,0/pci@1,1/ide@d
/pci@1f,0/pci@1,1/pmu@3
/pci@1f,0/pci@1,1/usb@c,3
/pci@1f,0/pci@1,1/network@c,1
/pci@1f,0/pci@1,1/isa@7
/pci@1f,0/pci@1,1/ebus@c
/pci@1f,0/pci@1,1/ide@d/cdrom
/pci@1f,0/pci@1,1/ide@d/disk
/pci@1f,0/pci@1,1/pmu@3/watchdog@0,cc
/pci@1f,0/pci@1,1/pmu@3/beep@0,b2
/pci@1f,0/pci@1,1/pmu@3/ppm@0,b3
/pci@1f,0/pci@1,1/pmu@3/i2c@0,0
/pci@1f,0/pci@1,1/pmu@3/i2c@0,0/pmc-fru@0,ac
/pci@1f,0/pci@1,1/pmu@3/i2c@0,0/motherboard-fru@0,a8
/pci@1f,0/pci@1,1/pmu@3/i2c@0,0/dimm@0,a6
/pci@1f,0/pci@1,1/pmu@3/i2c@0,0/dimm@0,a4
/pci@1f,0/pci@1,1/pmu@3/i2c@0,0/winbond@0,5a
/pci@1f,0/pci@1,1/isa@7/serial@0,2e8
/pci@1f,0/pci@1,1/isa@7/serial@0,3f8
/pci@1f,0/pci@1,1/isa@7/power@0,2000
/pci@1f,0/pci@1,1/isa@7/dma@0,0
/pci@1f,0/pci@1,1/isa@7/dma@0,0/parallel@0,378
/pci@1f,0/pci@1,1/isa@7/dma@0,0/floppy@0,3f0
/pci@1f,0/pci@1,1/ebus@c/idprom
/pci@1f,0/pci@1,1/ebus@c/eeprom@14,0
/pci@1f,0/pci@1,1/ebus@c/flashprom@10,0
/openprom/client-services
/packages/kbd-translator
/packages/dropins
/packages/ps2-keyboard
/packages/SUNW,builtin-drivers
/packages/disk-label
/packages/obp-tftp
/packages/deblocker
/packages/terminal-emulator

Code:
ok devalias
screen                   /pci@1f,0/pci@1,1/SUNW,m64B@2
dload                    /pci@1f,0/pci@1,1/network@c,1:,
net2                     /pci@1f,0/pci@1,1/network@5,1
net                      /pci@1f,0/pci@1,1/network@c,1
cdrom                    /pci@1f,0/pci@1,1/ide@d/cdrom@2,0:f
disk                     /pci@1f,0/pci@1,1/ide@d/disk@0,0
disk3                    /pci@1f,0/pci@1,1/ide@d/disk@3,0
disk2                    /pci@1f,0/pci@1,1/ide@d/disk@2,0
disk1                    /pci@1f,0/pci@1,1/ide@d/disk@1,0
disk0                    /pci@1f,0/pci@1,1/ide@d/disk@0,0
ide                      /pci@1f,0/pci@1,1/ide@d
floppy                   /pci@1f,0/pci@1,1/isa@7/dma/floppy
ttyb                     /pci@1f,0/pci@1,1/isa@7/serial@0,2e8
ttya                     /pci@1f,0/pci@1,1/isa@7/serial@0,3f8

# 2  
Old 10-11-2013
What is happening when you use boot disk?
# 3  
Old 10-11-2013
When I use
Code:
boot disk

It just says unable to open boot device.
# 4  
Old 10-11-2013
can you boot from cdrom?
# 5  
Old 10-11-2013
no.. there is no CD Rom drive..
# 6  
Old 10-11-2013
Humm, your show-disks command is showing a CDROM
Code:
ok show-disks
a) /pci@1f,0/pci@1,1/ide@d/cdrom
b) /pci@1f,0/pci@1,1/ide@d/disk

Did you remove the CDROM afterwords?
# 7  
Old 10-11-2013
.. I am not sure why it is showing a CD Rom device.
But there is no cd rom device.

---------- Post updated at 05:46 PM ---------- Previous update was at 12:25 PM ----------

If I am able to attach a usb cdrom and boot from cdrom, how can I repair the disk?
I do not want to lose the data.. any help? thanks...
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. AIX

Is my XIV device open?

Hi there, I am trying to determine if a specific XIV LUN on AIX is in OPEN or CLOSED state. I would like tthe same info as I can get from pcmpath command on v7000 LUN-s. I would need this info to find out if I can safely delete a LUN or not. I tried fuser command, but no luck. It did not... (6 Replies)
Discussion started by: trifo75
6 Replies

2. HP-UX

Failed to open tape device /dev/rmt/0mn:Device busy (errno = 16)

Hi, Unable to make tape backup, please help. /opt/ignite/bin/make_tape_recovery -a /dev/rmt/?mn -I -v -m tar -x inc_entire=vg00 * Creating local directories for configuration files and archive. ======= 04/25/16 16:28:08 IST Started /opt/ignite/bin/make_tape_recovery. (Mon... (4 Replies)
Discussion started by: anuragr
4 Replies

3. Solaris

Can't open boot device

I installed a new hard drive completely blank. sun blade 150 openboot 4.10.6 message: Boot device: disk:a File and args: Bad magic number in disk label Can't open label package Evaluating: Can't open boot device (15 Replies)
Discussion started by: janiper
15 Replies

4. Solaris

How to know what is the boot device?

Hello, I am wondering which commend /file to check to find out what is the boot device? regards Ahmed Egypt (1 Reply)
Discussion started by: ahmedamer12
1 Replies

5. Solaris

"Can't open boot device" error !!

I've a Sun V440 machine, and it's running solaris 10 .. for some reason i need to install a fresh copy of solaris 10. for that i've prepared solaris 10 dvd but surprisingly i found there is no any dvd rom on this machine, so i've took a dvd rom from a V240 machine and inserted on V440. after... (3 Replies)
Discussion started by: Anti_Evil
3 Replies

6. Boot Loaders

Reboot and Select Proper Boot device or insert Boot media in select Boot device and press a key

Hello, I have kubuntu on my laptop and now I decided to switch to Windows 7. I made the bios settings properly (first choice is boot from cd\vd) but I see the error " reboot and select proper Boot device or insert Boot media in select Boot device and press a key " I have tried CD and... (0 Replies)
Discussion started by: rpf
0 Replies

7. Solaris

question about opb boot device

hi all: I have a sun blade-1000 for labs only, with 73G hd loaded, which boot block installed on slice 0. I'm confused by setting "boot-device" value in obp, which my question as follow: in ok mode, I got device alias like this: disk0: /pci@8,600000/SUNW,qlc@4/fp@0,0/disk@2,0 as I know the... (4 Replies)
Discussion started by: netshu
4 Replies

8. Solaris

Can't open boot device

I have a real emergency. I have a Sun Fire V240 UltraSparc server and am connected via the Serial Mgmnt Port with a Laptop. I have been building an Oracle database on it for the past couple months, not getting very far along with it , when suddenly, the system had a fatal crash. I've lost the... (2 Replies)
Discussion started by: mayewil
2 Replies

9. Solaris

ERROR: Can't open boot-device

Hi i need help pls ... Server type sun fire 3800 I need to install solaris 9 . When i boot the system i recieve the following : System Controller 'sunfire3800': Type 0 for Platform Shell Type 1 for domain A console Type 2 for domain B console Type 3 for... (5 Replies)
Discussion started by: tt155
5 Replies

10. Solaris

cannot find boot device and won't boot off cdrom

I'm running solaris 2.5.1. My main development server is DEAD, i can't even boot off the cdrom, it powers up, acts like it is starting the boot process but then says cannot find boot device. I've done the search here on this site and saw the other posts, but at the ok prompt it won't even let me... (3 Replies)
Discussion started by: kymberm
3 Replies
Login or Register to Ask a Question

Featured Tech Videos