Visit Our UNIX and Linux User Community


Stty: : No such device or address


 
Thread Tools Search this Thread
Top Forums Shell Programming and Scripting Stty: : No such device or address
# 8  
Old 08-07-2013
Try using set big_cnt=$(sed -n '4p' sql_output.txt)

You could do yourself a bigger favour by not using CSH Smilie
# 9  
Old 08-07-2013
whether i should use csh or not, but 1 thing is sure that by removing ` sign from sqlplus, it has stopped writting in the output file.

Code:
sqlplus -s $ORACLE_USER/$ORACLE_PASS@$ORACLE_SID   << EOF > sql_output.txt
                select count(*) from bravo_statistics
                where trunc(time_stamp)=trunc(sysdate)
                and description in ('BEGIN NIT','END MR');
EOF

and at last it is giving
Quote:
Variable syntax
error
# 10  
Old 08-07-2013
This is likely a result of the C-Shell's ad-hoc parser which handles quotes abysmally badly.
# 11  
Old 08-07-2013
if i get a perfect way to handle ` sign in my script then i am all set, please suggest.
# 12  
Old 08-07-2013
There is nothing wrong with the SQLPlus. The backquotes are not required. The error comes from elsewhere.

Also the syntax of your if statement is Bourne shell... not C-Shell.

Code:
if ( $big_cnt == 0 ) then

# 13  
Old 08-07-2013
"
Quote:
Also the syntax of your if statement is Bourne shell... not C-Shell."
why it is not generating any error while running manually instead of crontab?
# 14  
Old 08-07-2013
If you're running this through cron you need to ensure that your environment is properly configured (usually by sourcing your ~/.profile and setting up your Oracle environment, etc.).

I've already given you my suggestion: Stop using the C-Shell.

Previous Thread | Next Thread
Test Your Knowledge in Computers #448
Difficulty: Medium
Quirky Linux and Puppy Linux were both created by Barry Kauler.
True or False?

7 More Discussions You Might Find Interesting

1. HP-UX

Failed to open tape device /dev/rmt/0mn:Device busy (errno = 16)

Hi, Unable to make tape backup, please help. /opt/ignite/bin/make_tape_recovery -a /dev/rmt/?mn -I -v -m tar -x inc_entire=vg00 * Creating local directories for configuration files and archive. ======= 04/25/16 16:28:08 IST Started /opt/ignite/bin/make_tape_recovery. (Mon... (4 Replies)
Discussion started by: anuragr
4 Replies

2. Debian

Problem configuring IP address on remote device

I need to add a printer with Ethernet to my local network. The default IP address in the printer is 0.0.0.0 and I need to change it to a 192.168.0.x address. I have previously temporarily changed the IP address of a computer (with ifconfig) to an address similar to the new device and changed the... (8 Replies)
Discussion started by: snorkack59
8 Replies

3. Red Hat

Unable To Activate Ethernet Network Device in RHEL 5.5 - e100 device eth0 does not seem to be presen

Hi All, Could anyone please help to resolve the below problem. I installed RHEL5.5 in my desktop.But when i try to activate the ethernet connection then it gives me the error. I spent 2 days for the above and go through with several suggestion found by googling. But no luck. ... (0 Replies)
Discussion started by: Tanmoy
0 Replies

4. Solaris

sar : insufficient address space to load xxxx device records

Hello, i am using Solaris 10, The sar running in my system might be corrupted, but not sure why as there has been no updates to it ( to the best of my knowledge) and it was working fine until few days back. If i try to get sar reports using sar -o <filename> 60 180 there is no error but the... (2 Replies)
Discussion started by: nimi20
2 Replies

5. UNIX for Dummies Questions & Answers

Device Probe freezes after detecting Ethernet address while installing FreeeBSD 7.0

I'm trying to install FreeBSD 7.0 from CDs I made a few months ago on a brand new system with parts I just got in from NewEgg. I select the default option from the Boot Loader and it goes into the device probe. Several devices are recognized, but then it freezes at: mskc0: <Marvell Yukon... (2 Replies)
Discussion started by: ideogon
2 Replies

6. UNIX for Dummies Questions & Answers

"/dev/rmt/0: No such device or address" when using mt command

/dev/rmt/0: No such device or address I get this when I do a "mt -f /dev/rmt/0 rewind" This is on a Solaris 7 system. I tried devfsadm -c tape and drvconfig ; tape and both didn't work. Help please....... :confused: (4 Replies)
Discussion started by: shorty
4 Replies

7. Shell Programming and Scripting

stty: : No such device or address

I encoutered the error "stty: : No such device or address" in the korn shell script log. I added STTY EARSE ^H in profile. why iam i getting that error in Korn shell Thanks nandinisagar (6 Replies)
Discussion started by: nandinisagar
6 Replies

Featured Tech Videos