Visit Our UNIX and Linux User Community


Locale setting


 
Thread Tools Search this Thread
Top Forums Programming Locale setting
# 1  
Old 07-05-2002
Locale setting

Hi,

In the sample program, I am trying to print a Japanese string.
The code is as follows:

main()
{
setlocale(LC_ALL,"");
printf("String is %S\n", L"JAP");
// Note "JAP" is a valid japanese string
}

If locale is C, the string gets printed, but if it a valid japanese locale, it does not print anything.


Can anyone figure out the reason?

Thanks.

Regards,

Dippan.
# 2  
Old 07-10-2002
Do you have the proper locales and fonts installed on your system?

Previous Thread | Next Thread
Test Your Knowledge in Computers #762
Difficulty: Medium
The L2 cache, and higher-level caches, are never shared between the CPU cores.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Perl error : perl: warning: Setting locale failed.

This's my problem perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LC_ALL = "en_US.UTF-8", LC__FASTMSG = "true", LC_MESSAGES = "", LC_CTYPE = "en_US.UTF-8", LC_TYPE = "en_US.UTF-8", LANG = "EN_US"... (1 Reply)
Discussion started by: bobochacha29
1 Replies

2. Solaris

Locale changes?

I am upgrading a machine to Solaris 10 and noticed a change that would cause a problem for us. We have always used en_US.ISO8859-1 and selected that when setting up the new system. This is the format on our old system $ date Fri Sep 21 10:35:51 PDT 2012 And this is what I got on our old... (1 Reply)
Discussion started by: Bryan.Eidson
1 Replies

3. Solaris

setting locale en_US.UTF-8

hi, I am using SOLARIS sparc 64 bit, during installation of Oracle i receive an error required OS locale en_US.UTF-8 does not exist on the installation computer. To avoid this issue, please ensure that the locale en_US.UTF-8 exists on the installation computer prior to installing Oracle. when... (4 Replies)
Discussion started by: zeeshan047
4 Replies

4. Solaris

Locale woes

Greetings Forumers! I've been fighting a locale problem on a v490 running Solaris 10 u4 (8/07). When I login to the system, I get several "locale" error messages: user1's password: Last login: Wed May 26 2010 09:14:13 -0400 from system1 You have mail. couldn't set locale correctly couldn't... (0 Replies)
Discussion started by: bluescreen
0 Replies

5. Solaris

Locale installation..

Hi All, I need to install a swedish locale on a solaris machine(ver. 10).I have the package downloaded.Can anyone please guide me through the steps and things i need to keep in mind when doing the same? (7 Replies)
Discussion started by: sankasu
7 Replies

6. Solaris

Installation of locale..

Hi All, i am pretty new to sun solaris env.I need to install a french locale onto my machine.Could you please guide me through the steps. (1 Reply)
Discussion started by: sankasu
1 Replies

7. Red Hat

Setting a locale in Redhat ES 4

Hi, I am writing a shell script which would ask user to select a locale and should set the locale for them. In the script I am doing export LANG=<user selected locale> and i do 'locale' it would show me the changed locale. But, when I come out of the program and do 'locale' it... (3 Replies)
Discussion started by: eamani_sun
3 Replies

8. Solaris

Sol 10 on SUN V490: Setting LOCALE

Hi all, We've upgraded/migrated our production server from Sol 9 on a Sun V480 to Sol 10 on a V490 server. How do I set/change the following values on Solaris 10: Solaris 9: $> locale LANG= LC_CTYPE=en_US.ISO8859-1 LC_NUMERIC=en_US.ISO8859-1 LC_TIME=en_US.ISO8859-1... (2 Replies)
Discussion started by: dewets
2 Replies

9. UNIX for Dummies Questions & Answers

Using locale

:confused: Can anyone tell me how to test that locale is working properly in commands like awk, basename, bg, cd, cmp, col, command, csplit, cut, echo, egrep For ex. suppose I have changed locale using LC_ALL=german_germany.8859 export LC_ALL now i want to test(see) it's effect on... (3 Replies)
Discussion started by: alodha
3 Replies

10. UNIX for Dummies Questions & Answers

Solaris 8 locale setting

Hello does anybody know how to change the LC_TIME locale on solaris 8 to dd/mm/YYYY currently it is set to. #locale -ck LC_TIME d_fmt="%m/%d/%y" Thanks (1 Reply)
Discussion started by: thangorn
1 Replies

Featured Tech Videos