opensolaris man page for bp_copyin

Query: bp_copyin

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

bp_copyin(9F)						   Kernel Functions for Drivers 					     bp_copyin(9F)

NAME
bp_copyin - copy from a buf(9S) into a driver buffer
SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> int bp_copyin(struct buf *bp, void *driverbuf, offset_t offset, size_t size);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to the buffer header structure to copy from. driverbuf Driver buffer to copy to. offset Offset into bp where to start copying. size Size of copy.
DESCRIPTION
The bp_copyin() function copies size bytes into the memory associated with bp to the destination driver buffer driverbuf. The offset only applies to bp.
RETURN VALUES
Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if bp references invalid pages.
CONTEXT
The bp_copyin() function can be called from user or kernel context only.
SEE ALSO
bp_copyout(9F), bp_mapin(9F), bp_mapout(9F), ddi_copyout(9F), buf(9S) SunOS 5.11 16 Oct 2007 bp_copyin(9F)
Related Man Pages
bioinit(9f) - opensolaris
bp_mapin(9f) - opensolaris
ddi_copyin(9f) - sunos
ddi_copyin(9f) - linux
ddi_copyout(9f) - linux
Similar Topics in the Unix Linux Community
CP to copy file is &quot;stuck&quot;
SL?s Architecture for CEP Visualization
Can not copy file not enough space on LV
copy dirctroy but not copy certain file
More &gt; 1 TB single file cant copy