Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

bp_mapin(9f) [opensolaris man page]

bp_mapin(9F)						   Kernel Functions for Drivers 					      bp_mapin(9F)

NAME
bp_mapin - allocate virtual address space SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void bp_mapin(struct buf *bp); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
bp Pointer to the buffer header structure. DESCRIPTION
bp_mapin() is used to map virtual address space to a page list maintained by the buffer header during a paged- I/O request. bp_mapin() allocates system virtual address space, maps that space to the page list, and returns the starting address of the space in the bp->b_un.b_addr field of the buf(9S) structure. Virtual address space is then deallocated using the bp_mapout(9F) function. If a null page list is encountered, bp_mapin() returns without allocating space and no mapping is performed. CONTEXT
bp_mapin() can be called from user and kernel contexts. SEE ALSO
bp_mapout(9F), buf(9S) Writing Device Drivers SunOS 5.11 13 Sep 1992 bp_mapin(9F)

Check Out this Related Man Page

bp_copyout(9F)						   Kernel Functions for Drivers 					    bp_copyout(9F)

NAME
bp_copyout - copy from a driver buffer into a buf(9S) SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> int bp_copyout(void *driverbuf, struct buf *bp, offset_t offset, size_t size); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
bp Pointer to the buffer header structure to copy to. driverbuf Driver buffer to copy from. offset Offset into bp where to start copying. size Size of copy. DESCRIPTION
The bp_copyout() function copies size bytes starting from the driver buffer driverbuf to offset bytes into the memory associated with bp. The offset only applies to bp. RETURN VALUES
Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if bp references invalid pages. CONTEXT
The bp_copyout() function can be called from user or kernel context only. SEE ALSO
bp_copyin(9F), bp_mapin(9F), bp_mapout(9F), ddi_copyout(9F), buf(9S) SunOS 5.11 16 Oct 2007 bp_copyout(9F)
Man Page

7 More Discussions You Might Find Interesting

1. AIX

Removing page space

I having problem removing a page space.... 1. When I list the page spaces available in the system, I am getting the following messages 0516-310 : Unable to find attribute state in the Device Configuration Database. Execute synclvodm to attempt to correct the database.... (4 Replies)
Discussion started by: srnkumar
4 Replies

2. UNIX for Dummies Questions & Answers

How to assign virtual address?.

Hello,I am new to unix,i want to know how to assign virtual ip address to a system that is in my personal network? (1 Reply)
Discussion started by: veeru_jarugula
1 Replies

3. Shell Programming and Scripting

Storing string with space (urgent)

hi i have a file content like my_file: 1US8738297897918000 000 000 i used while IFS= read line do echo "$line" | grep '^\ then last=`echo "$line" | cut -c 3-20` echo "$last" fi done < $my_file but it is writing blank spaces into the o/p fie (1 Reply)
Discussion started by: Satyak
1 Replies

4. Programming

Find Virtual address space size for process

Hi, I am looking to work on unix systems which include (hp-ux, ibm aix, solaris and linux). I want to get the total virtual address space of a process, the used virtual memory i am able to get without any problem. I have tried using getrlimit and getrlimit64, but that gives only ... (4 Replies)
Discussion started by: uiqbal
4 Replies

5. AIX

Virtual IP address in HACMP

I am new to HACMP V5.4 in AIX5.3.Please let me know how to get the virtual IP address configured for a HACMP cluster. Is this the correct way to identify it? If i give ifconfig -a the first ip address displayed is the real address of the host.So the other one can be VIP. Thanks in Advance (3 Replies)
Discussion started by: guru13
3 Replies

6. Shell Programming and Scripting

Replacing space with T only in the 1st line of the file

Hi Masters , I have a file whose header is like HDRCZECM8CZCM000000881 SVR00120100401160828+020020100401160828+0200CZK There is a space between 1 and S ,my req is to chng the space to T I tried echo `head -1 CDCZECM8CZCM000000881` | sed 's/ /T/' it works ,but how can I modify in... (5 Replies)
Discussion started by: Pratik4891
5 Replies

7. Programming

PC RAM and process address space

Suppose I have 3 gb of ram and 250 gb hard disk in my pc. Now I wrote a simple C program having only one statement malloc() to allocate 4 gb of memory as 32 bit os can address 4gb address space then will the malloc succeed? If yes then how it will get extra 1 gb of memory? Does the process gets... (3 Replies)
Discussion started by: rupeshkp728
3 Replies