Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

bp_copyin(9f) [opensolaris man page]

bp_copyin(9F)						   Kernel Functions for Drivers 					     bp_copyin(9F)

NAME
bp_copyin - copy from a buf(9S) into a driver buffer SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> int bp_copyin(struct buf *bp, void *driverbuf, offset_t offset, size_t size); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
bp Pointer to the buffer header structure to copy from. driverbuf Driver buffer to copy to. offset Offset into bp where to start copying. size Size of copy. DESCRIPTION
The bp_copyin() function copies size bytes into the memory associated with bp to the destination driver buffer driverbuf. The offset only applies to bp. RETURN VALUES
Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if bp references invalid pages. CONTEXT
The bp_copyin() function can be called from user or kernel context only. SEE ALSO
bp_copyout(9F), bp_mapin(9F), bp_mapout(9F), ddi_copyout(9F), buf(9S) SunOS 5.11 16 Oct 2007 bp_copyin(9F)

Check Out this Related Man Page

bp_mapout(9F)						   Kernel Functions for Drivers 					     bp_mapout(9F)

NAME
bp_mapout - deallocate virtual address space SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void bp_mapout(struct buf *bp); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
bp Pointer to the buffer header structure. DESCRIPTION
bp_mapout() deallocates system virtual address space allocated by a previous call to bp_mapin(9F).bp_mapout() should only be called on buffers which have been allocated and are owned by the device driver. It must not be called on buffers passed to the driver through the strategy(9E) entry point (for example a filesystem). Because bp_mapin(9F) does not keep a reference count, bp_mapout() will wipe out any kernel mapping that a layer above the device driver might rely on. CONTEXT
bp_mapout() can be called from user context only. SEE ALSO
strategy(9E), bp_mapin(9F), buf(9S) Writing Device Drivers SunOS 5.11 15 Nov 1996 bp_mapout(9F)
Man Page

3 More Discussions You Might Find Interesting

1. AIX

CP to copy file is "stuck"

For some reason, when I attempt to copy a file, using cp, from one location to another the cmd is stuck (or taking an unusually long time). Usually copying a 1 GB file will take 3-4 mins, so far it's at 11 mins and yesterday was stuck for several hours. Is there a way I can see WHY or WHAT is... (5 Replies)
Discussion started by: mcubitt
5 Replies

2. AIX

Can not copy file not enough space on LV

Hello, Please can someone help. I have created a lv called lv00 in datavg it has 8 PP's in use and each PP is 256MB I have 537 Free PP's Every time I copy my mksysb file to this new lv it gives me an error: 0653-447 Requested a write of ..... but wrote only ... errpt tells me... (2 Replies)
Discussion started by: pobman
2 Replies

3. Solaris

More > 1 TB single file cant copy

good evening, hi, I have problem for copy file, size more > 1 TB, just only for single file. error said, capacity not enough, even my storage I set to 4 TB, file always reject during finish copy. but, if I copy with multiple file/separate file, total calculation file is 2 TB, always success.... (10 Replies)
Discussion started by: katumping
10 Replies