opensolaris man page for bp_mapout

Query: bp_mapout

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

bp_mapout(9F)						   Kernel Functions for Drivers 					     bp_mapout(9F)

NAME
bp_mapout - deallocate virtual address space
SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void bp_mapout(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to the buffer header structure.
DESCRIPTION
bp_mapout() deallocates system virtual address space allocated by a previous call to bp_mapin(9F).bp_mapout() should only be called on buffers which have been allocated and are owned by the device driver. It must not be called on buffers passed to the driver through the strategy(9E) entry point (for example a filesystem). Because bp_mapin(9F) does not keep a reference count, bp_mapout() will wipe out any kernel mapping that a layer above the device driver might rely on.
CONTEXT
bp_mapout() can be called from user context only.
SEE ALSO
strategy(9E), bp_mapin(9F), buf(9S) Writing Device Drivers SunOS 5.11 15 Nov 1996 bp_mapout(9F)
Related Man Pages
bp_mapin(9f) - opensolaris
bioclone(9f) - sunos
bp_mapout(9f) - sunos
bp_mapin(9f) - sunos
getrbuf(9f) - minix
Similar Topics in the Unix Linux Community
How to learn UNIX
Change directory for core file
Grep the 'not running' jobs and will send the update in mail with its name(job)
%memused is high
Shopt -s histappend