Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

strlog(9f) [sunos man page]

strlog(9F)						   Kernel Functions for Drivers 						strlog(9F)

NAME
strlog - submit messages to the log driver SYNOPSIS
#include <sys/stream.h> #include <sys/strlog.h> #include <sys/log.h> int strlog(short mid, short sid, char level, unsigned short flags, char *fmt, ...);); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
mid Identification number of the module or driver submitting the message (in the case of a module, its mi_idnum value from mod- ule_info(9S)). sid Identification number for a particular minor device. level Tracing level for selective screening of low priority messages. Larger values imply less important information. flags Valid flag values are: SL_ERROR Message is for error logger. SL_TRACE Message is for trace. SL_NOTIFY Mail copy of message to system administrator. SL_CONSOLE Log message to console. SL_FATAL Error is fatal. SL_WARN Error is a warning. SL_NOTE Error is a notice. fmt printf(3C) style format string. %e, %g, and %G formats are not allowed but %s is supported. DESCRIPTION
strlog() expands the printf(3C) style format string passed to it, that is, the conversion specifiers are replaced by the actual argument values in the format string. The 32-bit representations of the arguments (up to NLORGARGS) follow the string starting at the next 32-bit boundary following the string. Note that the 64-bit argument will be truncated to 32-bits here but will be fully represented in the string. The messages can be retrieved with the getmsg(2) system call. The flags argument specifies the type of the message and where it is to be sent. strace(1M) receives messages from the log driver and sends them to the standard output. strerr(1M) receives error messages from the log driver and appends them to a file called /var/adm/streams/error.mm-dd, where mm-dd identifies the date of the error message. RETURN VALUES
strlog() returns 0 if it fails to submit the message to the log(7D) driver and 1 otherwise. CONTEXT
strlog() can be called from user or interrupt context. FILES
/var/adm/streams/error.mm-dd Error messages dated mm-dd appended by strerr(1M) from the log driver SEE ALSO
strace(1M), strerr(1M), getmsg(2), log(7D), module_info(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 strlog(9F)

Check Out this Related Man Page

strerr(8)						      System Manager's Manual							 strerr(8)

NAME
strerr - Receives error messages from the STREAMS log driver SYNOPSIS
/usr/sbin/strerr [-a sys_admin_mail_name] [-d logdir] PARAMETERS
Specifies the mail name of the user to receive the message via mail. This is the system administrator by default. Specifies the directory to contain the error log file. This is /var/adm/streams by default. DESCRIPTION
The strerr daemon receives error messages from the STREAMS log driver (strlog) for addition to the STREAMS error log files (error.mm.dd) in the STREAMS error logger directory (/var/adm/streams by default). When first called, the strerr daemon creates the log file error.mm.dd. This is a daily log file, where mm indicates the month and dd indicates the day of the logged messages. The strerr daemon then appends each error message that it subsequently receives from the STREAMS log driver to the log file. STREAMS error log messages have the following format: seq_num std_time ticks_time flags mod_ID sub_ID msg_text where: The error sequence number. The time the message was sent, in the format hh:mm:ss. The time the message was sent, measured in machine ticks since the last boot. Can be any of the following indicators: Indicates that the message has also been saved in the process's trace log. Indi- cates that the message signaled a fatal error. Indicates that the message is to be sent to the system administrator or specified user via mail. The module identification number of the trace message source. The subidentification number of the trace message source. The trace message text. The strerr daemon will run continuously until terminated by the user. FILES
The error log file or files on which strerr operates. NOTES
Only one strerr process can open the STREAMS log driver at a time. This restriction is intended to maximize performance. The STREAMS error logging mechanism works best when it is not overused. The strerr daemon can degrade STREAMS performance by affecting the response, throughput, and other behaviors of the drivers and modules that invoke it. The daemon will also fail to capture messages if drivers and modules generate messages at a higher rate than its optimum read rate. Missing sequence numbers among the messages in a log file indicate that messages have been lost. RELATED INFORMATION
Interfaces: strlog(7). delim off strerr(8)
Man Page