Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

module_info(9s) [sunos man page]

module_info(9S) 					    Data Structures for Drivers 					   module_info(9S)

NAME
module_info - STREAMS driver identification and limit value structure SYNOPSIS
#include <sys/stream.h> INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). DESCRIPTION
When a module or driver is declared, several identification and limit values can be set. These values are stored in the module_info struc- ture. The module_info structure is intended to be read-only. However, the flow control limits (mi_hiwat and mi_lowat) and the packet size limits (mi_minpsz and mi_maxpsz) are copied to the QUEUE structure, where they can be modified. For a driver, mi_idname must match the name of the driver binary file. For a module, mi_idname must match the fname field of the fmodsw structure. See fmodsw(9S) for details. STRUCTURE MEMBERS
ushort_t mi_idnum; /* module ID number */ char *mi_idname; /* module name */ ssize_t mi_minpsz; /* minimum packet size */ ssize_t mi_maxpsz; /* maximum packet size */ size_t mi_hiwat; /* high water mark */ size_t mi_lowat; /* low water mark */ The constant FMNAMESZ, limiting the length of a module's name, is set to eight in this release. SEE ALSO
fmodsw(9S), queue(9S) STREAMS Programming Guide SunOS 5.10 26 Nov 2002 module_info(9S)

Check Out this Related Man Page

fmodsw(9S)						    Data Structures for Drivers 						fmodsw(9S)

NAME
fmodsw - STREAMS module declaration structure SYNOPSIS
#include <sys/stream.h> #include <sys/conf.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
The fmodsw structure contains information for STREAMS modules. All STREAMS modules must define a fmodsw structure. f_name must match mi_idname in the module_info structure. See module_info(9S). f_name should also match the module binary name. (See WARN- INGS.) All modules must set the f_flag to D_MP to indicate that they safely allow multiple threads of execution. See mt-streams(9F) for additional flags. STRUCTURE MEMBERS
char f_name[FMNAMESZ + 1]; /* module name */ struct streamtab *f_str; /* streams information */ int f_flag; /* flags */ SEE ALSO
mt-streams(9F), modlstrmod(9S), module_info(9S) STREAMS Programming Guide WARNINGS
If f_name does not match the module binary name, unexpected failures can occur. SunOS 5.11 14 Nov 2002 fmodsw(9S)
Man Page

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

grep -E drives me crazy

Hi there, I'm new here. I registered my self today with this board because I hope to get some help before I'll become a slavering maniac. I'm really desperate, since I'm trying for hours(really!) to let grep search a pattern that goes about 2 lines. The pattern is as follows: Handle... (6 Replies)
Discussion started by: darkelf
6 Replies

2. Shell Programming and Scripting

Perl Getopt::Long question - stopping multiple args

Hi there, I have an example basic script (below) and ive been trying to figure out how to stop multiple arguments to my options occuring. for example using the example script below I can issue two arguments for, say the --surname option and it will not barf at me (although thats what i want it to... (11 Replies)
Discussion started by: rethink
11 Replies

3. Infrastructure Monitoring

Nagios 3.2.2 on RHEL 5

Hi, Installed it and all seems okay except when I try to actually use it. :-( Visiting my nagios url, it says Logs and conf's follow: nagios.log is: # cat /usr/local/nagios/var/nagios.log | tail -5 Successfully shutdown... (PID=3613) Nagios 3.2.2 starting... (PID=4645)... (7 Replies)
Discussion started by: smcracraft
7 Replies

4. AIX

AIX STREAMS driver question

Hi all, I have a AIX kernel STREAMS question need your help, I need to implement a firewall on AIX and get packet raw data then decide pass or drop it, I've seen similiar firewall code on HP-UX, on HP-UX, you have to implement a "dlpi STREAMS driver", and specify it as a "dlpi" driver in... (1 Reply)
Discussion started by: rocktilldie
1 Replies

5. Shell Programming and Scripting

configure options ised while compiling apache

How can I know which all options were used while compiling a apache binary. # /usr/local/apache/bin/httpd -v Server version: Apache/2.2.17 (Unix) Server built: Feb X 2XXX XX:29:08 Cpanel::Easy::Apache v3.2.0 rev5291 (1 Reply)
Discussion started by: anil510
1 Replies

6. Shell Programming and Scripting

file seach from pulseaudio module list

Hi Guys,I admit my knowledge in this area is awful, :( I'm trying to get the alsa card number from within the text returned by running pactl list cards Alsa card numbers from running aplay -l and above do not match. I'm attempting to get a match on the PA card list with the type of sound... (2 Replies)
Discussion started by: g8jvm
2 Replies

7. Web Development

Httpd not starting

I compiled apache 2.2.15 from source and installed it. When I try to start it, its not coming up. # ./httpd -k start # echo $? 1 # ps -ef | grep httpd | grep -v grep # # ./httpd -v Server version: Apache/2.2.15 (Unix) Server built: Dec 13 2013 04:31:41When I run it in gdb I am... (4 Replies)
Discussion started by: chacko193
4 Replies

8. AIX

Mix LDAP and LOCAL user on AIX

Hello, I'm currently trying to mix local and LDAP users on an AIX 7.1. I've triied many things. My LDAP Server in on a CentOS - OpenLDAP (which works fine with linux). I'm currently stuck on AIX at how to declare LDAP AND Local users. Here's what i did : /usr/sbin/mksecldap -c -h 'ldap03'... (15 Replies)
Discussion started by: AIX_user_324891
15 Replies

9. Shell Programming and Scripting

View all jar files contents in one go ?

I can view a jar file contents using the below command: $ jar -tvf ./checker-compat-qual-2.0.0.jar 0 Mon May 02 18:28:46 IST 2016 META-INF/ 184 Mon May 02 18:28:44 IST 2016 META-INF/MANIFEST.MF 0 Mon May 02 17:20:16 IST 2016 afu/ 0 Mon May 02 17:20:16 IST 2016 afu/org/ ... (5 Replies)
Discussion started by: mohtashims
5 Replies