opensolaris man page for bp_copyout

Query: bp_copyout

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

bp_copyout(9F)						   Kernel Functions for Drivers 					    bp_copyout(9F)

NAME
bp_copyout - copy from a driver buffer into a buf(9S)
SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> int bp_copyout(void *driverbuf, struct buf *bp, offset_t offset, size_t size);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to the buffer header structure to copy to. driverbuf Driver buffer to copy from. offset Offset into bp where to start copying. size Size of copy.
DESCRIPTION
The bp_copyout() function copies size bytes starting from the driver buffer driverbuf to offset bytes into the memory associated with bp. The offset only applies to bp.
RETURN VALUES
Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if bp references invalid pages.
CONTEXT
The bp_copyout() function can be called from user or kernel context only.
SEE ALSO
bp_copyin(9F), bp_mapin(9F), bp_mapout(9F), ddi_copyout(9F), buf(9S) SunOS 5.11 16 Oct 2007 bp_copyout(9F)
Related Man Pages
bp_mapout(9f) - sunos
bp_copyout(9f) - opensolaris
mcopymsg(9f) - opensolaris
ddi_copyin(9f) - linux
ddi_copyout(9f) - linux
Similar Topics in the Unix Linux Community
SL?s Architecture for CEP Visualization
Can not copy file not enough space on LV
copy dirctroy but not copy certain file
More &gt; 1 TB single file cant copy