mms(5) Standards, Environments, and Macros mms(5)
mms - MMS service overview
MMS is a distributed removable media management system. It is based on the standard, IEEE
1244, Media Management System (MMS).
The current implementation of MMS manages tapes and cartridges in a Sun StorageTek ACSLS
tape library and emulated tapes on a file system. MMS is capable of sharing drives among
multiple hosts. An important feature of MMS is that it provides a uniform and consistent
tape interface to its client applications.
MMS consists of a media manager (MM) which manages the entire MMS system. Information
about the system is maintained by MM in a database.
Every library managed by MMS has an active library manager (LM). An LM provides library
access and mounting service to MMS.
A drive managed by MMS has a drive manager (DM) on each host that has access to the drive.
A DM provides device specific operations. A DM also provides label processing. The current
implementation supports only ANSI labels.
MMS client applications request MM to mount and unmount cartridges and process them after
they are mounted. Applications use the Media Management Protocol (MMP) to make requests. A
library of client application functions is available.
The Solaris implementation of the MMS uses the mmsinit(1M) command to configure and start
the MMS service and the mmsadm(1M) command to list and set parameters required by the ser-
The MMS service instances, as reported by svcs(1), are:
Media Manager PostgreSQL database
The MMS service RBAC (see rbac(5)) authorizations are:
The following are the MMS service configuration data accessible through the service man-
agement facility (see smf(5)):
Host is media manager or watcher only. Valid values are server or client.
Host name where the media manager is running.
Port the media manager is using.
Media Manager is using SSL. Valid values are true or false. Note the Media Manager
needs an SSL RSA certificate and Diffie-Hellman parameters must be 'true'.
Media Manager-only value, determines whether two-way authentication is enabled, which
requires all Media Manager clients to have SSL RSA certificate. Valid values are are
true for two-way authentication and false for one-way authentication.
Name of file that contains the SSL RSA certificate, private key, and RSA certificate
Name of file for the private key password phrase if the RSA certificate is encrypted.
Media Manager-only value, name of file that stores the Diffie-Hellman parameters.
Name of optional CRL file.
Optional cipher change from EDH-RSA-DES-CBC3-SHA.
Optional client only, name of file that stores the media manager certificate. The cer-
tificate is checked against the certificate returned by SSL_get_peer_certificate()
The following are the MMS Database fault management resource identifier (FMRI) configura-
Directory where the PostgreSQL binaries are located. The directory is specific to the
version of PostgreSQL qualified for use by the MMS software.
Directory where the PostgreSQL database is located. The default location is a ver-
sion-specific subdirectory of /var/mms/db.
The following are the MMS Media Manager FMRI configuration data:
For future use. Set to localhost.
Port number to use for PostgreSQL login. The default value is 7656.
PostgreSQL user name. The default user name is postgres.
Name of PostgreSQL database to which to connect. The default value is mms.
Optional. The Media Manager trace level before connecting to the PostgreSQL database.
Number of times to wait for the database to accept a Media Manager connection.
Number of seconds to wait between reconnect tries.
The following are the MMS Watcher FMRI configuration data:
Path to ACSLS SSI daemon.
Path to ACSLS API library.
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Interface Stability |Committed |
svcs(1), mmsadm(1M), mmsclient(1M), mmsexplorer(1M), mmsinit(1M), mmsclient_script(4),
attributes(5), rbac(5), smf(5)
SunOS 5.11 11 Nov 2008 mms(5)