MDNSD(8) BSD System Manager's Manual MDNSD(8)
mdnsd -- Multicast and Unicast DNS daemon
mdnsd (also known as mDNSResponder on some systems) is a daemon invoked at boot time to
implement Multicast DNS and DNS Service Discovery. On Mac OS X 10.6 (Snow Leopard), mdnsd
is also the system-wide Unicast DNS Resolver.
mdnsd listens on UDP port 5353 for Multicast DNS Query packets. When it receives a query
for which it knows an answer, mdnsd issues the appropriate Multicast DNS Reply packet.
mdnsd also performs Unicast and Multicast DNS Queries on behalf of client processes, and
maintains a cache of the replies.
mdnsd has no user-specifiable command-line argument, and users should not run mdnsd manu-
There are several methods with which to examine mdnsd's internal state for debugging and
diagnostic purposes. The syslogd(8) logging levels map as follows:
Error - Error messages
Warning - Client-initiated operations
Notice - Sleep proxy operations
Info - Informational messages
By default, only log level Error is logged.
A SIGUSR1 signal toggles additional logging, with Warning and Notice enabled by default:
# pkill -USR1 mdnsd
A SIGUSR2 signal toggles packet logging:
# pkill -USR2 mdnsd
A SIGINFO signal will dump a snapshot summary of the internal state to /var/log/system.log:
# pkill -INFO mdnsd
dns-sd(1), pkill(1), syslogd(8)
For information on Multicast DNS, see http://www.multicastdns.org/
For information on DNS Service Discovery, see http://www.dns-sd.org/
For information on how to use the Multicast DNS and the DNS Service Discovery APIs on Mac OS
X and other platforms, see http://developer.apple.com/bonjour/
For the source code to mdnsd, see http://developer.apple.com/darwin/projects/bonjour/
The mdnsd daemon first appeared in Mac OS X 10.2 (Jaguar).
Also available from the Darwin open source repository (though not officially supported by
Apple) are mdnsd daemons for other platforms, including Mac OS 9, Microsoft Windows, Linux,
FreeBSD, NetBSD, Solaris, and other POSIX systems.
mdnsd bugs are tracked in Apple Radar component "mDNSResponder".
BSD February 27, 2011 BSD